summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2016-04-18 15:42:25 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2016-04-18 15:42:25 +0200
commit5e208c86aa70a6de8549c5bf24c0dee905ebb0e6 (patch)
treecb92b0d7cb9fbfb68b691115c52099aa80de953b
downloadmeta-el-standard-5e208c86aa70a6de8549c5bf24c0dee905ebb0e6.tar.gz
Initialize layer
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--COPYING.MIT17
-rw-r--r--README61
-rw-r--r--conf/layer.conf14
3 files changed, 92 insertions, 0 deletions
diff --git a/COPYING.MIT b/COPYING.MIT
new file mode 100644
index 0000000..89de354
--- /dev/null
+++ b/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/README b/README
new file mode 100644
index 0000000..428f2b9
--- /dev/null
+++ b/README
@@ -0,0 +1,61 @@
1meta-el-standard
2===================================================================
3
4This layer contains distro customizations specific to the Enea Linux
5Standard profile releases.
6
7Dependencies
8============
9
10This layer depends on:
11
12 URI: git://git.yoctoproject.org/poky
13 branch: master
14
15 URI: git://git.enea.com/linux/meta-el-common
16 branch: master
17
18
19Source code
20===========
21
22git://git.enea.com/linux/meta-el-standard.git
23
24
25Patches
26=======
27
28Please submit any patches against the el-standard layer to the
29linux-maintainers mailing list: linux-maintainers@enea.com
30
31Maintainers: Enea Linux Team <linux-maintainers@enea.com>
32
33
34Table
35=================
36
37 I. Adding the el-standard layer to your build
38 II. Misc
39
40
41I. Adding the el-standard layer to your build
42=================================================
43
44In order to use this layer, you need to make the build system aware of
45it.
46
47Assuming the el-standard layer exists at the top-level of your
48yocto build tree, you can add it to the build system by adding the
49location of the el-standard layer to bblayers.conf, along with any
50other layers needed. e.g.:
51
52
53 BBLAYERS ?= " \
54 /path/to/yocto/meta \
55 /path/to/yocto/meta-poky \
56 /path/to/yocto/meta-el-common \
57 /path/to/yocto/meta-el-standard \
58 "
59
60II. Misc
61========
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..69d03c9
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,14 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/images/* \
7 ${LAYERDIR}/packagegroups/* \
8 ${LAYERDIR}/recipes-*/*/*.bbappend"
9
10BBFILE_COLLECTIONS += "el-standard"
11BBFILE_PATTERN_el-standard = "^${LAYERDIR}/"
12BBFILE_PRIORITY_el-standard = "7"
13LAYERDEPENDS_el-standard = "el-common"
14