summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2018-07-06 11:22:56 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2018-07-06 11:22:56 +0200
commit4f3f11e0b79d46a86634f6a9676333fead5e55bb (patch)
tree77124b68c140b0f1dab6080e0e05d4ab1c562a94
downloadmeta-el-rt-4f3f11e0b79d46a86634f6a9676333fead5e55bb.tar.gz
Initialize layer
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--COPYING.MIT17
-rw-r--r--README63
-rw-r--r--conf/layer.conf14
3 files changed, 94 insertions, 0 deletions
diff --git a/COPYING.MIT b/COPYING.MIT
new file mode 100644
index 0000000..89de354
--- /dev/null
+++ b/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/README b/README
new file mode 100644
index 0000000..c5bfd7c
--- /dev/null
+++ b/README
@@ -0,0 +1,63 @@
1meta-el-rt
2===================================================================
3
4This layer contains distro customizations specific to the Enea Linux
5Realtime profile releases.
6
7Dependencies
8============
9
10This layer depends on:
11
12 URI: git://git.yoctoproject.org/poky
13 branch: sumo
14
15 URI: git://git.enea.com/linux/meta-el-common
16 branch: sumo
17
18
19Source code
20===========
21
22git://git.enea.com/linux/meta-el-rt.git
23
24
25Patches
26=======
27
28Please submit any patches against the el-standard layer to the
29following mailing list: linux@lists.enea.com
30
31Maintainers:
32Adrian Dudau <adrian.dudau@enea.com>
33Martin Borg <martin.borg@enea.com>
34
35
36Table
37=================
38
39 I. Adding the el-rt layer to your build
40 II. Misc
41
42
43I. Adding the el-rt layer to your build
44=================================================
45
46In order to use this layer, you need to make the build system aware of
47it.
48
49Assuming the el-rt layer exists at the top-level of your
50yocto build tree, you can add it to the build system by adding the
51location of the el-rt layer to bblayers.conf, along with any
52other layers needed. e.g.:
53
54
55 BBLAYERS ?= " \
56 /path/to/yocto/meta \
57 /path/to/yocto/meta-poky \
58 /path/to/yocto/meta-el-common \
59 /path/to/yocto/meta-el-rt \
60 "
61
62II. Misc
63========
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..1804666
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,14 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/images/* \
7 ${LAYERDIR}/packagegroups/* \
8 ${LAYERDIR}/recipes-*/*/*.bbappend"
9
10BBFILE_COLLECTIONS += "el-rt"
11BBFILE_PATTERN_el-rt = "^${LAYERDIR}/"
12BBFILE_PRIORITY_el-rt = "7"
13LAYERDEPENDS_el-rt = "el-common"
14