summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/template.atom-c3000/bblayers.conf.sample1
-rw-r--r--conf/template.atom-c3000/local.conf.sample10
-rw-r--r--conf/template.xeon-d/bblayers.conf.sample1
-rw-r--r--conf/template.xeon-d/local.conf.sample10
-rw-r--r--images/core-image-minimal-initramfs.bbappend4
-rw-r--r--images/enea-nfv-access-host-common.inc7
6 files changed, 33 insertions, 0 deletions
diff --git a/conf/template.atom-c3000/bblayers.conf.sample b/conf/template.atom-c3000/bblayers.conf.sample
index 4f47b72..fbd6b42 100644
--- a/conf/template.atom-c3000/bblayers.conf.sample
+++ b/conf/template.atom-c3000/bblayers.conf.sample
@@ -24,4 +24,5 @@ BBLAYERS ?= " \
24 ##OEROOT##/meta-cloud-services \ 24 ##OEROOT##/meta-cloud-services \
25 ##OEROOT##/meta-cloud-services/meta-openstack \ 25 ##OEROOT##/meta-cloud-services/meta-openstack \
26 ##OEROOT##/meta-java \ 26 ##OEROOT##/meta-java \
27 ##OEROOT##/meta-updater \
27 " 28 "
diff --git a/conf/template.atom-c3000/local.conf.sample b/conf/template.atom-c3000/local.conf.sample
index 38c9e8b..8c24e77 100644
--- a/conf/template.atom-c3000/local.conf.sample
+++ b/conf/template.atom-c3000/local.conf.sample
@@ -237,3 +237,13 @@ PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
237CONF_VERSION = "1" 237CONF_VERSION = "1"
238 238
239SKIP_META_VIRT_SANITY_CHECK = "1" 239SKIP_META_VIRT_SANITY_CHECK = "1"
240
241#
242# OSTree integration
243#
244
245SOTA_MACHINE ?= "${MACHINE}"
246
247DISTRO_FEATURES_append = " sota"
248DISTRO_FEATURES_NATIVE_append = " sota"
249INHERIT += " sota"
diff --git a/conf/template.xeon-d/bblayers.conf.sample b/conf/template.xeon-d/bblayers.conf.sample
index 4f47b72..fbd6b42 100644
--- a/conf/template.xeon-d/bblayers.conf.sample
+++ b/conf/template.xeon-d/bblayers.conf.sample
@@ -24,4 +24,5 @@ BBLAYERS ?= " \
24 ##OEROOT##/meta-cloud-services \ 24 ##OEROOT##/meta-cloud-services \
25 ##OEROOT##/meta-cloud-services/meta-openstack \ 25 ##OEROOT##/meta-cloud-services/meta-openstack \
26 ##OEROOT##/meta-java \ 26 ##OEROOT##/meta-java \
27 ##OEROOT##/meta-updater \
27 " 28 "
diff --git a/conf/template.xeon-d/local.conf.sample b/conf/template.xeon-d/local.conf.sample
index 00ad0f4..3b1063e 100644
--- a/conf/template.xeon-d/local.conf.sample
+++ b/conf/template.xeon-d/local.conf.sample
@@ -238,3 +238,13 @@ PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
238CONF_VERSION = "1" 238CONF_VERSION = "1"
239 239
240SKIP_META_VIRT_SANITY_CHECK = "1" 240SKIP_META_VIRT_SANITY_CHECK = "1"
241
242#
243# OSTree integration
244#
245
246SOTA_MACHINE ?= "${MACHINE}"
247
248DISTRO_FEATURES_append = " sota"
249DISTRO_FEATURES_NATIVE_append = " sota"
250INHERIT += " sota"
diff --git a/images/core-image-minimal-initramfs.bbappend b/images/core-image-minimal-initramfs.bbappend
index bdba015..2ca1d47 100644
--- a/images/core-image-minimal-initramfs.bbappend
+++ b/images/core-image-minimal-initramfs.bbappend
@@ -1 +1,5 @@
1PACKAGE_INSTALL += " nfv-installer kernel-modules" 1PACKAGE_INSTALL += " nfv-installer kernel-modules"
2
3# ostree-switchroot is used by the init script to switch root to the
4# ostree version specified in the kernel command line
5PACKAGE_INSTALL_append_sota = " ostree-switchroot"
diff --git a/images/enea-nfv-access-host-common.inc b/images/enea-nfv-access-host-common.inc
index 866fa99..83d7bd0 100644
--- a/images/enea-nfv-access-host-common.inc
+++ b/images/enea-nfv-access-host-common.inc
@@ -19,3 +19,10 @@ SYSLINUX_DEFAULT_CONSOLE_x86-64 = "console=tty0"
19GRUB_TIMEOUT_x86-64 = "10" 19GRUB_TIMEOUT_x86-64 = "10"
20# 10 - 1sec 20# 10 - 1sec
21SYSLINUX_TIMEOUT_x86-64 = "50" 21SYSLINUX_TIMEOUT_x86-64 = "50"
22
23# If building with sota enabled, build the otaimg before the hddimg, because
24# the hddimg needs it as a base image
25python __anonymous() {
26 if bb.utils.contains('DISTRO_FEATURES', 'sota', True, False, d):
27 d.appendVarFlag("do_bootimg", "depends", " %s:do_image_otaimg" % d.getVar("IMAGE_BASENAME", True))
28}