summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--images/core-image-minimal-initramfs.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/images/core-image-minimal-initramfs.bbappend b/images/core-image-minimal-initramfs.bbappend
index 2ca1d47..e743bb3 100644
--- a/images/core-image-minimal-initramfs.bbappend
+++ b/images/core-image-minimal-initramfs.bbappend
@@ -3,3 +3,13 @@ PACKAGE_INSTALL += " nfv-installer kernel-modules"
3# ostree-switchroot is used by the init script to switch root to the 3# ostree-switchroot is used by the init script to switch root to the
4# ostree version specified in the kernel command line 4# ostree version specified in the kernel command line
5PACKAGE_INSTALL_append_sota = " ostree-switchroot" 5PACKAGE_INSTALL_append_sota = " ostree-switchroot"
6
7create_enea_symlink() {
8 # enea image used in bare metal installation
9 cd ${DEPLOY_DIR_IMAGE}
10 ln -sf ${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.cpio.gz enea-image-minimal-initramfs-${MACHINE}.cpio.gz
11 cd -
12}
13
14IMAGE_POSTPROCESS_COMMAND_append += " create_enea_symlink;"
15