summaryrefslogtreecommitdiffstats
path: root/recipes-core/systemd/systemd_247.6.bbappend
diff options
context:
space:
mode:
authorMatei Valeanu <Matei.Valeanu@enea.com>2021-06-24 17:29:04 +0200
committerAlexandru Avadanii <Alexandru.Avadanii@enea.com>2021-06-30 06:35:36 +0200
commiteea99925d3bef32434653aa6c2fabe6de24be950 (patch)
tree758367825ddfa8eeb214d1531ad796e6d199081a /recipes-core/systemd/systemd_247.6.bbappend
parent7ede3bf0c747d741994e85230e8d9e529b33c9ab (diff)
downloadmeta-el-nfv-access-eea99925d3bef32434653aa6c2fabe6de24be950.tar.gz
Update UID/GID
New groups and users: -g - kvm: added by libvirt [2] -g - render: added by systemd, after boot-up introduced in [1] Removed groups and users: -g and u - systemd-resolve and systemd-network: both were only kept for backward compatibility, not needed anymore -g - lock: systemd_246.9.bb no longer adds it in GROUPADD_PARAM, unlike systemd version on 2.4.0-2 -g and u - polkitd: systemd_246.9.bb no longer adds polkit in PACKAGECONFIG -g and u - ntp: meta-enea-virtualization/recipes-enea/ntp-user-stub/\ ntp-user-stub_1.0.bb removed -g - netdev: dbus_1.12.20.bb no longer adds netdev in GROUPADD_PARAM Added systemd_246.9.bbappend to overwrite basic.conf.in and add 'render' using GROUPADD_PARAM at build-time instead on boot-time Add new groups/users in basic.conf.in using fixed ids, in sync with <layer>/files/{group,passwd} [1] https://github.com/systemd/systemd/commit/4e15a7343cb [2] https://git.yoctoproject.org/cgit/cgit.cgi/meta-virtualization/\ commit/recipes-extended/libvirt?h=gatesgarth&id=b5b5defc78ea03c8 Change-Id: If1768a544c53552bf2eff1d8051830975ae0ed2f Signed-off-by: Matei Valeanu <Matei.Valeanu@enea.com>
Diffstat (limited to 'recipes-core/systemd/systemd_247.6.bbappend')
-rw-r--r--recipes-core/systemd/systemd_247.6.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-core/systemd/systemd_247.6.bbappend b/recipes-core/systemd/systemd_247.6.bbappend
new file mode 100644
index 0000000..871da64
--- /dev/null
+++ b/recipes-core/systemd/systemd_247.6.bbappend
@@ -0,0 +1,19 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append_sota = " file://basic.conf.in"
4
5GROUPADD_PARAM_${PN}_append_sota = "; -r render"
6
7# systemd uses certain groups unless configured not to (e.g. journal logs are more
8# broadly available to the 'wheel' group unless told otherwise), while some resources
9# are using to the 'nobody' group. Configure systemd to:
10# - not use the 'wheel' group (journal access will be restriced to root user);
11# - use the proper group for 'nobody', which should have GID 65534 (for NFVA 'nogroup');
12EXTRA_OEMESON += " \
13 -Dwheel-group=false \
14 -Dnobody-group=nogroup \
15"
16
17do_configure_prepend_sota() {
18 cp ${WORKDIR}/basic.conf.in ${S}/sysusers.d/basic.conf.in
19}