summaryrefslogtreecommitdiffstats
path: root/recipes-core/systemd/systemd_247.6.bbappend
diff options
context:
space:
mode:
authorAlexandru Avadanii <Alexandru.Avadanii@enea.com>2021-07-14 22:45:52 +0200
committerAlexandru Avadanii <Alexandru.Avadanii@enea.com>2021-07-14 22:46:36 +0200
commit5a51cd396d0ef065a3e95fb9e90e424794dc6ec1 (patch)
tree1ec89e8a5bf697e018826ba30ebc79a225680c81 /recipes-core/systemd/systemd_247.6.bbappend
parente73962113957e3c83792e3273a071bec9ade6b38 (diff)
parenta56dcb5ce1ec5ea3c9f35c5a902efc03f7bb8118 (diff)
downloadmeta-el-nfv-access-5a51cd396d0ef065a3e95fb9e90e424794dc6ec1.tar.gz
Merge branch 'feature_CPDX-3405'
Change-Id: I1b1576f01045d4be17a18fe5f4a8fb612d38113a
Diffstat (limited to 'recipes-core/systemd/systemd_247.6.bbappend')
-rw-r--r--recipes-core/systemd/systemd_247.6.bbappend25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-core/systemd/systemd_247.6.bbappend b/recipes-core/systemd/systemd_247.6.bbappend
new file mode 100644
index 0000000..eb2b118
--- /dev/null
+++ b/recipes-core/systemd/systemd_247.6.bbappend
@@ -0,0 +1,25 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append_sota = " file://basic.conf.in"
4
5GROUPADD_PARAM_${PN}_append_sota = "; -r render"
6
7# systemd uses certain groups unless configured not to (e.g. journal logs are more
8# broadly available to the 'wheel' group unless told otherwise), while some resources
9# are using to the 'nobody' group. Configure systemd to:
10# - not use the 'wheel' group (journal access will be restriced to root user);
11# - use the proper group for 'nobody', which should have GID 65534 (for NFVA 'nogroup');
12EXTRA_OEMESON += " \
13 -Dwheel-group=false \
14 -Dnobody-group=nogroup \
15"
16
17do_configure_prepend_sota() {
18 cp ${WORKDIR}/basic.conf.in ${S}/sysusers.d/basic.conf.in
19}
20
21do_install_append () {
22 # Update default udev rules for /dev/kvm to be less permissive
23 sed -e 's/\(KERNEL=="kvm".*\)0666/\10660/' \
24 -i ${D}${rootlibexecdir}/udev/rules.d/50-udev-default.rules
25}