summaryrefslogtreecommitdiffstats
path: root/images
diff options
context:
space:
mode:
authorAdrian Stratulat <adrian.stratulat@enea.com>2020-06-16 08:30:23 +0200
committerAdrian Stratulat <adrian.stratulat@enea.com>2020-07-13 04:22:55 +0200
commitc82336bb19d4a6462af8d00366118704aa73239e (patch)
tree71bdb688cf957e3066a8500b965b59ee95573fa4 /images
parentde9614aad1d7da8204cfe2da9c2006ea757fc106 (diff)
downloadmeta-el-nfv-access-c82336bb19d4a6462af8d00366118704aa73239e.tar.gz
Ampere/aarch64 bring-up changes
* Refactor the efi-secure-boot feature (in order for it to be disabled for certain targets) * Add support for emag8180 compilation target (used as Enea NFV Access host) * Add emag8180 support in ostree * Add support for qemuarm64 compilation target (used as Enea NFV Access VNF) Note: The aarch64 family does not support the secure-boot feature yet, so the "efi-secure-boot" has been disabled. Change-Id: I32336761d322102a07d065c9ab02ea5051854609 Signed-off-by: Adrian Stratulat <adrian.stratulat@enea.com>
Diffstat (limited to 'images')
-rw-r--r--images/enea-nfv-access-host-common.inc15
-rw-r--r--images/enea-nfv-access-vnf.bb1
-rw-r--r--images/enea-nfv-access.bb11
3 files changed, 26 insertions, 1 deletions
diff --git a/images/enea-nfv-access-host-common.inc b/images/enea-nfv-access-host-common.inc
index 1cde827..370a3a8 100644
--- a/images/enea-nfv-access-host-common.inc
+++ b/images/enea-nfv-access-host-common.inc
@@ -2,9 +2,15 @@ REQUIRE_FILES = " \
2 images/enea-nfv-access-common.inc \ 2 images/enea-nfv-access-common.inc \
3 classes/override_grub-efi.inc \ 3 classes/override_grub-efi.inc \
4 " 4 "
5REQUIRE_FILES_append_df-efi-secure-boot = " \ 5
6# override_image_types_ostree - has some secure-boot changes
7# but we guarded them
8REQUIRE_FILES_append_sota = " \
6 classes/override_image_types_ostree.inc \ 9 classes/override_image_types_ostree.inc \
7 classes/override_image_types_ota.inc \ 10 classes/override_image_types_ota.inc \
11 "
12
13REQUIRE_FILES_append_df-efi-secure-boot = " \
8 classes/override_grub-efi_secureboot.inc \ 14 classes/override_grub-efi_secureboot.inc \
9 images/secure-boot.inc \ 15 images/secure-boot.inc \
10 " 16 "
@@ -20,14 +26,21 @@ IMAGE_INSTALL += " \
20LABELS_LIVE = "installer live-boot" 26LABELS_LIVE = "installer live-boot"
21 27
22GRUB_GFXSERIAL_x86-64 = "1" 28GRUB_GFXSERIAL_x86-64 = "1"
29GRUB_GFXSERIAL_aarch64 = "1"
30GRUB_SERIAL_aarch64 = "console=ttyAMA0,115200"
31
23# Append default parameters for x86-64 targets 32# Append default parameters for x86-64 targets
24APPEND_x86-64 = "quiet" 33APPEND_x86-64 = "quiet"
25SYSLINUX_DEFAULT_CONSOLE_x86-64 = "console=ttyS0,115200" 34SYSLINUX_DEFAULT_CONSOLE_x86-64 = "console=ttyS0,115200"
26 35
36APPEND_aarch64 = "quiet"
37
27# Skip menu and boot installer immediately 38# Skip menu and boot installer immediately
28GRUB_TIMEOUT_x86-64 = "0" 39GRUB_TIMEOUT_x86-64 = "0"
29AUTO_SYSLINUXMENU_x86-64 = "0" 40AUTO_SYSLINUXMENU_x86-64 = "0"
30 41
42GRUB_TIMEOUT_aarch64 = "5"
43
31# grub-efi-native is needed in recipe-sysroot-native to generate the initial 44# grub-efi-native is needed in recipe-sysroot-native to generate the initial
32# configuration file for grub 45# configuration file for grub
33DEPENDS_append += " grub-efi-native" 46DEPENDS_append += " grub-efi-native"
diff --git a/images/enea-nfv-access-vnf.bb b/images/enea-nfv-access-vnf.bb
index a3902c2..ebbb08d 100644
--- a/images/enea-nfv-access-vnf.bb
+++ b/images/enea-nfv-access-vnf.bb
@@ -4,6 +4,7 @@ require images/enea-nfv-access-common.inc
4 4
5IMAGE_FSTYPES += "wic.qcow2" 5IMAGE_FSTYPES += "wic.qcow2"
6WKS_FILE = "enea-nfv-access-vnf-qemux86-64.wks" 6WKS_FILE = "enea-nfv-access-vnf-qemux86-64.wks"
7WKS_FILE_aarch64 = "enea-nfv-access-vnf-qemuarm64.wks"
7 8
8CLOUDINITPKGS = "cloud-init util-linux-blkid" 9CLOUDINITPKGS = "cloud-init util-linux-blkid"
9CLOUDINITPKGS += " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'cloud-init-systemd', '', d)}" 10CLOUDINITPKGS += " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'cloud-init-systemd', '', d)}"
diff --git a/images/enea-nfv-access.bb b/images/enea-nfv-access.bb
index 9311992..845e668 100644
--- a/images/enea-nfv-access.bb
+++ b/images/enea-nfv-access.bb
@@ -1,7 +1,18 @@
1DESCRIPTION = "Image for the host side of the Enea NFV Access Platform with ODM and NETCONF Edgelink customizations" 1DESCRIPTION = "Image for the host side of the Enea NFV Access Platform with ODM and NETCONF Edgelink customizations"
2 2
3IMAGE_FSTYPES_append_aarch64 = " live"
4IMAGE_TYPES_MASKED_append_aarch64 = " hddimg iso"
5NOISO_aarch64 = "1"
6NOHDD_aarch64 = "0"
7
3require images/enea-nfv-access-host-common.inc 8require images/enea-nfv-access-host-common.inc
4 9
5IMAGE_INSTALL += " \ 10IMAGE_INSTALL += " \
6 element-vcpe \ 11 element-vcpe \
7 " 12 "
13
14# On AARCH64, the OVMF firmware images are required by KVM, but these images are not
15# pulled explicitly by other recipes.
16IMAGE_INSTALL_append_aarch64 = "\
17 ovmf \
18 "