summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Wellving <andreas.wellving@enea.com>2020-08-28 06:22:33 +0200
committerAndreas Wellving <andreas.wellving@enea.com>2020-08-28 06:22:33 +0200
commit9f469b481144dfebef413bbb994c97b120a41c6a (patch)
treedc50b801ae613067194f7ccbee1b9bbba7d0e5ad
parent12622948f531f0fb044c945c34116a925546ae0a (diff)
downloadmeta-el-nfv-access-9f469b481144dfebef413bbb994c97b120a41c6a.tar.gz
Add debug images including gdb, gdbserver and oprofile
Change-Id: I2a103bd73f5daaea8357ff2c5094dc2dd7fdf193 Signed-off-by: Andreas Wellving <andreas.wellving@enea.com>
-rw-r--r--conf/template.atom-c3000-debug/bblayers.conf.sample31
-rw-r--r--conf/template.atom-c3000-debug/conf-notes.txt2
-rw-r--r--conf/template.atom-c3000-debug/local.conf.sample252
-rw-r--r--conf/template.xeon-d-debug/bblayers.conf.sample31
-rw-r--r--conf/template.xeon-d-debug/conf-notes.txt2
-rw-r--r--conf/template.xeon-d-debug/local.conf.sample253
-rw-r--r--images/enea-nfv-access-debug.bb9
7 files changed, 580 insertions, 0 deletions
diff --git a/conf/template.atom-c3000-debug/bblayers.conf.sample b/conf/template.atom-c3000-debug/bblayers.conf.sample
new file mode 100644
index 0000000..71c77cc
--- /dev/null
+++ b/conf/template.atom-c3000-debug/bblayers.conf.sample
@@ -0,0 +1,31 @@
1# POKY_BBLAYERS_CONF_VERSION is increased each time build/conf/bblayers.conf
2# changes incompatibly
3POKY_BBLAYERS_CONF_VERSION = "2"
4
5BBPATH = "${TOPDIR}"
6BBFILES ?= ""
7
8BBLAYERS ?= " \
9 ##OEROOT##/meta \
10 ##OEROOT##/meta-poky \
11 ##OEROOT##/meta-intel \
12 ##OEROOT##/meta-dpdk \
13 ##OEROOT##/meta-nfv-access-bsp-common \
14 ##OEROOT##/meta-nfv-access-bsp-x86 \
15 ##OEROOT##/meta-virtualization \
16 ##OEROOT##/meta-enea-virtualization \
17 ##OEROOT##/meta-nfv-access-common \
18 ##OEROOT##/meta-el-nfv-access \
19 ##OEROOT##/meta-openembedded/meta-oe \
20 ##OEROOT##/meta-openembedded/meta-networking \
21 ##OEROOT##/meta-openembedded/meta-filesystems \
22 ##OEROOT##/meta-openembedded/meta-python \
23 ##OEROOT##/meta-openembedded/meta-webserver \
24 ##OEROOT##/meta-java \
25 ##OEROOT##/meta-updater \
26 ##OEROOT##/meta-openembedded/meta-perl \
27 ##OEROOT##/meta-secure-core/meta \
28 ##OEROOT##/meta-secure-core/meta-signing-key \
29 ##OEROOT##/meta-secure-core/meta-efi-secure-boot \
30 ##OEROOT##/meta-enea-user-keys \
31 "
diff --git a/conf/template.atom-c3000-debug/conf-notes.txt b/conf/template.atom-c3000-debug/conf-notes.txt
new file mode 100644
index 0000000..1c1c026
--- /dev/null
+++ b/conf/template.atom-c3000-debug/conf-notes.txt
@@ -0,0 +1,2 @@
1Common targets are:
2 enea-nfv-access-debug
diff --git a/conf/template.atom-c3000-debug/local.conf.sample b/conf/template.atom-c3000-debug/local.conf.sample
new file mode 100644
index 0000000..c749b24
--- /dev/null
+++ b/conf/template.atom-c3000-debug/local.conf.sample
@@ -0,0 +1,252 @@
1#
2# This file is your local configuration file and is where all local user settings
3# are placed. The comments in this file give some guide to the options a new user
4# to the system might want to change but pretty much any configuration option can
5# be set in this file. More adventurous users can look at local.conf.extended
6# which contains other examples of configuration which can be placed in this file
7# but new users likely won't need any of them initially.
8#
9# Lines starting with the '#' character are commented out and in some cases the
10# default values are provided as comments to show people example syntax. Enabling
11# the option is a question of removing the # character and making any change to the
12# variable as required.
13
14#
15# Machine Selection
16#
17# You need to select a specific machine to target the build with. There are a selection
18# of emulated machines available which can boot and run in the QEMU emulator:
19#
20#MACHINE ?= "qemuarm"
21#MACHINE ?= "qemuarm64"
22#MACHINE ?= "qemumips"
23#MACHINE ?= "qemumips64"
24#MACHINE ?= "qemuppc"
25#MACHINE ?= "qemux86"
26#MACHINE ?= "qemux86-64"
27#
28# There are also the following hardware board target machines included for
29# demonstration purposes:
30#
31#MACHINE ?= "beaglebone"
32#MACHINE ?= "genericx86"
33#MACHINE ?= "genericx86-64"
34#MACHINE ?= "mpc8315e-rdb"
35#MACHINE ?= "edgerouter"
36#
37# This sets the default machine to be qemux86 if no other machine is selected:
38MACHINE ?= "atom-c3000"
39
40#
41# Where to place downloads
42#
43# During a first build the system will download many different source code tarballs
44# from various upstream projects. This can take a while, particularly if your network
45# connection is slow. These are all stored in DL_DIR. When wiping and rebuilding you
46# can preserve this directory to speed up this part of subsequent builds. This directory
47# is safe to share between multiple builds on the same machine too.
48#
49# The default is a downloads directory under TOPDIR which is the build directory.
50#
51#DL_DIR ?= "${TOPDIR}/downloads"
52
53#
54# Where to place shared-state files
55#
56# BitBake has the capability to accelerate builds based on previously built output.
57# This is done using "shared state" files which can be thought of as cache objects
58# and this option determines where those files are placed.
59#
60# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
61# from these files if no changes were made to the configuration. If changes were made
62# to the configuration, only shared state files where the state was still valid would
63# be used (done using checksums).
64#
65# The default is a sstate-cache directory under TOPDIR.
66#
67#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
68
69#
70# Where to place the build output
71#
72# This option specifies where the bulk of the building work should be done and
73# where BitBake should place its temporary files and output. Keep in mind that
74# this includes the extraction and compilation of many applications and the toolchain
75# which can use Gigabytes of hard disk space.
76#
77# The default is a tmp directory under TOPDIR.
78#
79#TMPDIR = "${TOPDIR}/tmp"
80
81#
82# Default policy config
83#
84# The distribution setting controls which policy settings are used as defaults.
85# The default value is fine for general Yocto project use, at least initially.
86# Ultimately when creating custom policy, people will likely end up subclassing
87# these defaults.
88#
89DISTRO ?= "eneanfvaccess"
90# As an example of a subclass there is a "bleeding" edge policy configuration
91# where many versions are set to the absolute latest code from the upstream
92# source control systems. This is just mentioned here as an example, its not
93# useful to most new users.
94# DISTRO ?= "poky-bleeding"
95
96#
97# Package Management configuration
98#
99# This variable lists which packaging formats to enable. Multiple package backends
100# can be enabled at once and the first item listed in the variable will be used
101# to generate the root filesystems.
102# Options are:
103# - 'package_deb' for debian style deb files
104# - 'package_ipk' for ipk files are used by opkg (a debian style embedded package manager)
105# - 'package_rpm' for rpm style packages
106# E.g.: PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
107# We default to rpm:
108PACKAGE_CLASSES ?= "package_deb"
109
110#
111# SDK/ADT target architecture
112#
113# This variable specifies the architecture to build SDK/ADT items for and means
114# you can build the SDK packages for architectures other than the machine you are
115# running the build on (i.e. building i686 packages on an x86_64 host).
116# Supported values are i686 and x86_64
117#SDKMACHINE ?= "i686"
118
119#
120# Extra image configuration defaults
121#
122# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
123# images. Some of these options are added to certain image types automatically. The
124# variable can contain the following options:
125# "dbg-pkgs" - add -dbg packages for all installed packages
126# (adds symbol information for debugging/profiling)
127# "dev-pkgs" - add -dev packages for all installed packages
128# (useful if you want to develop against libs in the image)
129# "ptest-pkgs" - add -ptest packages for all ptest-enabled packages
130# (useful if you want to run the package test suites)
131# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
132# "tools-debug" - add debugging tools (gdb, strace)
133# "eclipse-debug" - add Eclipse remote debugging support
134# "tools-profile" - add profiling tools (oprofile, lttng, valgrind)
135# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
136# "debug-tweaks" - make an image suitable for development
137# e.g. ssh root access has a blank password
138# There are other application targets that can be used here too, see
139# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
140# We default to enabling the debugging tweaks.
141EXTRA_IMAGE_FEATURES = " \
142 tools-debug \
143 debug-tweaks \
144 "
145
146#
147# Additional image features
148#
149# The following is a list of additional classes to use when building images which
150# enable extra features. Some available options which can be included in this variable
151# are:
152# - 'buildstats' collect build statistics
153# - 'image-mklibs' to reduce shared library files size for an image
154# - 'image-prelink' in order to prelink the filesystem image
155# - 'image-swab' to perform host system intrusion detection
156# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
157# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
158USER_CLASSES ?= "buildstats image-mklibs image-prelink"
159
160#
161# Runtime testing of images
162#
163# The build system can test booting virtual machine images under qemu (an emulator)
164# after any root filesystems are created and run tests against those images. To
165# enable this uncomment this line. See classes/testimage(-auto).bbclass for
166# further details.
167#TEST_IMAGE = "1"
168#
169# Interactive shell configuration
170#
171# Under certain circumstances the system may need input from you and to do this it
172# can launch an interactive shell. It needs to do this since the build is
173# multithreaded and needs to be able to handle the case where more than one parallel
174# process may require the user's attention. The default is iterate over the available
175# terminal types to find one that works.
176#
177# Examples of the occasions this may happen are when resolving patches which cannot
178# be applied, to use the devshell or the kernel menuconfig
179#
180# Supported values are auto, gnome, xfce, rxvt, screen, konsole (KDE 3.x only), none
181# Note: currently, Konsole support only works for KDE 3.x due to the way
182# newer Konsole versions behave
183#OE_TERMINAL = "auto"
184# By default disable interactive patch resolution (tasks will just fail instead):
185PATCHRESOLVE = "noop"
186
187#
188# Disk Space Monitoring during the build
189#
190# Monitor the disk space during the build. If there is less that 1GB of space or less
191# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
192# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
193# of the build. The reason for this is that running completely out of space can corrupt
194# files and damages the build in ways which may not be easily recoverable.
195# It's necesary to monitor /tmp, if there is no space left the build will fail
196# with very exotic errors.
197BB_DISKMON_DIRS = "\
198 STOPTASKS,${TMPDIR},1G,100K \
199 STOPTASKS,${DL_DIR},1G,100K \
200 STOPTASKS,${SSTATE_DIR},1G,100K \
201 STOPTASKS,/tmp,100M,100K \
202 ABORT,${TMPDIR},100M,1K \
203 ABORT,${DL_DIR},100M,1K \
204 ABORT,${SSTATE_DIR},100M,1K \
205 ABORT,/tmp,10M,1K"
206
207#
208# Shared-state files from other locations
209#
210# As mentioned above, shared state files are prebuilt cache data objects which can
211# used to accelerate build time. This variable can be used to configure the system
212# to search other mirror locations for these objects before it builds the data itself.
213#
214# This can be a filesystem directory, or a remote url such as http or ftp. These
215# would contain the sstate-cache results from previous builds (possibly from other
216# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
217# cache locations to check for the shared objects.
218# NOTE: if the mirror uses the same structure as SSTATE_DIR, you need to add PATH
219# at the end as shown in the examples below. This will be substituted with the
220# correct path within the directory structure.
221#SSTATE_MIRRORS ?= "\
222#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \
223#file://.* file:///some/local/dir/sstate/PATH"
224
225
226#
227# Qemu configuration
228#
229# By default qemu will build with a builtin VNC server where graphical output can be
230# seen. The two lines below enable the SDL backend too. By default libsdl-native will
231# be built, if you want to use your host's libSDL instead of the minimal libsdl built
232# by libsdl-native then uncomment the ASSUME_PROVIDED line below.
233PACKAGECONFIG_append_pn-qemu-native = " sdl"
234PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
235#ASSUME_PROVIDED += "libsdl-native"
236
237# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
238# track the version of this file when it was generated. This can safely be ignored if
239# this doesn't mean anything to you.
240CONF_VERSION = "1"
241
242SKIP_META_VIRT_SANITY_CHECK = "1"
243
244#
245# OSTree integration
246#
247
248SOTA_MACHINE ?= "${MACHINE}"
249
250DISTRO_FEATURES_append = " sota"
251DISTRO_FEATURES_NATIVE_append = " sota"
252INHERIT += " sota"
diff --git a/conf/template.xeon-d-debug/bblayers.conf.sample b/conf/template.xeon-d-debug/bblayers.conf.sample
new file mode 100644
index 0000000..71c77cc
--- /dev/null
+++ b/conf/template.xeon-d-debug/bblayers.conf.sample
@@ -0,0 +1,31 @@
1# POKY_BBLAYERS_CONF_VERSION is increased each time build/conf/bblayers.conf
2# changes incompatibly
3POKY_BBLAYERS_CONF_VERSION = "2"
4
5BBPATH = "${TOPDIR}"
6BBFILES ?= ""
7
8BBLAYERS ?= " \
9 ##OEROOT##/meta \
10 ##OEROOT##/meta-poky \
11 ##OEROOT##/meta-intel \
12 ##OEROOT##/meta-dpdk \
13 ##OEROOT##/meta-nfv-access-bsp-common \
14 ##OEROOT##/meta-nfv-access-bsp-x86 \
15 ##OEROOT##/meta-virtualization \
16 ##OEROOT##/meta-enea-virtualization \
17 ##OEROOT##/meta-nfv-access-common \
18 ##OEROOT##/meta-el-nfv-access \
19 ##OEROOT##/meta-openembedded/meta-oe \
20 ##OEROOT##/meta-openembedded/meta-networking \
21 ##OEROOT##/meta-openembedded/meta-filesystems \
22 ##OEROOT##/meta-openembedded/meta-python \
23 ##OEROOT##/meta-openembedded/meta-webserver \
24 ##OEROOT##/meta-java \
25 ##OEROOT##/meta-updater \
26 ##OEROOT##/meta-openembedded/meta-perl \
27 ##OEROOT##/meta-secure-core/meta \
28 ##OEROOT##/meta-secure-core/meta-signing-key \
29 ##OEROOT##/meta-secure-core/meta-efi-secure-boot \
30 ##OEROOT##/meta-enea-user-keys \
31 "
diff --git a/conf/template.xeon-d-debug/conf-notes.txt b/conf/template.xeon-d-debug/conf-notes.txt
new file mode 100644
index 0000000..1c1c026
--- /dev/null
+++ b/conf/template.xeon-d-debug/conf-notes.txt
@@ -0,0 +1,2 @@
1Common targets are:
2 enea-nfv-access-debug
diff --git a/conf/template.xeon-d-debug/local.conf.sample b/conf/template.xeon-d-debug/local.conf.sample
new file mode 100644
index 0000000..e898db6
--- /dev/null
+++ b/conf/template.xeon-d-debug/local.conf.sample
@@ -0,0 +1,253 @@
1#
2# This file is your local configuration file and is where all local user settings
3# are placed. The comments in this file give some guide to the options a new user
4# to the system might want to change but pretty much any configuration option can
5# be set in this file. More adventurous users can look at local.conf.extended
6# which contains other examples of configuration which can be placed in this file
7# but new users likely won't need any of them initially.
8#
9# Lines starting with the '#' character are commented out and in some cases the
10# default values are provided as comments to show people example syntax. Enabling
11# the option is a question of removing the # character and making any change to the
12# variable as required.
13
14#
15# Machine Selection
16#
17# You need to select a specific machine to target the build with. There are a selection
18# of emulated machines available which can boot and run in the QEMU emulator:
19#
20#MACHINE ?= "qemuarm"
21#MACHINE ?= "qemuarm64"
22#MACHINE ?= "qemumips"
23#MACHINE ?= "qemumips64"
24#MACHINE ?= "qemuppc"
25#MACHINE ?= "qemux86"
26#MACHINE ?= "qemux86-64"
27#
28# There are also the following hardware board target machines included for
29# demonstration purposes:
30#
31#MACHINE ?= "beaglebone"
32#MACHINE ?= "genericx86"
33#MACHINE ?= "genericx86-64"
34#MACHINE ?= "mpc8315e-rdb"
35#MACHINE ?= "edgerouter"
36#
37# This sets the default machine to be qemux86 if no other machine is selected:
38MACHINE ?= "xeon-d"
39
40
41#
42# Where to place downloads
43#
44# During a first build the system will download many different source code tarballs
45# from various upstream projects. This can take a while, particularly if your network
46# connection is slow. These are all stored in DL_DIR. When wiping and rebuilding you
47# can preserve this directory to speed up this part of subsequent builds. This directory
48# is safe to share between multiple builds on the same machine too.
49#
50# The default is a downloads directory under TOPDIR which is the build directory.
51#
52#DL_DIR ?= "${TOPDIR}/downloads"
53
54#
55# Where to place shared-state files
56#
57# BitBake has the capability to accelerate builds based on previously built output.
58# This is done using "shared state" files which can be thought of as cache objects
59# and this option determines where those files are placed.
60#
61# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
62# from these files if no changes were made to the configuration. If changes were made
63# to the configuration, only shared state files where the state was still valid would
64# be used (done using checksums).
65#
66# The default is a sstate-cache directory under TOPDIR.
67#
68#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
69
70#
71# Where to place the build output
72#
73# This option specifies where the bulk of the building work should be done and
74# where BitBake should place its temporary files and output. Keep in mind that
75# this includes the extraction and compilation of many applications and the toolchain
76# which can use Gigabytes of hard disk space.
77#
78# The default is a tmp directory under TOPDIR.
79#
80#TMPDIR = "${TOPDIR}/tmp"
81
82#
83# Default policy config
84#
85# The distribution setting controls which policy settings are used as defaults.
86# The default value is fine for general Yocto project use, at least initially.
87# Ultimately when creating custom policy, people will likely end up subclassing
88# these defaults.
89#
90DISTRO ?= "eneanfvaccess"
91# As an example of a subclass there is a "bleeding" edge policy configuration
92# where many versions are set to the absolute latest code from the upstream
93# source control systems. This is just mentioned here as an example, its not
94# useful to most new users.
95# DISTRO ?= "poky-bleeding"
96
97#
98# Package Management configuration
99#
100# This variable lists which packaging formats to enable. Multiple package backends
101# can be enabled at once and the first item listed in the variable will be used
102# to generate the root filesystems.
103# Options are:
104# - 'package_deb' for debian style deb files
105# - 'package_ipk' for ipk files are used by opkg (a debian style embedded package manager)
106# - 'package_rpm' for rpm style packages
107# E.g.: PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
108# We default to rpm:
109PACKAGE_CLASSES ?= "package_deb"
110
111#
112# SDK/ADT target architecture
113#
114# This variable specifies the architecture to build SDK/ADT items for and means
115# you can build the SDK packages for architectures other than the machine you are
116# running the build on (i.e. building i686 packages on an x86_64 host).
117# Supported values are i686 and x86_64
118#SDKMACHINE ?= "i686"
119
120#
121# Extra image configuration defaults
122#
123# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
124# images. Some of these options are added to certain image types automatically. The
125# variable can contain the following options:
126# "dbg-pkgs" - add -dbg packages for all installed packages
127# (adds symbol information for debugging/profiling)
128# "dev-pkgs" - add -dev packages for all installed packages
129# (useful if you want to develop against libs in the image)
130# "ptest-pkgs" - add -ptest packages for all ptest-enabled packages
131# (useful if you want to run the package test suites)
132# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
133# "tools-debug" - add debugging tools (gdb, strace)
134# "eclipse-debug" - add Eclipse remote debugging support
135# "tools-profile" - add profiling tools (oprofile, lttng, valgrind)
136# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
137# "debug-tweaks" - make an image suitable for development
138# e.g. ssh root access has a blank password
139# There are other application targets that can be used here too, see
140# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
141# We default to enabling the debugging tweaks.
142EXTRA_IMAGE_FEATURES = " \
143 tools-debug \
144 debug-tweaks \
145 "
146
147#
148# Additional image features
149#
150# The following is a list of additional classes to use when building images which
151# enable extra features. Some available options which can be included in this variable
152# are:
153# - 'buildstats' collect build statistics
154# - 'image-mklibs' to reduce shared library files size for an image
155# - 'image-prelink' in order to prelink the filesystem image
156# - 'image-swab' to perform host system intrusion detection
157# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
158# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
159USER_CLASSES ?= "buildstats image-mklibs image-prelink"
160
161#
162# Runtime testing of images
163#
164# The build system can test booting virtual machine images under qemu (an emulator)
165# after any root filesystems are created and run tests against those images. To
166# enable this uncomment this line. See classes/testimage(-auto).bbclass for
167# further details.
168#TEST_IMAGE = "1"
169#
170# Interactive shell configuration
171#
172# Under certain circumstances the system may need input from you and to do this it
173# can launch an interactive shell. It needs to do this since the build is
174# multithreaded and needs to be able to handle the case where more than one parallel
175# process may require the user's attention. The default is iterate over the available
176# terminal types to find one that works.
177#
178# Examples of the occasions this may happen are when resolving patches which cannot
179# be applied, to use the devshell or the kernel menuconfig
180#
181# Supported values are auto, gnome, xfce, rxvt, screen, konsole (KDE 3.x only), none
182# Note: currently, Konsole support only works for KDE 3.x due to the way
183# newer Konsole versions behave
184#OE_TERMINAL = "auto"
185# By default disable interactive patch resolution (tasks will just fail instead):
186PATCHRESOLVE = "noop"
187
188#
189# Disk Space Monitoring during the build
190#
191# Monitor the disk space during the build. If there is less that 1GB of space or less
192# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
193# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
194# of the build. The reason for this is that running completely out of space can corrupt
195# files and damages the build in ways which may not be easily recoverable.
196# It's necesary to monitor /tmp, if there is no space left the build will fail
197# with very exotic errors.
198BB_DISKMON_DIRS = "\
199 STOPTASKS,${TMPDIR},1G,100K \
200 STOPTASKS,${DL_DIR},1G,100K \
201 STOPTASKS,${SSTATE_DIR},1G,100K \
202 STOPTASKS,/tmp,100M,100K \
203 ABORT,${TMPDIR},100M,1K \
204 ABORT,${DL_DIR},100M,1K \
205 ABORT,${SSTATE_DIR},100M,1K \
206 ABORT,/tmp,10M,1K"
207
208#
209# Shared-state files from other locations
210#
211# As mentioned above, shared state files are prebuilt cache data objects which can
212# used to accelerate build time. This variable can be used to configure the system
213# to search other mirror locations for these objects before it builds the data itself.
214#
215# This can be a filesystem directory, or a remote url such as http or ftp. These
216# would contain the sstate-cache results from previous builds (possibly from other
217# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
218# cache locations to check for the shared objects.
219# NOTE: if the mirror uses the same structure as SSTATE_DIR, you need to add PATH
220# at the end as shown in the examples below. This will be substituted with the
221# correct path within the directory structure.
222#SSTATE_MIRRORS ?= "\
223#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \
224#file://.* file:///some/local/dir/sstate/PATH"
225
226
227#
228# Qemu configuration
229#
230# By default qemu will build with a builtin VNC server where graphical output can be
231# seen. The two lines below enable the SDL backend too. By default libsdl-native will
232# be built, if you want to use your host's libSDL instead of the minimal libsdl built
233# by libsdl-native then uncomment the ASSUME_PROVIDED line below.
234PACKAGECONFIG_append_pn-qemu-native = " sdl"
235PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
236#ASSUME_PROVIDED += "libsdl-native"
237
238# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
239# track the version of this file when it was generated. This can safely be ignored if
240# this doesn't mean anything to you.
241CONF_VERSION = "1"
242
243SKIP_META_VIRT_SANITY_CHECK = "1"
244
245#
246# OSTree integration
247#
248
249SOTA_MACHINE ?= "${MACHINE}"
250
251DISTRO_FEATURES_append = " sota"
252DISTRO_FEATURES_NATIVE_append = " sota"
253INHERIT += " sota"
diff --git a/images/enea-nfv-access-debug.bb b/images/enea-nfv-access-debug.bb
new file mode 100644
index 0000000..63a2322
--- /dev/null
+++ b/images/enea-nfv-access-debug.bb
@@ -0,0 +1,9 @@
1DESCRIPTION = "Image for the host side of the Enea NFV Access Platform with ODM and NETCONF Edgelink customizations"
2
3require images/enea-nfv-access-host-common.inc
4
5IMAGE_INSTALL += " \
6 element-vcpe \
7 gdbserver \
8 oprofile \
9 "