summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/elfutils/elfutils
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/elfutils/elfutils')
-rw-r--r--recipes-devtools/elfutils/elfutils/add-ptest.patch23
-rw-r--r--recipes-devtools/elfutils/elfutils/avoid_parallel_tests.patch20
-rw-r--r--recipes-devtools/elfutils/elfutils/run-ptest3
3 files changed, 0 insertions, 46 deletions
diff --git a/recipes-devtools/elfutils/elfutils/add-ptest.patch b/recipes-devtools/elfutils/elfutils/add-ptest.patch
deleted file mode 100644
index 88f808d..0000000
--- a/recipes-devtools/elfutils/elfutils/add-ptest.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1Add 'install-ptest' rule.
2
3Signed-off-by: Mihaela Sendrea <mihaela.sendrea@enea.com>
4Upstream-status: Pending
5---
6diff -uNr a/tests/Makefile.am b/tests/Makefile.am
7--- a/tests/Makefile.am 2013-08-19 14:05:23.256292155 +0200
8+++ b/tests/Makefile.am 2013-08-19 15:49:16.084543591 +0200
9@@ -240,3 +240,14 @@
10 coverage:
11 -$(srcdir)/coverage.sh
12 endif
13+
14+install-ptest:
15+ @$(MKDIR_P) $(DESTDIR)/tests
16+ @$(MKDIR_P) $(DESTDIR)/src
17+ @install $(builddir)/*$(EXEEXT) $(DESTDIR)/tests
18+ @install $(srcdir)/*.sh $(DESTDIR)/tests
19+ @install $(builddir)/../src/*$(EXEEXT) $(DESTDIR)/src
20+ @cp $(builddir)/../Makefile $(DESTDIR)
21+ @sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/tests/Makefile
22+ @sed -i -e 's|$(srcdir)|.|' $(DESTDIR)/tests/Makefile
23+
diff --git a/recipes-devtools/elfutils/elfutils/avoid_parallel_tests.patch b/recipes-devtools/elfutils/elfutils/avoid_parallel_tests.patch
deleted file mode 100644
index 95afc54..0000000
--- a/recipes-devtools/elfutils/elfutils/avoid_parallel_tests.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1ptest needs buildtest-TESTS and runtest-TESTS targets.
2serial-tests is required to generate those targets.
3
4Signed-off-by: Alexandra Safta <alexandra.safta@enea.com>
5Signed-off-by: Tudor Florea <tudor.florea@enea.com>
6Signed-off-by: Martin Borg <martin.borg@enea.com>
7Upstream-Status: Inappropriate
8
9--- a/configure.ac 2015-10-15 15:16:57.000000000 +0200
10+++ b/configure.ac 2016-02-02 12:03:17.432986965 +0100
11
12@@ -26,7 +26,7 @@
13 AC_PREREQ(2.63) dnl Minimum Autoconf version required.
14
15 dnl We use GNU make extensions; automake 1.10 defaults to -Wportability.
16-AM_INIT_AUTOMAKE([gnits 1.11 -Wno-portability dist-bzip2 no-dist-gzip parallel-tests])
17+AM_INIT_AUTOMAKE([gnits 1.11 -Wno-portability dist-bzip2 no-dist-gzip serial-tests])
18 AM_MAINTAINER_MODE
19
20 AM_SILENT_RULES([yes])
diff --git a/recipes-devtools/elfutils/elfutils/run-ptest b/recipes-devtools/elfutils/elfutils/run-ptest
deleted file mode 100644
index 51ea6df..0000000
--- a/recipes-devtools/elfutils/elfutils/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3make -C tests -k runtest-TESTS