summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Mangeac <Adrian.Mangeac@enea.com>2019-07-31 08:38:07 +0200
committerAdrian Mangeac <Adrian.Mangeac@enea.com>2019-07-31 08:38:07 +0200
commitb48eab79bf5a5af3d1ee6182cf76f15196f171ec (patch)
treedc6b33e445e57d227ca15df8102a7d9d7baa8cda
parent7ad40131c72b099295bcf2995dd893864b7411b5 (diff)
downloadmeta-el-common-b48eab79bf5a5af3d1ee6182cf76f15196f171ec.tar.gz
Remove patches fixed in upstream
CVE-2016-6252 CVE-2018-13785 Change-Id: I4d016e267929d7df020ee86366a76b5723908705 Signed-off-by: Adrian Mangeac <Adrian.Mangeac@enea.com>
-rw-r--r--recipes-extended/shadow/shadow/CVE-2016-6252.patch48
-rw-r--r--recipes-extended/shadow/shadow_%.bbappend5
-rw-r--r--recipes-multimedia/libpng/libpng/CVE-2018-13785.patch40
-rw-r--r--recipes-multimedia/libpng/libpng_%.bbappend5
4 files changed, 0 insertions, 98 deletions
diff --git a/recipes-extended/shadow/shadow/CVE-2016-6252.patch b/recipes-extended/shadow/shadow/CVE-2016-6252.patch
deleted file mode 100644
index 6e05584..0000000
--- a/recipes-extended/shadow/shadow/CVE-2016-6252.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From 1d5a926cc2d6078d23a96222b1ef3e558724dad1 Mon Sep 17 00:00:00 2001
2From: Sebastian Krahmer <krahmer@suse.com>
3Date: Wed, 3 Aug 2016 11:51:07 -0500
4Subject: [PATCH] Simplify getulong
5
6Use strtoul to read an unsigned long, rather than reading
7a signed long long and casting it.
8
9https://bugzilla.suse.com/show_bug.cgi?id=979282
10
11CVE: CVE-2016-6252
12Upstream-Status: Backport [https://github.com/shadow-maint/shadow/commit/1d5a926cc2d6078d23a96222b1ef3e558724dad1]
13
14Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
15---
16 lib/getulong.c | 9 +++------
17 1 file changed, 3 insertions(+), 6 deletions(-)
18
19diff --git a/lib/getulong.c b/lib/getulong.c
20index 61579cae..08d2c1a8 100644
21--- a/lib/getulong.c
22+++ b/lib/getulong.c
23@@ -44,22 +44,19 @@
24 */
25 int getulong (const char *numstr, /*@out@*/unsigned long int *result)
26 {
27- long long int val;
28+ unsigned long int val;
29 char *endptr;
30
31 errno = 0;
32- val = strtoll (numstr, &endptr, 0);
33+ val = strtoul (numstr, &endptr, 0);
34 if ( ('\0' == *numstr)
35 || ('\0' != *endptr)
36 || (ERANGE == errno)
37- /*@+ignoresigns@*/
38- || (val != (unsigned long int)val)
39- /*@=ignoresigns@*/
40 ) {
41 return 0;
42 }
43
44- *result = (unsigned long int)val;
45+ *result = val;
46 return 1;
47 }
48
diff --git a/recipes-extended/shadow/shadow_%.bbappend b/recipes-extended/shadow/shadow_%.bbappend
deleted file mode 100644
index 4f04479..0000000
--- a/recipes-extended/shadow/shadow_%.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4SRC_URI += "file://CVE-2016-6252.patch \
5 "
diff --git a/recipes-multimedia/libpng/libpng/CVE-2018-13785.patch b/recipes-multimedia/libpng/libpng/CVE-2018-13785.patch
deleted file mode 100644
index 0d8aaf8..0000000
--- a/recipes-multimedia/libpng/libpng/CVE-2018-13785.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 8a05766cb74af05c04c53e6c9d60c13fc4d59bf2 Mon Sep 17 00:00:00 2001
2From: Cosmin Truta <ctruta@gmail.com>
3Date: Sun, 17 Jun 2018 22:56:29 -0400
4Subject: [PATCH] [libpng16] Fix the calculation of row_factor in
5 png_check_chunk_length
6
7(Bug report by Thuan Pham, SourceForge issue #278)
8
9CVE: CVE-2018-13785
10Upstream-Status: Backport
11
12Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
13---
14 pngrutil.c | 9 ++++++---
15 1 file changed, 6 insertions(+), 3 deletions(-)
16
17diff --git a/pngrutil.c b/pngrutil.c
18index 95571b5..5ba995a 100644
19--- a/pngrutil.c
20+++ b/pngrutil.c
21@@ -3167,10 +3167,13 @@ png_check_chunk_length(png_const_structrp png_ptr, const png_uint_32 length)
22 {
23 png_alloc_size_t idat_limit = PNG_UINT_31_MAX;
24 size_t row_factor =
25- (png_ptr->width * png_ptr->channels * (png_ptr->bit_depth > 8? 2: 1)
26- + 1 + (png_ptr->interlaced? 6: 0));
27+ (size_t)png_ptr->width
28+ * (size_t)png_ptr->channels
29+ * (png_ptr->bit_depth > 8? 2: 1)
30+ + 1
31+ + (png_ptr->interlaced? 6: 0);
32 if (png_ptr->height > PNG_UINT_32_MAX/row_factor)
33- idat_limit=PNG_UINT_31_MAX;
34+ idat_limit = PNG_UINT_31_MAX;
35 else
36 idat_limit = png_ptr->height * row_factor;
37 row_factor = row_factor > 32566? 32566 : row_factor;
38--
391.9.1
40
diff --git a/recipes-multimedia/libpng/libpng_%.bbappend b/recipes-multimedia/libpng/libpng_%.bbappend
deleted file mode 100644
index 948941d..0000000
--- a/recipes-multimedia/libpng/libpng_%.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4SRC_URI += "file://CVE-2018-13785.patch \
5 "