summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2017-11-23 14:42:39 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2017-11-24 15:06:10 +0100
commit9793975ed89d6ca38bdee19ac228bb65d87c9f09 (patch)
tree7b6f5dfe0fdd46369e04a3701c297d3d8f1bd46d
parent7fded7d7d61ab65530ec0bfd0a168d4a8afb322c (diff)
downloadmeta-el-common-9793975ed89d6ca38bdee19ac228bb65d87c9f09.tar.gz
libtasn1: Drop duplicate CVE patch
The patch is already applied in upstream poky/pyro. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-support/gnutls/libtasn1/CVE-2017-10790.patch63
-rw-r--r--recipes-support/gnutls/libtasn1_%.bbappend5
2 files changed, 0 insertions, 68 deletions
diff --git a/recipes-support/gnutls/libtasn1/CVE-2017-10790.patch b/recipes-support/gnutls/libtasn1/CVE-2017-10790.patch
deleted file mode 100644
index be84380..0000000
--- a/recipes-support/gnutls/libtasn1/CVE-2017-10790.patch
+++ /dev/null
@@ -1,63 +0,0 @@
1From d8d805e1f2e6799bb2dff4871a8598dc83088a39 Mon Sep 17 00:00:00 2001
2From: Nikos Mavrogiannopoulos <nmav@redhat.com>
3Date: Thu, 22 Jun 2017 16:31:37 +0200
4Subject: [PATCH] _asn1_check_identifier: safer access to values read
5
6Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
7
8http://git.savannah.gnu.org/gitweb/?p=libtasn1.git;a=commit;h=d8d805e1f2e6799bb2dff4871a8598dc83088a39
9Upstream-Status: Backport
10
11CVE: CVE-2017-10790
12
13Signed-off-by: Yue Tao <Yue.Tao@windriver.com>
14Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
15---
16 lib/parser_aux.c | 17 ++++++++++++-----
17 1 file changed, 12 insertions(+), 5 deletions(-)
18
19diff --git a/lib/parser_aux.c b/lib/parser_aux.c
20index 976ab38..786ea64 100644
21--- a/lib/parser_aux.c
22+++ b/lib/parser_aux.c
23@@ -955,7 +955,7 @@ _asn1_check_identifier (asn1_node node)
24 if (p2 == NULL)
25 {
26 if (p->value)
27- _asn1_strcpy (_asn1_identifierMissing, p->value);
28+ _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p->value);
29 else
30 _asn1_strcpy (_asn1_identifierMissing, "(null)");
31 return ASN1_IDENTIFIER_NOT_FOUND;
32@@ -968,9 +968,15 @@ _asn1_check_identifier (asn1_node node)
33 if (p2 && (type_field (p2->type) == ASN1_ETYPE_DEFAULT))
34 {
35 _asn1_str_cpy (name2, sizeof (name2), node->name);
36- _asn1_str_cat (name2, sizeof (name2), ".");
37- _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
38- _asn1_strcpy (_asn1_identifierMissing, p2->value);
39+ if (p2->value)
40+ {
41+ _asn1_str_cat (name2, sizeof (name2), ".");
42+ _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
43+ _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p2->value);
44+ }
45+ else
46+ _asn1_strcpy (_asn1_identifierMissing, "(null)");
47+
48 p2 = asn1_find_node (node, name2);
49 if (!p2 || (type_field (p2->type) != ASN1_ETYPE_OBJECT_ID) ||
50 !(p2->type & CONST_ASSIGN))
51@@ -990,7 +996,8 @@ _asn1_check_identifier (asn1_node node)
52 _asn1_str_cpy (name2, sizeof (name2), node->name);
53 _asn1_str_cat (name2, sizeof (name2), ".");
54 _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
55- _asn1_strcpy (_asn1_identifierMissing, p2->value);
56+ _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p2->value);
57+
58 p2 = asn1_find_node (node, name2);
59 if (!p2 || (type_field (p2->type) != ASN1_ETYPE_OBJECT_ID)
60 || !(p2->type & CONST_ASSIGN))
61--
621.7.9.5
63
diff --git a/recipes-support/gnutls/libtasn1_%.bbappend b/recipes-support/gnutls/libtasn1_%.bbappend
deleted file mode 100644
index 7ac7e24..0000000
--- a/recipes-support/gnutls/libtasn1_%.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4SRC_URI += "file://CVE-2017-10790.patch \
5 "