summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Ionescu <gabriel.ionescu@enea.com>2017-11-20 19:03:25 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2017-11-22 11:46:21 +0100
commit2c80876ac2a42928167ed5567dc803179485c815 (patch)
tree5722d5eb5d0e566e72fe6f117b4350c1410773e8
parent3f946c2e7ecd26f401b2c7de6d0937bc22872c19 (diff)
downloadmeta-el-common-2c80876ac2a42928167ed5567dc803179485c815.tar.gz
run-postinsts: Disable dpkg --configure for debs to fix boot lockup
When a board boots for the first time, it executes run-postinsts.service and dpkg-configure.service. Since both services run dpkg --configure, it sometimes results in locking up the login service. This patch disables the execution of dpkg --configure from run-postinsts by removing the deb keyword from the list of scanned packet types. Signed-off-by: Gabriel Ionescu <gabriel.ionescu@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend b/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend
new file mode 100644
index 0000000..37b648b
--- /dev/null
+++ b/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend
@@ -0,0 +1,7 @@
1
2# Don't run 'dpkg --configure' for debs, because it is already executed by a
3# service included in the dpkg recipe
4do_install_append() {
5 sed -i 's/backend_list="rpm deb ipk"/backend_list="rpm ipk"/' \
6 ${D}${sbindir}/run-postinsts
7}