summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDragos Motrea <Dragos.Motrea@enea.com>2017-07-17 14:21:32 +0200
committerAdrian Calianu <adrian.calianu@enea.com>2017-07-19 10:25:43 +0200
commite0b480da53093f8832a5d6b0a2fd083a9e99c7e8 (patch)
tree3fd6bd7d2d455cab31e4713aa93d7ac9e19c088d
parent4bf7d1abd0e8414a7f096864fa916e3cc705ac11 (diff)
downloadmeta-el-common-e0b480da53093f8832a5d6b0a2fd083a9e99c7e8.tar.gz
Upgraded to the latest rt-tools version
Added new recipe for the bitcalc tool. Removed list2mask recipe and updated the partrt and the count-ticks recipes. Signed-off-by: Dragos Motrea <Dragos.Motrea@enea.com> Signed-off-by: Adrian Calianu <adrian.calianu@enea.com>
-rw-r--r--recipes-core/packagegroups/packagegroup-enea-rt-tools.bb2
-rw-r--r--recipes-enea/bitcalc/bitcalc/0001-bitcalc-resolved-compilation-warnings.patch50
-rw-r--r--recipes-enea/bitcalc/bitcalc/0001-bitcalc-resolved-memory-leaks.patch43
-rw-r--r--recipes-enea/bitcalc/bitcalc_1.0.bb (renamed from recipes-enea/list2mask/list2mask_1.0.bb)18
-rw-r--r--recipes-enea/count-ticks/count-ticks_1.1.bb4
-rw-r--r--recipes-enea/list2mask/list2mask/run-ptest15
-rw-r--r--recipes-enea/partrt/partrt_1.1.bb6
7 files changed, 108 insertions, 30 deletions
diff --git a/recipes-core/packagegroups/packagegroup-enea-rt-tools.bb b/recipes-core/packagegroups/packagegroup-enea-rt-tools.bb
index ae26f42..9e15d8e 100644
--- a/recipes-core/packagegroups/packagegroup-enea-rt-tools.bb
+++ b/recipes-core/packagegroups/packagegroup-enea-rt-tools.bb
@@ -9,5 +9,5 @@ inherit packagegroup
9RDEPENDS_${PN} = " \ 9RDEPENDS_${PN} = " \
10 partrt \ 10 partrt \
11 count-ticks \ 11 count-ticks \
12 list2mask \ 12 bitcalc \
13 " 13 "
diff --git a/recipes-enea/bitcalc/bitcalc/0001-bitcalc-resolved-compilation-warnings.patch b/recipes-enea/bitcalc/bitcalc/0001-bitcalc-resolved-compilation-warnings.patch
new file mode 100644
index 0000000..d1410cd
--- /dev/null
+++ b/recipes-enea/bitcalc/bitcalc/0001-bitcalc-resolved-compilation-warnings.patch
@@ -0,0 +1,50 @@
1From 00f03f600f29323cc6fd1c0f484a06d31acfd51d Mon Sep 17 00:00:00 2001
2From: Dragos Motrea <Dragos.Motrea@enea.com>
3Date: Thu, 13 Jul 2017 13:55:42 +0200
4Subject: [rt-tools][LXCR-7892][PATCHv1 1/1] bitcalc: resolved compilation
5 warnings
6
7Two warnings resolved: functions which are candidates for 'pure' attribute and
8an uninitialized variable.
9
10Upstream-Status: Submitted
11
12Signed-off-by: Dragos Motrea <Dragos.Motrea@enea.com>
13---
14 bitcalc/src/bitcalc.c | 2 +-
15 bitcalc/src/bitmap.h | 4 ++--
16 2 files changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/bitcalc/src/bitcalc.c b/bitcalc/src/bitcalc.c
19index bae4c06..8a51628 100644
20--- a/bitcalc/src/bitcalc.c
21+++ b/bitcalc/src/bitcalc.c
22@@ -54,7 +54,7 @@ static size_t bitmap_stack_depth_max = 0;
23
24 static char *bitmap_str(const struct bitmap_t *set)
25 {
26- char *str;
27+ char *str = NULL;
28
29 switch (display_format) {
30 case format_mask:
31diff --git a/bitcalc/src/bitmap.h b/bitcalc/src/bitmap.h
32index 17fee3a..5022dac 100644
33--- a/bitcalc/src/bitmap.h
34+++ b/bitcalc/src/bitmap.h
35@@ -61,10 +61,10 @@ extern struct bitmap_t *bitmap_alloc_from_u32_list(const char *mlist);
36 */
37
38 /* Return 1 if bit is set in bit mask, 0 otherwise. */
39-extern int bitmap_isset(size_t bit, const struct bitmap_t *set);
40+extern int bitmap_isset(size_t bit, const struct bitmap_t *set) __attribute__((pure));
41
42 /* Return the number of bits set in bit mask. */
43-extern size_t bitmap_bit_count(const struct bitmap_t *set);
44+extern size_t bitmap_bit_count(const struct bitmap_t *set) __attribute__((pure));
45
46 /*
47 * Modify bitmap
48--
492.7.4
50
diff --git a/recipes-enea/bitcalc/bitcalc/0001-bitcalc-resolved-memory-leaks.patch b/recipes-enea/bitcalc/bitcalc/0001-bitcalc-resolved-memory-leaks.patch
new file mode 100644
index 0000000..39bda0b
--- /dev/null
+++ b/recipes-enea/bitcalc/bitcalc/0001-bitcalc-resolved-memory-leaks.patch
@@ -0,0 +1,43 @@
1From ca0eba026490d8ee29786f80725fb3077dd200a4 Mon Sep 17 00:00:00 2001
2From: Dragos Motrea <Dragos.Motrea@enea.com>
3Date: Mon, 17 Jul 2017 11:08:41 +0200
4Subject: [rt-tools][LXCR-7893][PATCHv3 1/1] bitcalc: resolved memory leaks
5
6Upstream-status: Submitted
7
8Signed-off-by: Dragos Motrea <Dragos.Motrea@enea.com>
9---
10Changes from v2:
11- added Upstream-Status
12****
13 bitcalc/src/bitcalc.c | 1 +
14 bitcalc/src/bitmap.c | 1 +
15 2 files changed, 2 insertions(+)
16
17diff --git a/bitcalc/src/bitcalc.c b/bitcalc/src/bitcalc.c
18index 8a51628..196d406 100644
19--- a/bitcalc/src/bitcalc.c
20+++ b/bitcalc/src/bitcalc.c
21@@ -487,6 +487,7 @@ int main(int argc, char *argv[])
22 char *const bitmap = bitmap_str(item);
23 printf("%s%s", first ? "" : " ", bitmap);
24 bitmap_free(item);
25+ free(bitmap);
26 first = 0;
27 }
28
29diff --git a/bitcalc/src/bitmap.c b/bitcalc/src/bitmap.c
30index 3c60d0b..c29d47c 100644
31--- a/bitcalc/src/bitmap.c
32+++ b/bitcalc/src/bitmap.c
33@@ -76,6 +76,7 @@ void bitmap_free(struct bitmap_t *set)
34 {
35 set->size_u32 = 0;
36 set->size_bits = 0;
37+ free(set->map);
38 free(set);
39 }
40
41--
422.7.4
43
diff --git a/recipes-enea/list2mask/list2mask_1.0.bb b/recipes-enea/bitcalc/bitcalc_1.0.bb
index d72bcda..e9c677a 100644
--- a/recipes-enea/list2mask/list2mask_1.0.bb
+++ b/recipes-enea/bitcalc/bitcalc_1.0.bb
@@ -4,22 +4,22 @@ SECTION = "utils"
4LICENSE = "BSD" 4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b52bab7a403562f36be803f11489f1a4" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=b52bab7a403562f36be803f11489f1a4"
6 6
7PR = "r1" 7PR = "r0"
8 8
9DEPENDS = "gcc-sanitizers"
9RDEPENDS_${PN} = "bash" 10RDEPENDS_${PN} = "bash"
10 11
12FILESEXTRAPATHS_append := "${THISDIR}/${PN}"
13
11SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ 14SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \
12 file://run-ptest \ 15 file://0001-bitcalc-resolved-compilation-warnings.patch \
16 file://0001-bitcalc-resolved-memory-leaks.patch \
13 " 17 "
14 18
15SRCREV = "db6eff03d80c04803fb146939c504b500e16fe2f" 19SRCREV = "9d4d1ce26b58ada516466c30e53c75c2961d6f0a"
16
17inherit ptest
18 20
19S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
20 22
21FILES_${PN} += "/bin/*" 23EXTRA_OEMAKE += "'DESTDIR=${D}/usr/bin'"
22 24
23do_install() { 25inherit pkgconfig cmake
24 install -D ${S}/install/bin/${PN} ${D}/usr/bin/${PN}
25}
diff --git a/recipes-enea/count-ticks/count-ticks_1.1.bb b/recipes-enea/count-ticks/count-ticks_1.1.bb
index caa6ed7..a33a0f9 100644
--- a/recipes-enea/count-ticks/count-ticks_1.1.bb
+++ b/recipes-enea/count-ticks/count-ticks_1.1.bb
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \
12 file://run-ptest \ 12 file://run-ptest \
13 " 13 "
14 14
15SRCREV = "0fa0a8e084fe68e77a1f0968f2fbfa993292ae9c" 15SRCREV = "9d4d1ce26b58ada516466c30e53c75c2961d6f0a"
16 16
17inherit ptest 17inherit ptest
18 18
@@ -21,5 +21,5 @@ S = "${WORKDIR}/git"
21FILES_${PN} += "/bin/*" 21FILES_${PN} += "/bin/*"
22 22
23do_install() { 23do_install() {
24 install -D ${S}/install/bin/count_ticks ${D}/usr/bin/count_ticks 24 install -D ${S}/count_ticks/count_ticks ${D}/usr/bin/count_ticks
25} 25}
diff --git a/recipes-enea/list2mask/list2mask/run-ptest b/recipes-enea/list2mask/list2mask/run-ptest
deleted file mode 100644
index 9eb6c2f..0000000
--- a/recipes-enea/list2mask/list2mask/run-ptest
+++ /dev/null
@@ -1,15 +0,0 @@
1#!/bin/sh -eu
2
3mask=$(list2mask --cpus 2-3,5,7-8)
4
5if [ $? -ne 0 ]; then
6 echo "FAIL: list2mask failed to execute"
7 exit
8fi
9
10if [ "$mask" != "1ac" ]; then
11 echo "FAIL: list2mask returns mask '$mask', expected '1ac'"
12 exit
13fi
14
15echo "PASS: list2mask"
diff --git a/recipes-enea/partrt/partrt_1.1.bb b/recipes-enea/partrt/partrt_1.1.bb
index 8113805..5c22e4a 100644
--- a/recipes-enea/partrt/partrt_1.1.bb
+++ b/recipes-enea/partrt/partrt_1.1.bb
@@ -11,7 +11,7 @@ SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \
11 file://run-ptest \ 11 file://run-ptest \
12 " 12 "
13 13
14SRCREV = "cbe36a4946a2b3bb4927ca3b8ac800111ae9ce49" 14SRCREV = "9d4d1ce26b58ada516466c30e53c75c2961d6f0a"
15 15
16inherit ptest 16inherit ptest
17 17
@@ -21,10 +21,10 @@ FILES_${PN} += "/bin/*"
21 21
22do_install() { 22do_install() {
23 install -d ${D}/usr/bin 23 install -d ${D}/usr/bin
24 install ${S}/install/bin/partrt ${D}/usr/bin 24 install ${S}/partrt/partrt ${D}/usr/bin
25} 25}
26 26
27do_install_ptest() { 27do_install_ptest() {
28 install ${S}/test/test_partition.py ${D}${PTEST_PATH} 28 install ${S}/partrt/test/test_partition.py ${D}${PTEST_PATH}
29 sed -i s/target/${MACHINE}/ ${D}${PTEST_PATH}/run-ptest 29 sed -i s/target/${MACHINE}/ ${D}${PTEST_PATH}/run-ptest
30} 30}