summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSona Sarmadi <sona.sarmadi@enea.com>2017-10-03 10:55:32 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2017-10-04 09:58:01 +0200
commit404efc06d1d42e6e56a51b8a703f2bcf653c1705 (patch)
treedf969ed52578eff816133d58a36563f469e8f5bb
parent3dc41a3a217bc5e6957742c8004683460f07fd84 (diff)
downloadmeta-el-common-404efc06d1d42e6e56a51b8a703f2bcf653c1705.tar.gz
libtasn1: CVE-2017-10790
The _asn1_check_identifier function in GNU Libtasn1 through 4.12 causes a NULL pointer dereference and crash when reading crafted input that triggers assignment of a NULL value within an asn1_node structure. It may lead to a remote denial of service attack. References: https://nvd.nist.gov/vuln/detail/CVE-2017-10790 http://git.savannah.gnu.org/gitweb/?p=libtasn1.git;a=commit; h=d8d805e1f2e6799bb2dff4871a8598dc83088a39 (From OE-Core rev: 6176151625c971de031e14c97601ffd75a29772f) (From OE-Core rev: 649f78102222ec156d490968c13d3222379a1956) Patch from: http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?h= pyro&id=cb4fd41504826905455a34d3cb85e952f4ed4991 Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-support/gnutls/libtasn1/CVE-2017-10790.patch63
-rw-r--r--recipes-support/gnutls/libtasn1_%.bbappend5
2 files changed, 68 insertions, 0 deletions
diff --git a/recipes-support/gnutls/libtasn1/CVE-2017-10790.patch b/recipes-support/gnutls/libtasn1/CVE-2017-10790.patch
new file mode 100644
index 0000000..be84380
--- /dev/null
+++ b/recipes-support/gnutls/libtasn1/CVE-2017-10790.patch
@@ -0,0 +1,63 @@
1From d8d805e1f2e6799bb2dff4871a8598dc83088a39 Mon Sep 17 00:00:00 2001
2From: Nikos Mavrogiannopoulos <nmav@redhat.com>
3Date: Thu, 22 Jun 2017 16:31:37 +0200
4Subject: [PATCH] _asn1_check_identifier: safer access to values read
5
6Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
7
8http://git.savannah.gnu.org/gitweb/?p=libtasn1.git;a=commit;h=d8d805e1f2e6799bb2dff4871a8598dc83088a39
9Upstream-Status: Backport
10
11CVE: CVE-2017-10790
12
13Signed-off-by: Yue Tao <Yue.Tao@windriver.com>
14Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
15---
16 lib/parser_aux.c | 17 ++++++++++++-----
17 1 file changed, 12 insertions(+), 5 deletions(-)
18
19diff --git a/lib/parser_aux.c b/lib/parser_aux.c
20index 976ab38..786ea64 100644
21--- a/lib/parser_aux.c
22+++ b/lib/parser_aux.c
23@@ -955,7 +955,7 @@ _asn1_check_identifier (asn1_node node)
24 if (p2 == NULL)
25 {
26 if (p->value)
27- _asn1_strcpy (_asn1_identifierMissing, p->value);
28+ _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p->value);
29 else
30 _asn1_strcpy (_asn1_identifierMissing, "(null)");
31 return ASN1_IDENTIFIER_NOT_FOUND;
32@@ -968,9 +968,15 @@ _asn1_check_identifier (asn1_node node)
33 if (p2 && (type_field (p2->type) == ASN1_ETYPE_DEFAULT))
34 {
35 _asn1_str_cpy (name2, sizeof (name2), node->name);
36- _asn1_str_cat (name2, sizeof (name2), ".");
37- _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
38- _asn1_strcpy (_asn1_identifierMissing, p2->value);
39+ if (p2->value)
40+ {
41+ _asn1_str_cat (name2, sizeof (name2), ".");
42+ _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
43+ _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p2->value);
44+ }
45+ else
46+ _asn1_strcpy (_asn1_identifierMissing, "(null)");
47+
48 p2 = asn1_find_node (node, name2);
49 if (!p2 || (type_field (p2->type) != ASN1_ETYPE_OBJECT_ID) ||
50 !(p2->type & CONST_ASSIGN))
51@@ -990,7 +996,8 @@ _asn1_check_identifier (asn1_node node)
52 _asn1_str_cpy (name2, sizeof (name2), node->name);
53 _asn1_str_cat (name2, sizeof (name2), ".");
54 _asn1_str_cat (name2, sizeof (name2), (char *) p2->value);
55- _asn1_strcpy (_asn1_identifierMissing, p2->value);
56+ _asn1_str_cpy (_asn1_identifierMissing, sizeof(_asn1_identifierMissing), (char*)p2->value);
57+
58 p2 = asn1_find_node (node, name2);
59 if (!p2 || (type_field (p2->type) != ASN1_ETYPE_OBJECT_ID)
60 || !(p2->type & CONST_ASSIGN))
61--
621.7.9.5
63
diff --git a/recipes-support/gnutls/libtasn1_%.bbappend b/recipes-support/gnutls/libtasn1_%.bbappend
new file mode 100644
index 0000000..7ac7e24
--- /dev/null
+++ b/recipes-support/gnutls/libtasn1_%.bbappend
@@ -0,0 +1,5 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4SRC_URI += "file://CVE-2017-10790.patch \
5 "