summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Ionescu <gabriel.ionescu@enea.com>2017-12-05 15:08:13 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2017-12-06 11:40:45 +0100
commit3864dfb7366dad8a823f417f920882b5896903dd (patch)
tree6b58b2a3b19cee27ec36ca86606570786ede22a4
parent0df8e030c3028584d32c3d25ec3d1430553b5deb (diff)
downloadmeta-el-common-pyro-nfvaccess.tar.gz
run-postinsts: don't call update-rc.d if systemd is presentpyro-nfvaccess
This patch removes the call to update-rc.d in order to fix the console login issue for the Cavium board. Signed-off-by: Gabriel Ionescu <gabriel.ionescu@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend15
1 files changed, 11 insertions, 4 deletions
diff --git a/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend b/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend
index 37b648b..c800e85 100644
--- a/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend
+++ b/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend
@@ -1,7 +1,14 @@
1 1
2# Don't run 'dpkg --configure' for debs, because it is already executed by a
3# service included in the dpkg recipe
4do_install_append() { 2do_install_append() {
5 sed -i 's/backend_list="rpm deb ipk"/backend_list="rpm ipk"/' \ 3 # Don't run 'dpkg --configure' for debs, because it is already executed by a
6 ${D}${sbindir}/run-postinsts 4 # service included in the dpkg recipe
5 if ${@bb.utils.contains('PACKAGE_CLASSES', 'package_deb', 'true', 'false', d)}; then
6 sed -i 's/backend_list="rpm deb ipk"/backend_list="rpm ipk"/' \
7 ${D}${sbindir}/run-postinsts
8 fi
9
10 # Don't call update-rc.d remove if systemd is present
11 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
12 sed -i "s/update-rc.d -f run-postinsts remove/:/" ${D}${sbindir}/run-postinsts
13 fi
7} 14}