summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSona Sarmadi <sona.sarmadi@enea.com>2016-09-26 12:18:19 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2016-09-26 12:49:29 +0200
commit8ac9ad185c0889af0bfb2fcd90a6987cb972eb0a (patch)
treec82b3353905debe6ea8ca2946294971e6e149e22
parentc95a5d22dedc5701d18e91e40a0c54802915187d (diff)
downloadmeta-el-common-8ac9ad185c0889af0bfb2fcd90a6987cb972eb0a.tar.gz
openssl: Security fix CVE-2016-6302
affects openssl < 1.0.2i Reference: https://www.openssl.org/news/secadv/20160922.txt Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-connectivity/openssl/openssl/CVE-2016-6302.patch53
-rw-r--r--recipes-connectivity/openssl/openssl_1.0.2h.bbappend1
2 files changed, 54 insertions, 0 deletions
diff --git a/recipes-connectivity/openssl/openssl/CVE-2016-6302.patch b/recipes-connectivity/openssl/openssl/CVE-2016-6302.patch
new file mode 100644
index 0000000..a72ee70
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl/CVE-2016-6302.patch
@@ -0,0 +1,53 @@
1From baaabfd8fdcec04a691695fad9a664bea43202b6 Mon Sep 17 00:00:00 2001
2From: "Dr. Stephen Henson" <steve@openssl.org>
3Date: Tue, 23 Aug 2016 18:14:54 +0100
4Subject: [PATCH] Sanity check ticket length.
5
6If a ticket callback changes the HMAC digest to SHA512 the existing
7sanity checks are not sufficient and an attacker could perform a DoS
8attack with a malformed ticket. Add additional checks based on
9HMAC size.
10
11Thanks to Shi Lei for reporting this bug.
12
13CVE-2016-6302
14
15Reviewed-by: Rich Salz <rsalz@openssl.org>
16
17Upstream-Status: Backport
18CVE: CVE-2016-6302
19Signed-off-by: Armin Kuster <akuster@mvista.com>
20
21---
22 ssl/t1_lib.c | 11 ++++++++---
23 1 file changed, 8 insertions(+), 3 deletions(-)
24
25Index: openssl-1.0.2h/ssl/t1_lib.c
26===================================================================
27--- openssl-1.0.2h.orig/ssl/t1_lib.c
28+++ openssl-1.0.2h/ssl/t1_lib.c
29@@ -3397,9 +3397,7 @@ static int tls_decrypt_ticket(SSL *s, co
30 HMAC_CTX hctx;
31 EVP_CIPHER_CTX ctx;
32 SSL_CTX *tctx = s->initial_ctx;
33- /* Need at least keyname + iv + some encrypted data */
34- if (eticklen < 48)
35- return 2;
36+
37 /* Initialize session ticket encryption and HMAC contexts */
38 HMAC_CTX_init(&hctx);
39 EVP_CIPHER_CTX_init(&ctx);
40@@ -3433,6 +3431,13 @@ static int tls_decrypt_ticket(SSL *s, co
41 if (mlen < 0) {
42 goto err;
43 }
44+ /* Sanity check ticket length: must exceed keyname + IV + HMAC */
45+ if (eticklen <= 16 + EVP_CIPHER_CTX_iv_length(&ctx) + mlen) {
46+ HMAC_CTX_cleanup(&hctx);
47+ EVP_CIPHER_CTX_cleanup(&ctx);
48+ return 2;
49+ }
50+
51 eticklen -= mlen;
52 /* Check HMAC of encrypted ticket */
53 if (HMAC_Update(&hctx, etick, eticklen) <= 0
diff --git a/recipes-connectivity/openssl/openssl_1.0.2h.bbappend b/recipes-connectivity/openssl/openssl_1.0.2h.bbappend
index eb369e4..e07690f 100644
--- a/recipes-connectivity/openssl/openssl_1.0.2h.bbappend
+++ b/recipes-connectivity/openssl/openssl_1.0.2h.bbappend
@@ -7,4 +7,5 @@ SRC_URI += "file://CVE-2016-2178.patch \
7 file://CVE-2016-2181_p2.patch \ 7 file://CVE-2016-2181_p2.patch \
8 file://CVE-2016-2181_p3.patch \ 8 file://CVE-2016-2181_p3.patch \
9 file://CVE-2016-2182.patch \ 9 file://CVE-2016-2182.patch \
10 file://CVE-2016-6302.patch \
10 " 11 "