summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSona Sarmadi <sona.sarmadi@enea.com>2016-09-26 12:18:20 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2016-09-26 12:49:29 +0200
commit744b01090f6cf4984c11bb682693647a62103644 (patch)
tree208be72fcded42cf6160f6d5c1905b8088ad4e84
parent8ac9ad185c0889af0bfb2fcd90a6987cb972eb0a (diff)
downloadmeta-el-common-744b01090f6cf4984c11bb682693647a62103644.tar.gz
openssl: Security fix CVE-2016-6303
affects openssl < 1.0.2i Reference: https://www.openssl.org/news/secadv/20160922.txt Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--recipes-connectivity/openssl/openssl/CVE-2016-6303.patch36
-rw-r--r--recipes-connectivity/openssl/openssl_1.0.2h.bbappend1
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-connectivity/openssl/openssl/CVE-2016-6303.patch b/recipes-connectivity/openssl/openssl/CVE-2016-6303.patch
new file mode 100644
index 0000000..95bdec4
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl/CVE-2016-6303.patch
@@ -0,0 +1,36 @@
1From 1027ad4f34c30b8585592764b9a670ba36888269 Mon Sep 17 00:00:00 2001
2From: "Dr. Stephen Henson" <steve@openssl.org>
3Date: Fri, 19 Aug 2016 23:28:29 +0100
4Subject: [PATCH] Avoid overflow in MDC2_Update()
5
6Thanks to Shi Lei for reporting this issue.
7
8CVE-2016-6303
9
10Reviewed-by: Matt Caswell <matt@openssl.org>
11(cherry picked from commit 55d83bf7c10c7b205fffa23fa7c3977491e56c07)
12
13Upstream-Status: Backport
14CVE: CVE-2016-6303
15Signed-off-by: Armin Kuster <akuster@mvista.com>
16
17---
18 crypto/mdc2/mdc2dgst.c | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/crypto/mdc2/mdc2dgst.c b/crypto/mdc2/mdc2dgst.c
22index 6615cf8..2dce493 100644
23--- a/crypto/mdc2/mdc2dgst.c
24+++ b/crypto/mdc2/mdc2dgst.c
25@@ -91,7 +91,7 @@ int MDC2_Update(MDC2_CTX *c, const unsigned char *in, size_t len)
26
27 i = c->num;
28 if (i != 0) {
29- if (i + len < MDC2_BLOCK) {
30+ if (len < MDC2_BLOCK - i) {
31 /* partial block */
32 memcpy(&(c->data[i]), in, len);
33 c->num += (int)len;
34--
352.7.4
36
diff --git a/recipes-connectivity/openssl/openssl_1.0.2h.bbappend b/recipes-connectivity/openssl/openssl_1.0.2h.bbappend
index e07690f..528a77c 100644
--- a/recipes-connectivity/openssl/openssl_1.0.2h.bbappend
+++ b/recipes-connectivity/openssl/openssl_1.0.2h.bbappend
@@ -8,4 +8,5 @@ SRC_URI += "file://CVE-2016-2178.patch \
8 file://CVE-2016-2181_p3.patch \ 8 file://CVE-2016-2181_p3.patch \
9 file://CVE-2016-2182.patch \ 9 file://CVE-2016-2182.patch \
10 file://CVE-2016-6302.patch \ 10 file://CVE-2016-6302.patch \
11 file://CVE-2016-6303.patch \
11 " 12 "