summaryrefslogtreecommitdiffstats
path: root/conf/template.zcu102-zynqmp/local.conf.sample
diff options
context:
space:
mode:
Diffstat (limited to 'conf/template.zcu102-zynqmp/local.conf.sample')
-rw-r--r--conf/template.zcu102-zynqmp/local.conf.sample250
1 files changed, 250 insertions, 0 deletions
diff --git a/conf/template.zcu102-zynqmp/local.conf.sample b/conf/template.zcu102-zynqmp/local.conf.sample
new file mode 100644
index 0000000..eed45b8
--- /dev/null
+++ b/conf/template.zcu102-zynqmp/local.conf.sample
@@ -0,0 +1,250 @@
1#
2# This file is your local configuration file and is where all local user settings
3# are placed. The comments in this file give some guide to the options a new user
4# to the system might want to change but pretty much any configuration option can
5# be set in this file. More adventurous users can look at local.conf.extended
6# which contains other examples of configuration which can be placed in this file
7# but new users likely won't need any of them initially.
8#
9# Lines starting with the '#' character are commented out and in some cases the
10# default values are provided as comments to show people example syntax. Enabling
11# the option is a question of removing the # character and making any change to the
12# variable as required.
13
14#
15# Machine Selection
16#
17# You need to select a specific machine to target the build with. There are a selection
18# of emulated machines available which can boot and run in the QEMU emulator:
19#
20#MACHINE ?= "qemuarm"
21#MACHINE ?= "qemuarm64"
22#MACHINE ?= "qemumips"
23#MACHINE ?= "qemumips64"
24#MACHINE ?= "qemuppc"
25#MACHINE ?= "qemux86"
26#MACHINE ?= "qemux86-64"
27#
28# There are also the following hardware board target machines included for
29# demonstration purposes:
30#
31#MACHINE ?= "beaglebone"
32#MACHINE ?= "genericx86"
33#MACHINE ?= "genericx86-64"
34#MACHINE ?= "mpc8315e-rdb"
35#MACHINE ?= "edgerouter"
36#
37# This sets the default machine to be qemux86 if no other machine is selected:
38MACHINE = "zcu102-zynqmp"
39TOOLCHAIN_TARGET_TASK_append = " kernel-devsrc"
40
41#
42# Where to place downloads
43#
44# During a first build the system will download many different source code tarballs
45# from various upstream projects. This can take a while, particularly if your network
46# connection is slow. These are all stored in DL_DIR. When wiping and rebuilding you
47# can preserve this directory to speed up this part of subsequent builds. This directory
48# is safe to share between multiple builds on the same machine too.
49#
50# The default is a downloads directory under TOPDIR which is the build directory.
51#
52#DL_DIR ?= "${TOPDIR}/downloads"
53
54#
55# Where to place shared-state files
56#
57# BitBake has the capability to accelerate builds based on previously built output.
58# This is done using "shared state" files which can be thought of as cache objects
59# and this option determines where those files are placed.
60#
61# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
62# from these files if no changes were made to the configuration. If changes were made
63# to the configuration, only shared state files where the state was still valid would
64# be used (done using checksums).
65#
66# The default is a sstate-cache directory under TOPDIR.
67#
68#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
69
70#
71# Where to place the build output
72#
73# This option specifies where the bulk of the building work should be done and
74# where BitBake should place its temporary files and output. Keep in mind that
75# this includes the extraction and compilation of many applications and the toolchain
76# which can use Gigabytes of hard disk space.
77#
78# The default is a tmp directory under TOPDIR.
79#
80#TMPDIR = "${TOPDIR}/tmp"
81
82#
83# Default policy config
84#
85# The distribution setting controls which policy settings are used as defaults.
86# The default value is fine for general Yocto project use, at least initially.
87# Ultimately when creating custom policy, people will likely end up subclassing
88# these defaults.
89#
90DISTRO = "enea"
91# As an example of a subclass there is a "bleeding" edge policy configuration
92# where many versions are set to the absolute latest code from the upstream
93# source control systems. This is just mentioned here as an example, its not
94# useful to most new users.
95# DISTRO ?= "poky-bleeding"
96
97#
98# Package Management configuration
99#
100# This variable lists which packaging formats to enable. Multiple package backends
101# can be enabled at once and the first item listed in the variable will be used
102# to generate the root filesystems.
103# Options are:
104# - 'package_deb' for debian style deb files
105# - 'package_ipk' for ipk files are used by opkg (a debian style embedded package manager)
106# - 'package_rpm' for rpm style packages
107# E.g.: PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
108# We default to rpm:
109PACKAGE_CLASSES = "package_rpm"
110
111#
112# SDK/ADT target architecture
113#
114# This variable specifies the architecture to build SDK/ADT items for and means
115# you can build the SDK packages for architectures other than the machine you are
116# running the build on (i.e. building i686 packages on an x86_64 host).
117# Supported values are i686 and x86_64
118#SDKMACHINE ?= "i686"
119
120#
121# Extra image configuration defaults
122#
123# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
124# images. Some of these options are added to certain image types automatically. The
125# variable can contain the following options:
126# "dbg-pkgs" - add -dbg packages for all installed packages
127# (adds symbol information for debugging/profiling)
128# "dev-pkgs" - add -dev packages for all installed packages
129# (useful if you want to develop against libs in the image)
130# "ptest-pkgs" - add -ptest packages for all ptest-enabled packages
131# (useful if you want to run the package test suites)
132# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
133# "tools-debug" - add debugging tools (gdb, strace)
134# "eclipse-debug" - add Eclipse remote debugging support
135# "tools-profile" - add profiling tools (oprofile, lttng, valgrind)
136# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
137# "debug-tweaks" - make an image suitable for development
138# e.g. ssh root access has a blank password
139# There are other application targets that can be used here too, see
140# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
141# We default to enabling the debugging tweaks.
142EXTRA_IMAGE_FEATURES = "debug-tweaks"
143
144#
145# Additional image features
146#
147# The following is a list of additional classes to use when building images which
148# enable extra features. Some available options which can be included in this variable
149# are:
150# - 'buildstats' collect build statistics
151# - 'image-mklibs' to reduce shared library files size for an image
152# - 'image-prelink' in order to prelink the filesystem image
153# - 'image-swab' to perform host system intrusion detection
154# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
155# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
156USER_CLASSES ?= "buildstats image-mklibs image-prelink"
157
158#
159# Runtime testing of images
160#
161# The build system can test booting virtual machine images under qemu (an emulator)
162# after any root filesystems are created and run tests against those images. To
163# enable this uncomment this line. See classes/testimage(-auto).bbclass for
164# further details.
165#TEST_IMAGE = "1"
166#
167# Interactive shell configuration
168#
169# Under certain circumstances the system may need input from you and to do this it
170# can launch an interactive shell. It needs to do this since the build is
171# multithreaded and needs to be able to handle the case where more than one parallel
172# process may require the user's attention. The default is iterate over the available
173# terminal types to find one that works.
174#
175# Examples of the occasions this may happen are when resolving patches which cannot
176# be applied, to use the devshell or the kernel menuconfig
177#
178# Supported values are auto, gnome, xfce, rxvt, screen, konsole (KDE 3.x only), none
179# Note: currently, Konsole support only works for KDE 3.x due to the way
180# newer Konsole versions behave
181#OE_TERMINAL = "auto"
182# By default disable interactive patch resolution (tasks will just fail instead):
183PATCHRESOLVE = "noop"
184
185#
186# Disk Space Monitoring during the build
187#
188# Monitor the disk space during the build. If there is less that 1GB of space or less
189# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
190# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
191# of the build. The reason for this is that running completely out of space can corrupt
192# files and damages the build in ways which may not be easily recoverable.
193# It's necesary to monitor /tmp, if there is no space left the build will fail
194# with very exotic errors.
195BB_DISKMON_DIRS = "\
196 STOPTASKS,${TMPDIR},1G,100K \
197 STOPTASKS,${DL_DIR},1G,100K \
198 STOPTASKS,${SSTATE_DIR},1G,100K \
199 STOPTASKS,/tmp,100M,100K \
200 ABORT,${TMPDIR},100M,1K \
201 ABORT,${DL_DIR},100M,1K \
202 ABORT,${SSTATE_DIR},100M,1K \
203 ABORT,/tmp,10M,1K"
204
205#
206# Shared-state files from other locations
207#
208# As mentioned above, shared state files are prebuilt cache data objects which can
209# used to accelerate build time. This variable can be used to configure the system
210# to search other mirror locations for these objects before it builds the data itself.
211#
212# This can be a filesystem directory, or a remote url such as http or ftp. These
213# would contain the sstate-cache results from previous builds (possibly from other
214# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
215# cache locations to check for the shared objects.
216# NOTE: if the mirror uses the same structure as SSTATE_DIR, you need to add PATH
217# at the end as shown in the examples below. This will be substituted with the
218# correct path within the directory structure.
219#SSTATE_MIRRORS ?= "\
220#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \
221#file://.* file:///some/local/dir/sstate/PATH"
222
223
224#
225# Qemu configuration
226#
227# By default qemu will build with a builtin VNC server where graphical output can be
228# seen. The two lines below enable the SDL backend too. By default libsdl-native will
229# be built, if you want to use your host's libSDL instead of the minimal libsdl built
230# by libsdl-native then uncomment the ASSUME_PROVIDED line below.
231PACKAGECONFIG_append_pn-qemu-native = " sdl"
232PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
233#ASSUME_PROVIDED += "libsdl-native"
234
235# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
236# track the version of this file when it was generated. This can safely be ignored if
237# this doesn't mean anything to you.
238CONF_VERSION = "1"
239
240DISTRO_FEATURES_remove = " x11"
241
242LICENSE_FLAGS_WHITELIST = "commercial_oseutils"
243
244BBMASK += " \
245 meta-enea-bsp-arm/recipes-kernel/linux/linux-raspberrypi-rt_4.19.bbappend \
246 meta-enea-bsp-arm/recipes-kernel/linux/linux-raspberrypi_4.9.bbappend \
247 meta-amp/recipes-kernel/linux/linux-intel_%.bbappend \
248 "
249# For Ultrascale+ don't include the kernel source in the image
250IMAGE_INSTALL_remove += "kernel-devsrc"