summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel BORNAZ <daniel.bornaz@enea.com>2020-07-07 11:15:45 +0200
committerDaniel BORNAZ <daniel.bornaz@enea.com>2020-07-07 11:15:50 +0200
commit2aea3bb89cf3a0d8b492367f4df91adcd2c1aa1d (patch)
tree4c90684f941a08b1e2852fcb843f0078fc898bd1
parented11cd82055b543f01e5a4b1ad68dfc5aca4d535 (diff)
downloadmeta-el-accelerated-2aea3bb89cf3a0d8b492367f4df91adcd2c1aa1d.tar.gz
Fixed bad CONFIG_PMUFW_INIT_FILE var
Workaround on the multi platform build for U-Boot, please take care as this should be corrected when U-Boot / zcu102 will be build with multiplatform option! Change-Id: Ia6de40863f7d135dd656a061d6d3efee08e5eefb
-rw-r--r--recipes-u-boot/u-boot/files/0001-Fixed-missformed-CONFIG_PMUFW_INIT_FILE.patch35
-rw-r--r--recipes-u-boot/u-boot/u-boot-xlnx_2019.1.bbappend11
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes-u-boot/u-boot/files/0001-Fixed-missformed-CONFIG_PMUFW_INIT_FILE.patch b/recipes-u-boot/u-boot/files/0001-Fixed-missformed-CONFIG_PMUFW_INIT_FILE.patch
new file mode 100644
index 0000000..3d54c3b
--- /dev/null
+++ b/recipes-u-boot/u-boot/files/0001-Fixed-missformed-CONFIG_PMUFW_INIT_FILE.patch
@@ -0,0 +1,35 @@
1From 845ef4193cf00feef7de9c248adab642eda725b8 Mon Sep 17 00:00:00 2001
2From: Daniel BORNAZ <daniel.bornaz@enea.com>
3Date: Tue, 7 Jul 2020 11:13:02 +0200
4Subject: [PATCH] Fixed missformed CONFIG_PMUFW_INIT_FILE
5
6---
7 scripts/Makefile.spl | 12 ++++++------
8 1 file changed, 6 insertions(+), 6 deletions(-)
9
10diff --git a/scripts/Makefile.spl b/scripts/Makefile.spl
11index e5b604e2d2..9ae6672907 100644
12--- a/scripts/Makefile.spl
13+++ b/scripts/Makefile.spl
14@@ -180,12 +180,12 @@ ifdef CONFIG_ARCH_ZYNQ
15 MKIMAGEFLAGS_boot.bin = -T zynqimage -R $(srctree)/$(CONFIG_BOOT_INIT_FILE)
16 endif
17 ifdef CONFIG_ARCH_ZYNQMP
18-ifneq ($(CONFIG_PMUFW_INIT_FILE),"")
19-spl/boot.bin: zynqmp-check-pmufw
20-zynqmp-check-pmufw: FORCE
21- ( cd $(srctree) && test -r $(CONFIG_PMUFW_INIT_FILE) ) \
22- || ( echo "Cannot read $(CONFIG_PMUFW_INIT_FILE)" && false )
23-endif
24+# ifneq ($(CONFIG_PMUFW_INIT_FILE),"")
25+# spl/boot.bin: zynqmp-check-pmufw
26+# zynqmp-check-pmufw: FORCE
27+# ( cd $(srctree) && test -r $(CONFIG_PMUFW_INIT_FILE) ) \
28+# || ( echo "Cannot read $(CONFIG_PMUFW_INIT_FILE)" && false )
29+# endif
30 MKIMAGEFLAGS_boot.bin = -T zynqmpimage -R $(srctree)/$(CONFIG_BOOT_INIT_FILE) \
31 -n "$(shell cd $(srctree); readlink -f $(CONFIG_PMUFW_INIT_FILE))"
32 endif
33--
342.20.1
35
diff --git a/recipes-u-boot/u-boot/u-boot-xlnx_2019.1.bbappend b/recipes-u-boot/u-boot/u-boot-xlnx_2019.1.bbappend
new file mode 100644
index 0000000..1d03d10
--- /dev/null
+++ b/recipes-u-boot/u-boot/u-boot-xlnx_2019.1.bbappend
@@ -0,0 +1,11 @@
1include u-boot-spl-zynq-init.inc
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
4
5SRC_URI_append = "\
6 file://0001-Fixed-missformed-CONFIG_PMUFW_INIT_FILE.patch \
7 "
8
9python() {
10 d.appendVar("EXTRA_OEMAKE", " TEST=NOTHING")
11}