summaryrefslogtreecommitdiffstats
path: root/meta-iot/recipes-web/the-thing-system/tts-nodejs_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-iot/recipes-web/the-thing-system/tts-nodejs_git.bb')
-rw-r--r--meta-iot/recipes-web/the-thing-system/tts-nodejs_git.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-iot/recipes-web/the-thing-system/tts-nodejs_git.bb b/meta-iot/recipes-web/the-thing-system/tts-nodejs_git.bb
new file mode 100644
index 0000000..813526e
--- /dev/null
+++ b/meta-iot/recipes-web/the-thing-system/tts-nodejs_git.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "Node.js is a server-side JavaScript environment for TheThingSystem"
2LICENSE = "MIT & BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=4a31e6c424761191227143b86f58a1ef"
4
5S = "${WORKDIR}/git"
6SRCREV = "cc56c62ed879ad4f93b1fdab3235c43e60f48b7e"
7PV = "0.10.26"
8
9SRC_URI = "\
10 git://github.com/joyent/node.git;branch=v0.10.26-release \
11"
12
13THE_THING_SYSTEM ?= "/opt/TheThingSystem"
14
15DEPENDS = "openssl ninja-native"
16
17# v8 errors out if you have set CCACHE
18CCACHE = ""
19
20ARCHFLAGS_arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard',\
21 '--with-arm-float-abi=hard', '--with-arm-float-abi=softfp', d)}"
22ARCHFLAGS ?= ""
23
24do_configure() {
25 export LD="${CXX}"
26 ./configure --ninja --prefix=${prefix} --without-snapshot ${ARCHFLAGS}
27}
28
29do_compile() {
30 export LD="${CXX}"
31 make BUILDTYPE=Release
32}
33
34do_install() {
35 oe_runmake install DESTDIR=${D}
36}
37
38FILES_${PN} = "\
39 ${libdir} \
40 ${bindir} \
41"
42
43RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess \
44 python-crypt python-textutils python-netclient \
45 python-misc python-multiprocessing \
46"
47RDEPENDS_${PN}_class-native = ""
48
49BBCLASSEXTEND = "native"