summaryrefslogtreecommitdiffstats
path: root/meta-eca/recipes-connectivity/connman/connman_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-eca/recipes-connectivity/connman/connman_git.bb')
-rw-r--r--meta-eca/recipes-connectivity/connman/connman_git.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-eca/recipes-connectivity/connman/connman_git.bb b/meta-eca/recipes-connectivity/connman/connman_git.bb
new file mode 100644
index 0000000..0f4274c
--- /dev/null
+++ b/meta-eca/recipes-connectivity/connman/connman_git.bb
@@ -0,0 +1,51 @@
1require recipes-connectivity/connman/connman.inc
2
3# We use a known good version instead of some buggy point version.
4SRCREV = "f5a441e9d636eefd98335322e79e71ca7e4f55cc"
5SRC_URI = "\
6 git://git.kernel.org/pub/scm/network/connman/connman.git \
7 file://add_xuser_dbus_permission.patch \
8"
9LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
10 file://src/main.c;beginline=1;endline=20;md5=486a279a6ab0c8d152bcda3a5b5edc36 \
11"
12
13# Enable debugging the easy way in systemd based distro.
14# See 0001-doc-Debugging-in-host-that-uses-systemd.patch for usage.
15SRC_URI += "\
16 file://0002-systemd-Use-environment-file-for-connmand-debug-opti.patch \
17 file://0003-systemd-Use-environment-file-for-connman-vpnd-debug-.patch \
18"
19
20S = "${WORKDIR}/git"
21PR = "${INC_PR}.0"
22PV = "1.23+git${SRCPV}"
23
24
25# Override some options from poky connman recipe
26EXTRA_OECONF += "\
27 --enable-loopback=builtin \
28 --enable-ethernet=builtin \
29 --enable-test \
30 --enable-client \
31 --enable-tools \
32 --disable-polkit \
33 --enable-pacrunner \
34 --enable-wispr \
35"
36
37
38# Make sure we will use bluez5 instead of older bluez4
39PACKAGECONFIG[bluetooth] = "--enable-bluetooth, --disable-bluetooth, bluez5"
40RDEPENDS_${PN} = "\
41 dbus \
42 ${@base_contains('PACKAGECONFIG', 'bluetooth', 'bluez5', '', d)} \
43 ${@base_contains('PACKAGECONFIG', 'wifi','wpa-supplicant', '', d)} \
44 ${@base_contains('PACKAGECONFIG', '3g','ofono', '', d)} \
45 "
46
47
48do_install_append() {
49 install -d ${D}${sysconfdir}/connman
50 install -m 0644 ${S}/src/main.conf ${D}${sysconfdir}/connman/main.conf.example
51}