summaryrefslogtreecommitdiffstats
path: root/meta-eca/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-eca/conf/layer.conf')
-rw-r--r--meta-eca/conf/layer.conf15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-eca/conf/layer.conf b/meta-eca/conf/layer.conf
new file mode 100644
index 0000000..c746254
--- /dev/null
+++ b/meta-eca/conf/layer.conf
@@ -0,0 +1,15 @@
1BBPATH ?= ""
2# We add conf directory to BBPATH
3BBPATH .= ":${LAYERDIR}"
4
5# We have a recipes directory containing .bb and .bbappend files, add to BBFILES
6BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
7 ${LAYERDIR}/recipes-*/*/*.bbappend"
8
9BBFILE_COLLECTIONS += "eca"
10BBFILE_PATTERN_eca := "^${LAYERDIR}/"
11BBFILE_PRIORITY_eca = "7"
12
13# Define a similar VARIABLE to COREBASE in order to get a reference to
14# top directory easily
15ECA_COREBASE := '${@os.path.normpath("${LAYERDIR}/../")}'