summaryrefslogtreecommitdiffstats
path: root/meta-eca-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-eca-bsp')
-rw-r--r--meta-eca-bsp/conf/layer.conf13
-rw-r--r--meta-eca-bsp/recipes-eca/grub-conf/eca-grub-conf_1.0.bb16
-rw-r--r--meta-eca-bsp/recipes-eca/grub-conf/files/grub.conf10
-rw-r--r--meta-eca-bsp/recipes-eca/images/core-image-minimal-initramfs.bbappend4
-rw-r--r--meta-eca-bsp/recipes-eca/images/eca-image.bbappend10
-rw-r--r--meta-eca-bsp/recipes-eca/packagegroups/packagegroup-eca.bbappend23
-rw-r--r--meta-eca-bsp/recipes-kernel/linux/clanton/linux-yocto-clanton_3.8.bbappend28
-rw-r--r--meta-eca-bsp/recipes-kernel/linux/linux-mainline/netfilter.cfg13
-rw-r--r--meta-eca-bsp/recipes-kernel/linux/linux-mainline_3.8.bbappend14
-rw-r--r--meta-eca-bsp/recipes-kernel/linux/linux-yocto/beagle_qemu.cfg5
-rw-r--r--meta-eca-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend7
11 files changed, 143 insertions, 0 deletions
diff --git a/meta-eca-bsp/conf/layer.conf b/meta-eca-bsp/conf/layer.conf
new file mode 100644
index 0000000..6328a44
--- /dev/null
+++ b/meta-eca-bsp/conf/layer.conf
@@ -0,0 +1,13 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8# Clanton has own kernel recipe
9BBFILES_clanton += "${LAYERDIR}/recipes-*/*/clanton/*.bbappend"
10
11BBFILE_COLLECTIONS += "ecabsp"
12BBFILE_PATTERN_ecabsp = "^${LAYERDIR}/"
13BBFILE_PRIORITY_ecabsp = "5"
diff --git a/meta-eca-bsp/recipes-eca/grub-conf/eca-grub-conf_1.0.bb b/meta-eca-bsp/recipes-eca/grub-conf/eca-grub-conf_1.0.bb
new file mode 100644
index 0000000..47df56e
--- /dev/null
+++ b/meta-eca-bsp/recipes-eca/grub-conf/eca-grub-conf_1.0.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "grub.conf"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5GRUB_CONF = "grub.conf"
6GRUB_PATH = "boot/grub/"
7SRC_URI = "file://${GRUB_CONF}"
8
9do_grub() {
10 install -d ${DEPLOY_DIR_IMAGE}/${GRUB_PATH}
11 install -m 0755 ${WORKDIR}/${GRUB_CONF} ${DEPLOY_DIR_IMAGE}/${GRUB_PATH}/${GRUB_CONF}
12}
13
14do_grub[nostamp] = "1"
15
16addtask grub before do_build after do_compile
diff --git a/meta-eca-bsp/recipes-eca/grub-conf/files/grub.conf b/meta-eca-bsp/recipes-eca/grub-conf/files/grub.conf
new file mode 100644
index 0000000..cfb1f54
--- /dev/null
+++ b/meta-eca-bsp/recipes-eca/grub-conf/files/grub.conf
@@ -0,0 +1,10 @@
1default 0
2timeout 3
3
4color white/blue white/cyan
5
6title ECA for Clanton
7 root (hd0,0)
8 kernel /bzImage root=/dev/ram0 console=ttyS1,115200n8 earlycon=uart8250,mmio32,0x8010f000,115200n8 reboot=efi,warm apic=debug rw LABEL=boot debugshell=5
9 initrd /core-image-minimal-initramfs-clanton.cpio.gz
10
diff --git a/meta-eca-bsp/recipes-eca/images/core-image-minimal-initramfs.bbappend b/meta-eca-bsp/recipes-eca/images/core-image-minimal-initramfs.bbappend
new file mode 100644
index 0000000..48a2f5b
--- /dev/null
+++ b/meta-eca-bsp/recipes-eca/images/core-image-minimal-initramfs.bbappend
@@ -0,0 +1,4 @@
1IMAGE_INSTALL_clanton = "initramfs-live-boot busybox base-passwd udev"
2IMAGE_INSTALL_clanton += "kernel-module-usb-storage"
3IMAGE_INSTALL_clanton += "kernel-module-ehci-hcd kernel-module-ehci-pci kernel-module-ohci-hcd"
4IMAGE_INSTALL_clanton += "kernel-module-stmmac"
diff --git a/meta-eca-bsp/recipes-eca/images/eca-image.bbappend b/meta-eca-bsp/recipes-eca/images/eca-image.bbappend
new file mode 100644
index 0000000..65c5838
--- /dev/null
+++ b/meta-eca-bsp/recipes-eca/images/eca-image.bbappend
@@ -0,0 +1,10 @@
1
2IMAGE_FSTYPES_clanton = "ext3 live"
3
4NOISO_clanton = "1"
5NOHDD_clanton = "1"
6
7EXTRA_IMAGEDEPENDS_clanton = "eca-grub-conf"
8
9# root fs name should be rootfs.img as initrd expects to find that
10IMAGE_POSTPROCESS_COMMAND_clanton += "rm -f rootfs.img; ln -s ${IMAGE_LINK_NAME}.ext3 rootfs.img; "
diff --git a/meta-eca-bsp/recipes-eca/packagegroups/packagegroup-eca.bbappend b/meta-eca-bsp/recipes-eca/packagegroups/packagegroup-eca.bbappend
new file mode 100644
index 0000000..7fae0cc
--- /dev/null
+++ b/meta-eca-bsp/recipes-eca/packagegroups/packagegroup-eca.bbappend
@@ -0,0 +1,23 @@
1def get_depends_qemu(bb, d, dep):
2 val = (bb.data.getVar("MACHINEOVERRIDES", d) or "")
3 if val.find("qemuall"):
4 return ""
5 else:
6 return dep
7
8IWLWIFI := "\
9 ${@get_depends_qemu(bb, d, 'linux-firmware-iwlwifi-licence')} \
10 ${@get_depends_qemu(bb, d, 'linux-firmware-iwlwifi-6000g2a-5')} \
11 ${@get_depends_qemu(bb, d, 'linux-firmware-iwlwifi-6000g2b-6')} \
12"
13
14# Add iwlwifi firmware for Intel devices but not for qemu images because
15# user probably does not have Intel layer defined there
16RDEPENDS_packagegroup-eca_append_x86 += "\
17 ${IWLWIFI} \
18"
19
20# network configuration for connman if running qemu
21RDEPENDS_packagegroup-eca_append_qemuall += "\
22 connman-conf \
23"
diff --git a/meta-eca-bsp/recipes-kernel/linux/clanton/linux-yocto-clanton_3.8.bbappend b/meta-eca-bsp/recipes-kernel/linux/clanton/linux-yocto-clanton_3.8.bbappend
new file mode 100644
index 0000000..8cff3f2
--- /dev/null
+++ b/meta-eca-bsp/recipes-kernel/linux/clanton/linux-yocto-clanton_3.8.bbappend
@@ -0,0 +1,28 @@
1# find defconfig path
2FILESEXTRAPATHS := "${THISDIR}/../../../meta-eca/recipes-kernel/linux/linux-yocto"
3
4SRC_URI += " \
5 file://wlan-atheros.cfg \
6 file://wlan-ralink.cfg \
7 file://wlan-realtek.cfg \
8 file://wlan-broadcom.cfg \
9 file://wlan-zydas.cfg \
10 file://wlan-marwel.cfg \
11 file://wlan-ti.cfg \
12 file://wlan-intel.cfg \
13 file://bluetooth.cfg \
14 file://nokia-phonet.cfg \
15 file://usb-serial.cfg \
16 file://tun-device.cfg \
17 file://l2tp.cfg \
18 file://rfkill.cfg \
19 file://mac80211.cfg \
20 file://nfc.cfg \
21 file://high-speed-mobile-devices.cfg \
22 file://usb-eth-gadget.cfg \
23 file://usb-net.cfg \
24 file://ipv6.cfg \
25 file://nfacct.cfg \
26 file://bridge.cfg \
27 file://netfilter-small-3.8.cfg \
28"
diff --git a/meta-eca-bsp/recipes-kernel/linux/linux-mainline/netfilter.cfg b/meta-eca-bsp/recipes-kernel/linux/linux-mainline/netfilter.cfg
new file mode 100644
index 0000000..552c937
--- /dev/null
+++ b/meta-eca-bsp/recipes-kernel/linux/linux-mainline/netfilter.cfg
@@ -0,0 +1,13 @@
1CONFIG_NF_CONNTRACK=m
2CONFIG_NF_CONNTRACK_PROCFS=y
3CONFIG_NF_NAT=m
4CONFIG_NF_NAT_NEEDED=y
5CONFIG_NF_DEFRAG_IPV4=m
6CONFIG_NF_CONNTRACK_IPV4=m
7CONFIG_NF_CONNTRACK_PROC_COMPAT=y
8CONFIG_NF_NAT_IPV4=m
9CONFIG_IP_NF_TARGET_MASQUERADE=m
10CONFIG_NF_CONNTRACK_MARK=y
11CONFIG_NETFILTER_XT_CONNMARK=m
12CONFIG_NETFILTER_XT_TARGET_CONNMARK=m
13CONFIG_NETFILTER_XT_MATCH_CONNMARK=m
diff --git a/meta-eca-bsp/recipes-kernel/linux/linux-mainline_3.8.bbappend b/meta-eca-bsp/recipes-kernel/linux/linux-mainline_3.8.bbappend
new file mode 100644
index 0000000..429ed34
--- /dev/null
+++ b/meta-eca-bsp/recipes-kernel/linux/linux-mainline_3.8.bbappend
@@ -0,0 +1,14 @@
1# find defconfig path
2FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
3
4# netfilter stuff is missing from beaglebone kernel
5SRC_URI_append_beaglebone += "file://netfilter.cfg"
6
7do_configure_append_beaglebone () {
8 for i in ${S}/../*.cfg; do
9 echo "Adding ${i} to ${S}/.config"
10 cat ${i} >> ${S}/.config
11 done
12
13 yes '' | oe_runmake oldconfig
14}
diff --git a/meta-eca-bsp/recipes-kernel/linux/linux-yocto/beagle_qemu.cfg b/meta-eca-bsp/recipes-kernel/linux/linux-yocto/beagle_qemu.cfg
new file mode 100644
index 0000000..0ace211
--- /dev/null
+++ b/meta-eca-bsp/recipes-kernel/linux/linux-yocto/beagle_qemu.cfg
@@ -0,0 +1,5 @@
1CONFIG_PANEL_GENERIC_DPI=y
2
3CONFIG_USB_OHCI_HCD=y
4CONFIG_USB_OHCI_HCD_OMAP3=y
5CONFIG_USB_OHCI_LITTLE_ENDIAN=y
diff --git a/meta-eca-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-eca-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
new file mode 100644
index 0000000..5bde90b
--- /dev/null
+++ b/meta-eca-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -0,0 +1,7 @@
1# find defconfig path
2FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
3
4# Kernel configs
5SRC_URI_append_beagleboard = " \
6 file://beagle_qemu.cfg \
7 "