summaryrefslogtreecommitdiffstats
path: root/meta-eca-bsp/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-eca-bsp/recipes-kernel')
-rw-r--r--meta-eca-bsp/recipes-kernel/linux/clanton/linux-yocto-clanton_3.8.bbappend28
-rw-r--r--meta-eca-bsp/recipes-kernel/linux/linux-mainline/netfilter.cfg13
-rw-r--r--meta-eca-bsp/recipes-kernel/linux/linux-mainline_3.8.bbappend14
-rw-r--r--meta-eca-bsp/recipes-kernel/linux/linux-yocto/beagle_qemu.cfg5
-rw-r--r--meta-eca-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend7
5 files changed, 67 insertions, 0 deletions
diff --git a/meta-eca-bsp/recipes-kernel/linux/clanton/linux-yocto-clanton_3.8.bbappend b/meta-eca-bsp/recipes-kernel/linux/clanton/linux-yocto-clanton_3.8.bbappend
new file mode 100644
index 0000000..8cff3f2
--- /dev/null
+++ b/meta-eca-bsp/recipes-kernel/linux/clanton/linux-yocto-clanton_3.8.bbappend
@@ -0,0 +1,28 @@
1# find defconfig path
2FILESEXTRAPATHS := "${THISDIR}/../../../meta-eca/recipes-kernel/linux/linux-yocto"
3
4SRC_URI += " \
5 file://wlan-atheros.cfg \
6 file://wlan-ralink.cfg \
7 file://wlan-realtek.cfg \
8 file://wlan-broadcom.cfg \
9 file://wlan-zydas.cfg \
10 file://wlan-marwel.cfg \
11 file://wlan-ti.cfg \
12 file://wlan-intel.cfg \
13 file://bluetooth.cfg \
14 file://nokia-phonet.cfg \
15 file://usb-serial.cfg \
16 file://tun-device.cfg \
17 file://l2tp.cfg \
18 file://rfkill.cfg \
19 file://mac80211.cfg \
20 file://nfc.cfg \
21 file://high-speed-mobile-devices.cfg \
22 file://usb-eth-gadget.cfg \
23 file://usb-net.cfg \
24 file://ipv6.cfg \
25 file://nfacct.cfg \
26 file://bridge.cfg \
27 file://netfilter-small-3.8.cfg \
28"
diff --git a/meta-eca-bsp/recipes-kernel/linux/linux-mainline/netfilter.cfg b/meta-eca-bsp/recipes-kernel/linux/linux-mainline/netfilter.cfg
new file mode 100644
index 0000000..552c937
--- /dev/null
+++ b/meta-eca-bsp/recipes-kernel/linux/linux-mainline/netfilter.cfg
@@ -0,0 +1,13 @@
1CONFIG_NF_CONNTRACK=m
2CONFIG_NF_CONNTRACK_PROCFS=y
3CONFIG_NF_NAT=m
4CONFIG_NF_NAT_NEEDED=y
5CONFIG_NF_DEFRAG_IPV4=m
6CONFIG_NF_CONNTRACK_IPV4=m
7CONFIG_NF_CONNTRACK_PROC_COMPAT=y
8CONFIG_NF_NAT_IPV4=m
9CONFIG_IP_NF_TARGET_MASQUERADE=m
10CONFIG_NF_CONNTRACK_MARK=y
11CONFIG_NETFILTER_XT_CONNMARK=m
12CONFIG_NETFILTER_XT_TARGET_CONNMARK=m
13CONFIG_NETFILTER_XT_MATCH_CONNMARK=m
diff --git a/meta-eca-bsp/recipes-kernel/linux/linux-mainline_3.8.bbappend b/meta-eca-bsp/recipes-kernel/linux/linux-mainline_3.8.bbappend
new file mode 100644
index 0000000..429ed34
--- /dev/null
+++ b/meta-eca-bsp/recipes-kernel/linux/linux-mainline_3.8.bbappend
@@ -0,0 +1,14 @@
1# find defconfig path
2FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
3
4# netfilter stuff is missing from beaglebone kernel
5SRC_URI_append_beaglebone += "file://netfilter.cfg"
6
7do_configure_append_beaglebone () {
8 for i in ${S}/../*.cfg; do
9 echo "Adding ${i} to ${S}/.config"
10 cat ${i} >> ${S}/.config
11 done
12
13 yes '' | oe_runmake oldconfig
14}
diff --git a/meta-eca-bsp/recipes-kernel/linux/linux-yocto/beagle_qemu.cfg b/meta-eca-bsp/recipes-kernel/linux/linux-yocto/beagle_qemu.cfg
new file mode 100644
index 0000000..0ace211
--- /dev/null
+++ b/meta-eca-bsp/recipes-kernel/linux/linux-yocto/beagle_qemu.cfg
@@ -0,0 +1,5 @@
1CONFIG_PANEL_GENERIC_DPI=y
2
3CONFIG_USB_OHCI_HCD=y
4CONFIG_USB_OHCI_HCD_OMAP3=y
5CONFIG_USB_OHCI_LITTLE_ENDIAN=y
diff --git a/meta-eca-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-eca-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
new file mode 100644
index 0000000..5bde90b
--- /dev/null
+++ b/meta-eca-bsp/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -0,0 +1,7 @@
1# find defconfig path
2FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
3
4# Kernel configs
5SRC_URI_append_beagleboard = " \
6 file://beagle_qemu.cfg \
7 "