summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_23.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk_23.11.bb')
-rw-r--r--recipes-extended/dpdk/dpdk_23.11.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_23.11.bb b/recipes-extended/dpdk/dpdk_23.11.bb
new file mode 100644
index 0000000..5f0f9ec
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_23.11.bb
@@ -0,0 +1,68 @@
1include dpdk.inc
2
3SRC_URI += " file://0001-config-meson-get-cpu_instruction_set-from-meson-opti.patch "
4
5STABLE = "-stable"
6BRANCH = "23.11"
7SRCREV = "eeb0605f118dae66e80faa44f7b3e88748032353"
8S = "${WORKDIR}/git"
9
10def get_cpu_instruction_set(bb, d):
11 import re
12 march = re.search(r'-march=([^\s]*)', d.getVar('CC')).group(1)
13 return march
14
15EXTRA_OEMESON = " -Dexamples=all -Dcpu_instruction_set=${@get_cpu_instruction_set(bb, d)} "
16
17COMPATIBLE_MACHINE = "null"
18COMPATIBLE_HOST:libc-musl:class-target = "null"
19COMPATIBLE_HOST:linux-gnux32 = "null"
20
21PACKAGECONFIG ??= " "
22PACKAGECONFIG[afxdp] = ",,libbpf xdp-tools"
23PACKAGECONFIG[libvirt] = ",,libvirt"
24
25RDEPENDS:${PN} += "pciutils python3-core"
26RDEPENDS:${PN}-examples += "bash"
27DEPENDS = "numactl python3-pyelftools-native"
28
29inherit meson pkgconfig
30
31INSTALL_PATH = "${prefix}/share/dpdk"
32
33do_install:append(){
34 # remove source files
35 rm -rf ${D}/${INSTALL_PATH}/examples/*
36
37 # Install examples
38 install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
39 for dirname in ${B}/examples/dpdk-*
40 do
41 if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
42 install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
43 fi
44 done
45
46}
47
48PACKAGES =+ "${PN}-examples ${PN}-tools"
49
50FILES:${PN} += " ${bindir}/dpdk-testpmd \
51 ${bindir}/dpdk-proc-info \
52 ${libdir}/*.so* \
53 ${libdir}/dpdk/pmds-22.0/*.so* \
54 "
55FILES:${PN}-examples = " \
56 ${prefix}/share/dpdk/examples/* \
57 "
58
59FILES:${PN}-tools = " \
60 ${bindir}/dpdk-pdump \
61 ${bindir}/dpdk-test \
62 ${bindir}/dpdk-test-* \
63 ${bindir}/dpdk-*.py \
64 "
65
66CVE_PRODUCT = "data_plane_development_kit"
67
68INSANE_SKIP:${PN} = "dev-so"