summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_20.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk_20.11.1.bb')
-rw-r--r--recipes-extended/dpdk/dpdk_20.11.1.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_20.11.1.bb b/recipes-extended/dpdk/dpdk_20.11.1.bb
new file mode 100644
index 0000000..7b0f0ee
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_20.11.1.bb
@@ -0,0 +1,64 @@
1include dpdk.inc
2
3SRC_URI += " \
4 file://0001-meson.build-march-and-mcpu-already-passed-by-Yocto.patch \
5"
6
7STABLE = "-stable"
8BRANCH = "20.11"
9SRCREV = "b1e71cf43153cca07db6cbb69fdca030ccf52234"
10S = "${WORKDIR}/git"
11
12# kernel module is provide by dpdk-module recipe, so disable here
13EXTRA_OEMESON = " -Denable_kmods=false \
14 -Dexamples=all \
15"
16
17COMPATIBLE_MACHINE = "null"
18COMPATIBLE_HOST_libc-musl_class-target = "null"
19COMPATIBLE_HOST_linux-gnux32 = "null"
20
21RDEPENDS_${PN} += "pciutils python3-core"
22RDEPENDS_${PN}-examples += "bash"
23DEPENDS = "numactl"
24
25inherit meson
26
27INSTALL_PATH = "${prefix}/share/dpdk"
28
29do_install_append(){
30 # remove source files
31 rm -rf ${D}/${INSTALL_PATH}/examples/*
32
33 # Install examples
34 install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
35 for dirname in ${B}/examples/dpdk-*
36 do
37 if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
38 install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
39 fi
40 done
41
42}
43
44PACKAGES =+ "${PN}-examples ${PN}-tools"
45
46FILES_${PN} = " ${bindir}/dpdk-testpmd \
47 ${bindir}/dpdk-proc-info \
48 ${libdir}/*.so* \
49 ${libdir}/dpdk/pmds-21.0/*.so* \
50 "
51FILES_${PN}-examples = " \
52 ${prefix}/share/dpdk/examples/* \
53 "
54
55FILES_${PN}-tools = " \
56 ${bindir}/dpdk-pdump \
57 ${bindir}/dpdk-test \
58 ${bindir}/dpdk-test-* \
59 ${bindir}/dpdk-*.py \
60 "
61
62CVE_PRODUCT = "data_plane_development_kit"
63
64INSANE_SKIP_${PN} = "dev-so"