summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_19.11.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk_19.11.5.bb')
-rw-r--r--recipes-extended/dpdk/dpdk_19.11.5.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/recipes-extended/dpdk/dpdk_19.11.5.bb b/recipes-extended/dpdk/dpdk_19.11.5.bb
index 2ae9b43..41f56b0 100644
--- a/recipes-extended/dpdk/dpdk_19.11.5.bb
+++ b/recipes-extended/dpdk/dpdk_19.11.5.bb
@@ -14,8 +14,8 @@ SRCREV = "1d28832feb881d4512993791d30d695cc9c7160b"
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16COMPATIBLE_MACHINE = "null" 16COMPATIBLE_MACHINE = "null"
17COMPATIBLE_HOST_libc-musl_class-target = "null" 17COMPATIBLE_HOST:libc-musl:class-target = "null"
18COMPATIBLE_HOST_linux-gnux32 = "null" 18COMPATIBLE_HOST:linux-gnux32 = "null"
19 19
20# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat. 20# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
21# fuse is in meta-filesystems and qat is not yet upstreamed. 21# fuse is in meta-filesystems and qat is not yet upstreamed.
@@ -37,7 +37,7 @@ export CONFIG_HAVE_NUMA = "${@bb.utils.contains('PACKAGECONFIG', 'numa', 'y', 'n
37# specific directory 37# specific directory
38datadir[unexport] = "1" 38datadir[unexport] = "1"
39 39
40RDEPENDS_${PN} += "pciutils python3-core" 40RDEPENDS:${PN} += "pciutils python3-core"
41DEPENDS = "virtual/kernel" 41DEPENDS = "virtual/kernel"
42do_configure[depends] += "virtual/kernel:do_shared_workdir" 42do_configure[depends] += "virtual/kernel:do_shared_workdir"
43 43
@@ -60,9 +60,9 @@ export ICP_LAC_API_DIR = "${STAGING_DIR_TARGET}${includedir}/lac"
60export EXAMPLES_BUILD_DIR = "${RTE_TARGET}" 60export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
61export ARCHDIR = "generic" 61export ARCHDIR = "generic"
62 62
63DPDK_RTE_TARGET_x86-64 = "x86_64-native-linuxapp-gcc" 63DPDK_RTE_TARGET:x86-64 = "x86_64-native-linuxapp-gcc"
64DPDK_RTE_TARGET_x86 = "i686-native-linuxapp-gcc" 64DPDK_RTE_TARGET:x86 = "i686-native-linuxapp-gcc"
65DPDK_RTE_TARGET_aarch64 = "arm64-${DPDK_TARGET_MACH}-linuxapp-gcc" 65DPDK_RTE_TARGET:aarch64 = "arm64-${DPDK_TARGET_MACH}-linuxapp-gcc"
66export RTE_TARGET = "${DPDK_RTE_TARGET}" 66export RTE_TARGET = "${DPDK_RTE_TARGET}"
67 67
68# Workaround failure on gcc10 68# Workaround failure on gcc10
@@ -163,16 +163,16 @@ do_install () {
163 163
164PACKAGES += "${PN}-examples ${PN}-test" 164PACKAGES += "${PN}-examples ${PN}-test"
165 165
166FILES_${PN}-dbg += " \ 166FILES:${PN}-dbg += " \
167 ${INSTALL_PATH}/.debug \ 167 ${INSTALL_PATH}/.debug \
168 ${INSTALL_PATH}/examples/*/.debug \ 168 ${INSTALL_PATH}/examples/*/.debug \
169 " 169 "
170 170
171FILES_${PN}-doc += "\ 171FILES:${PN}-doc += "\
172 ${INSTALL_PATH}/doc \ 172 ${INSTALL_PATH}/doc \
173 " 173 "
174 174
175FILES_${PN}-dev += " \ 175FILES:${PN}-dev += " \
176 ${INSTALL_PATH}/${RTE_TARGET}/.config \ 176 ${INSTALL_PATH}/${RTE_TARGET}/.config \
177 ${includedir} \ 177 ${includedir} \
178 ${includedir}/${ARCHDIR} \ 178 ${includedir}/${ARCHDIR} \
@@ -183,15 +183,15 @@ FILES_${PN}-dev += " \
183 ${INSTALL_PATH}/mk \ 183 ${INSTALL_PATH}/mk \
184 " 184 "
185 185
186FILES_${PN} += " ${INSTALL_PATH}/usertools/ \ 186FILES:${PN} += " ${INSTALL_PATH}/usertools/ \
187 ${prefix}/sbin/ \ 187 ${prefix}/sbin/ \
188 ${prefix}/bin/ \ 188 ${prefix}/bin/ \
189 ${libdir}/ \ 189 ${libdir}/ \
190 " 190 "
191FILES_${PN}-examples += " \ 191FILES:${PN}-examples += " \
192 ${INSTALL_PATH}/examples/* \ 192 ${INSTALL_PATH}/examples/* \
193 " 193 "
194 194
195FILES_${PN}-test += " \ 195FILES:${PN}-test += " \
196 ${INSTALL_PATH}/test \ 196 ${INSTALL_PATH}/test \
197 " 197 "