summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch')
-rw-r--r--recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch79
1 files changed, 0 insertions, 79 deletions
diff --git a/recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch b/recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch
deleted file mode 100644
index 0505888..0000000
--- a/recipes-extended/dpdk/dpdk/dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch
+++ /dev/null
@@ -1,79 +0,0 @@
1From 0be350c3b04d83ea9182f45936ef3219aed5c0c1 Mon Sep 17 00:00:00 2001
2From: Shashwat Pandey <shashwatx.p@intel.com>
3Date: Mon, 20 Feb 2017 15:46:22 +0800
4Subject: [PATCH] dpdk: fix installation warning and issue
5
6Upstream-Status: Inappropriate [configuration]
7
8Ensure that all compiled libs should be installed to correct location.
9For cross compiling cp -r and extra tar flags used to avoid QA warning
10[host-user-contaminated].
11Added excluded files from bin and removing mk and app/dpdk-pmdinfogen files
12installation since it is not needed as a part of image.
13
14Signed-off-by: Shashwat Pandey <shashwatx.p@intel.com>
15
16---
17 mk/rte.sdkinstall.mk | 29 ++++++++++++++---------------
18 1 file changed, 14 insertions(+), 15 deletions(-)
19
20diff --git a/mk/rte.sdkinstall.mk b/mk/rte.sdkinstall.mk
21index 4e97feff9fde..42625333a4e2 100644
22--- a/mk/rte.sdkinstall.mk
23+++ b/mk/rte.sdkinstall.mk
24@@ -115,16 +115,17 @@ endif
25
26 install-runtime:
27 $(Q)$(call rte_mkdir, $(DESTDIR)$(libdir))
28- $(Q)cp -a $O/lib/* $(DESTDIR)$(libdir)
29+ $(Q)cp -r $O/lib/* $(DESTDIR)$(libdir)
30 $(Q)$(call rte_mkdir, $(DESTDIR)$(bindir))
31- $(Q)tar -cf - -C $O --exclude 'app/*.map' \
32- --exclude app/dpdk-pmdinfogen \
33- --exclude 'app/cmdline*' --exclude app/test \
34- --exclude app/testacl --exclude app/testpipeline app | \
35- tar -xf - -C $(DESTDIR)$(bindir) --strip-components=1 \
36- --keep-newer-files
37+ $(Q)tar -cf - -C $O --exclude app/dpdk-pmdinfogen app | \
38+ tar -xf - -C $(DESTDIR)$(bindir) --no-same-owner --no-same-permissions \
39+ --strip-components=1 --keep-newer-files --warning=no-ignore-newer
40 $(Q)$(call rte_mkdir, $(DESTDIR)$(datadir))
41- $(Q)cp -a $(RTE_SDK)/usertools $(DESTDIR)$(datadir)
42+ $(Q)cp -r $(RTE_SDK)/usertools $(DESTDIR)$(datadir)
43+ $(Q)$(call rte_symlink, $(DESTDIR)$(datadir)/usertools/dpdk-setup.sh, \
44+ $(DESTDIR)$(datadir)/usertools/setup.sh)
45+ $(Q)$(call rte_symlink, $(DESTDIR)$(datadir)/usertools/dpdk-devbind.py, \
46+ $(DESTDIR)$(datadir)/usertools/dpdk_nic_bind.py)
47 $(Q)$(call rte_mkdir, $(DESTDIR)$(sbindir))
48 $(Q)$(call rte_symlink, $(DESTDIR)$(datadir)/usertools/dpdk-devbind.py, \
49 $(DESTDIR)$(sbindir)/dpdk-devbind)
50@@ -142,7 +143,7 @@ endif
51 install-kmod:
52 ifneq ($(wildcard $O/kmod/*),)
53 $(Q)$(call rte_mkdir, $(DESTDIR)$(kerneldir))
54- $(Q)cp -a $O/kmod/* $(DESTDIR)$(kerneldir)
55+ $(Q)cp -r $O/kmod/* $(DESTDIR)$(kerneldir)
56 endif
57
58 install-sdk:
59@@ -151,11 +152,9 @@ install-sdk:
60 tar -xf - -C $(DESTDIR)$(includedir) --strip-components=1 \
61 --keep-newer-files
62 $(Q)$(call rte_mkdir, $(DESTDIR)$(sdkdir))
63- $(Q)cp -a $(RTE_SDK)/mk $(DESTDIR)$(sdkdir)
64- $(Q)cp -a $(RTE_SDK)/buildtools $(DESTDIR)$(sdkdir)
65- $(Q)$(call rte_mkdir, $(DESTDIR)$(targetdir)/app)
66- $(Q)cp -a $O/.config $(DESTDIR)$(targetdir)
67- $(Q)cp -a $O/app/dpdk-pmdinfogen $(DESTDIR)$(targetdir)/app
68+ $(Q)cp -r $(RTE_SDK)/buildtools $(DESTDIR)$(sdkdir)
69+ $(Q)$(call rte_mkdir, $(DESTDIR)$(targetdir))
70+ $(Q)cp -r $O/.config $(DESTDIR)$(targetdir)
71 $(Q)$(call rte_symlink, $(DESTDIR)$(includedir), $(DESTDIR)$(targetdir)/include)
72 $(Q)$(call rte_symlink, $(DESTDIR)$(libdir), $(DESTDIR)$(targetdir)/lib)
73
74@@ -171,4 +170,4 @@ ifneq ($(wildcard $O/doc/*/*/*pdf),)
75 $(Q)cp -a $O/doc/*/*/*pdf $(DESTDIR)$(docdir)/guides
76 endif
77 $(Q)$(call rte_mkdir, $(DESTDIR)$(datadir))
78- $(Q)cp -a $(RTE_SDK)/examples $(DESTDIR)$(datadir)
79+ $(Q)cp -r $(RTE_SDK)/examples $(DESTDIR)$(datadir)