summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk/0001-config-meson-get-cpu_instruction_set-from-meson-opti.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk/0001-config-meson-get-cpu_instruction_set-from-meson-opti.patch')
-rw-r--r--recipes-extended/dpdk/dpdk/0001-config-meson-get-cpu_instruction_set-from-meson-opti.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk/0001-config-meson-get-cpu_instruction_set-from-meson-opti.patch b/recipes-extended/dpdk/dpdk/0001-config-meson-get-cpu_instruction_set-from-meson-opti.patch
new file mode 100644
index 0000000..92e3523
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk/0001-config-meson-get-cpu_instruction_set-from-meson-opti.patch
@@ -0,0 +1,32 @@
1From 121e5d019f0bb6dec0ace2b361611edd10fc8ff8 Mon Sep 17 00:00:00 2001
2From: Lee Chee Yang <chee.yang.lee@intel.com>
3Date: Wed, 6 Dec 2023 16:58:10 +0800
4Subject: [PATCH] config/meson: get cpu_instruction_set from meson option
5
6Workaround error:
7| ../git/config/meson.build:178:8: ERROR: Problem encountered: Compiler
8does not support "x86_64" arch flag.
9
10Upstream-Status: Inappropriate [ yocto specific to set cpu_instruction_set ]
11
12Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com>
13---
14 config/meson.build | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/config/meson.build b/config/meson.build
18index a9ccd56deb..f310c7adf6 100644
19--- a/config/meson.build
20+++ b/config/meson.build
21@@ -105,7 +105,7 @@ platform = get_option('platform')
22
23 # set the cpu_instruction_set and cflags for it
24 if meson.is_cross_build()
25- cpu_instruction_set = host_machine.cpu()
26+ cpu_instruction_set = get_option('cpu_instruction_set')
27 else
28 cpu_instruction_set = get_option('cpu_instruction_set')
29 machine = get_option('machine')
30--
312.37.3
32