summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/iwlwifi
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/iwlwifi')
-rw-r--r--common/recipes-kernel/iwlwifi/backport-iwlwifi/0001-Makefile.real-skip-host-install-scripts.patch36
-rw-r--r--common/recipes-kernel/iwlwifi/backport-iwlwifi/iwlwifi.conf12
-rw-r--r--common/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb42
3 files changed, 0 insertions, 90 deletions
diff --git a/common/recipes-kernel/iwlwifi/backport-iwlwifi/0001-Makefile.real-skip-host-install-scripts.patch b/common/recipes-kernel/iwlwifi/backport-iwlwifi/0001-Makefile.real-skip-host-install-scripts.patch
deleted file mode 100644
index 1d4137b..0000000
--- a/common/recipes-kernel/iwlwifi/backport-iwlwifi/0001-Makefile.real-skip-host-install-scripts.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From f69ff2fd27903ee052309179271f708d720a2f94 Mon Sep 17 00:00:00 2001
2From: Mikko Ylinen <mikko.ylinen@linux.intel.com>
3Date: Thu, 10 Aug 2017 21:12:51 +0300
4Subject: [PATCH] Makefile.real: skip host install scripts
5
6The scripts run in install target are relevant (and working)
7only if the driver installation is run on the build host.
8
9Skip the scripts when cross-compiling.
10
11Upstream-Status: Inappropriate [Cross-Compile]
12
13Signed-off-by: Mikko Ylinen <mikko.ylinen@linux.intel.com>
14---
15 Makefile.real | 5 -----
16 1 file changed, 5 deletions(-)
17
18diff --git a/Makefile.real b/Makefile.real
19index ba09f99..f5075de 100644
20--- a/Makefile.real
21+++ b/Makefile.real
22@@ -104,11 +104,6 @@ install: modules
23 @$(MAKE) -C $(KLIB_BUILD) M=$(BACKPORT_DIR) \
24 INSTALL_MOD_DIR=$(KMODDIR) $(KMODPATH_ARG) \
25 modules_install
26- @./scripts/blacklist.sh $(KLIB)/ $(KLIB)/$(KMODDIR)
27- @./scripts/compress_modules.sh $(KLIB)/$(KMODDIR)
28- @./scripts/check_depmod.sh
29- @/sbin/depmod -a
30- @./scripts/update-initramfs.sh $(KLIB)
31 @echo
32 @echo Your backported driver modules should be installed now.
33 @echo Reboot.
34--
352.1.4
36
diff --git a/common/recipes-kernel/iwlwifi/backport-iwlwifi/iwlwifi.conf b/common/recipes-kernel/iwlwifi/backport-iwlwifi/iwlwifi.conf
deleted file mode 100644
index a0e5f6f..0000000
--- a/common/recipes-kernel/iwlwifi/backport-iwlwifi/iwlwifi.conf
+++ /dev/null
@@ -1,12 +0,0 @@
1# /etc/modprobe.d/iwlwifi.conf
2# iwlwifi will dynamically load either iwldvm or iwlmvm depending on the
3# microcode file installed on the system. When removing iwlwifi, first
4# remove the iwl?vm module and then iwlwifi.
5remove iwlwifi (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm16 -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) && /sbin/modprobe -r mac80211
6
7#options iwlwifi lar_disable=1
8#options iwlwifi nvm_file="nvm-sfp-b2-open.bin"
9options iwlmvm power_scheme=1
10
11# PCI BUS
12
diff --git a/common/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb b/common/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb
deleted file mode 100644
index f793a10..0000000
--- a/common/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb
+++ /dev/null
@@ -1,42 +0,0 @@
1SUMMARY = "Intel Wireless LinuxCore kernel driver"
2DESCRIPTION = "Intel Wireless LinuxCore kernel driver"
3SECTION = "kernel"
4LICENSE = "GPLv2"
5
6REQUIRED_DISTRO_FEATURES = "wifi"
7
8LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
9
10inherit module
11
12PV = "30"
13SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi;branch=release/LinuxCore${PV}"
14SRC_URI += "file://0001-Makefile.real-skip-host-install-scripts.patch"
15SRC_URI += "file://iwlwifi.conf"
16
17SRCREV = "${AUTOREV}"
18
19S = "${WORKDIR}/git"
20
21EXTRA_OEMAKE = "INSTALL_MOD_PATH=${D} KLIB_BUILD=${KBUILD_OUTPUT}"
22
23do_configure() {
24 CC=gcc CFLAGS= LDFLAGS= make defconfig-iwlwifi-public KLIB_BUILD=${KBUILD_OUTPUT}
25}
26
27MODULES_INSTALL_TARGET="install"
28
29do_install_append() {
30 ## install configs and service scripts
31 install -d ${D}${sysconfdir}/modprobe.d
32 install -m 0644 ${WORKDIR}/iwlwifi.conf ${D}${sysconfdir}/modprobe.d
33}
34
35SYSTEMD_AUTO_ENABLE_${PN} = "enable"
36
37RDEPENDS_${PN} = "linux-firmware-iwlwifi"
38
39KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
40KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
41
42KERNEL_MODULE_PACKAGE_PREFIX = "backport-iwlwifi"