summaryrefslogtreecommitdiffstats
path: root/meta-qat/recipes-extended/openssl-qat/openssl-qat/openssl_qat-build-qat_mem-ko-against-yocto-kernel.patch
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-09-26 08:35:13 -0700
committerSaul Wold <sgw@linux.intel.com>2017-09-26 08:35:13 -0700
commit67149d869eddad4b1e487fbc4368974c153f358d (patch)
treebe9db2eae71f09e50e2fa6fbc6cacb95082eacd0 /meta-qat/recipes-extended/openssl-qat/openssl-qat/openssl_qat-build-qat_mem-ko-against-yocto-kernel.patch
parenta98b71ccadc1458bf3a959e328d5ae814eb7e9b3 (diff)
downloadmeta-dpdk-67149d869eddad4b1e487fbc4368974c153f358d.tar.gz
Removal of meta-intel content to make meta-dpdk standalone
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-qat/recipes-extended/openssl-qat/openssl-qat/openssl_qat-build-qat_mem-ko-against-yocto-kernel.patch')
-rw-r--r--meta-qat/recipes-extended/openssl-qat/openssl-qat/openssl_qat-build-qat_mem-ko-against-yocto-kernel.patch62
1 files changed, 0 insertions, 62 deletions
diff --git a/meta-qat/recipes-extended/openssl-qat/openssl-qat/openssl_qat-build-qat_mem-ko-against-yocto-kernel.patch b/meta-qat/recipes-extended/openssl-qat/openssl-qat/openssl_qat-build-qat_mem-ko-against-yocto-kernel.patch
deleted file mode 100644
index 7c43b56..0000000
--- a/meta-qat/recipes-extended/openssl-qat/openssl-qat/openssl_qat-build-qat_mem-ko-against-yocto-kernel.patch
+++ /dev/null
@@ -1,62 +0,0 @@
1From 3927de1c19b48a031b27b2635928cd6f9650d02e Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Wed, 8 Jul 2015 17:49:09 +0800
4Subject: [PATCH] openssl-qat: build qat_mem ko against yocto kernel
5
6Upstream-Status: Inappropriate [Configuration]
7
8Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
9---
10 engines/qat_engine/qat_mem/Makefile | 23 +++++++----------------
11 1 file changed, 7 insertions(+), 16 deletions(-)
12
13diff --git a/engines/qat_engine/qat_mem/Makefile b/engines/qat_engine/qat_mem/Makefile
14index 3d9a19f..4369503 100644
15--- a/engines/qat_engine/qat_mem/Makefile
16+++ b/engines/qat_engine/qat_mem/Makefile
17@@ -9,23 +9,10 @@
18 MODULENAME := qat_mem
19 ### should not need to change stuff below ######################
20
21-
22-KDIR := /lib/modules/$(shell uname -r)/build
23-#KDIR := /exports/linux-2.6.12.2/
24+KDIR := $(KERNEL_SOURCE_ROOT)
25 PWD := $(shell pwd)
26
27-ifeq ($(shell uname -r|grep -c grsec-WR), 1)
28-AUTO_CONF=/lib/modules/$(shell uname -r)/build/include/generated/autoconf.h
29-else
30-AUTO_CONF=/usr/src/kernels/$(shell uname -r)/include/linux/autoconf.h
31-endif
32-
33-ifdef KERNEL_SOURCE_ROOT
34-AUTO_CONF=$(KERNEL_SOURCE_ROOT)/include/linux/autoconf.h
35-KDIR=$(KERNEL_SOURCE_ROOT)
36-endif
37-
38-CC := gcc -Wall -imacros $(AUTO_CONF)
39+CC := ${CC} -Wall -imacros $(KERNEL_BUILDDIR)/include/generated/autoconf.h
40
41 ifeq ($(KERNELRELEASE),)
42 all: $(MODULENAME)_test
43@@ -38,6 +25,11 @@ endif
44 $(MODULENAME)_test: $(MODULENAME)_test.c
45 $(CC) -g -o $(MODULENAME)_test $(MODULENAME)_test.c
46
47+install: modules_install
48+ cp $(MODULENAME)_test $(DESTDIR)
49+
50+modules_install:
51+ $(MAKE) -C $(KDIR) M=$(PWD) modules_install
52
53 load:
54 insmod ./$(MODULENAME).ko
55@@ -50,4 +42,3 @@ test: all
56
57 clean:
58 rm -f *.o *.ko Modules.symvers *.mod.c .*.cmd $(MODULENAME)_test
59-
60--
611.7.9.5
62