summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAwais Belal <awais_belal@mentor.com>2018-04-11 12:54:31 +0500
committerCalifornia Sullivan <california.l.sullivan@intel.com>2018-04-12 09:00:48 -0700
commitd82b045ffe1a35b328a68b2c27088d2f557ac42e (patch)
tree9c2bbb6e6c055e4026da974100d282757c837b26
parent242f6362a33312f07a4d54541aa61fa1ace52fb2 (diff)
downloadmeta-dpdk-d82b045ffe1a35b328a68b2c27088d2f557ac42e.tar.gz
dpdk: move common fragments to include
This cleans up the versioned recipes and moves the common fragments to the include so to make the maintenance easy. Signed-off-by: Awais Belal <awais_belal@mentor.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
-rw-r--r--recipes-extended/dpdk/dpdk.inc8
-rw-r--r--recipes-extended/dpdk/dpdk_17.11.1.bb10
-rw-r--r--recipes-extended/dpdk/dpdk_18.02.bb10
3 files changed, 7 insertions, 21 deletions
diff --git a/recipes-extended/dpdk/dpdk.inc b/recipes-extended/dpdk/dpdk.inc
index 54af9c6..aa03a67 100644
--- a/recipes-extended/dpdk/dpdk.inc
+++ b/recipes-extended/dpdk/dpdk.inc
@@ -17,7 +17,7 @@ SRC_URI = "git://dpdk.org/dpdk${STABLE};branch=${BRANCH} \
17 17
18COMPATIBLE_MACHINE = "null" 18COMPATIBLE_MACHINE = "null"
19COMPATIBLE_HOST_libc-musl_class-target = "null" 19COMPATIBLE_HOST_libc-musl_class-target = "null"
20 20COMPATIBLE_HOST_linux-gnux32 = "null"
21 21
22# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat. 22# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
23# fuse is in meta-filesystems and qat is not yet upstreamed. 23# fuse is in meta-filesystems and qat is not yet upstreamed.
@@ -56,6 +56,9 @@ export SYSROOTPATH = "--sysroot=${STAGING_DIR_HOST}"
56export DPDK_TARGET_MACH = "${@get_dpdk_target_mach(bb,d)}" 56export DPDK_TARGET_MACH = "${@get_dpdk_target_mach(bb,d)}"
57export ICP_LAC_API_DIR = "${STAGING_DIR_TARGET}${includedir}/lac" 57export ICP_LAC_API_DIR = "${STAGING_DIR_TARGET}${includedir}/lac"
58 58
59export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
60export ARCHDIR = "generic"
61
59# The list of intel Comms platforms and their target machine 62# The list of intel Comms platforms and their target machine
60# process mapping. The supported target machine is listed under 63# process mapping. The supported target machine is listed under
61# dpdk/mk/machine 64# dpdk/mk/machine
@@ -84,6 +87,9 @@ do_configure () {
84 sed -e "s#CONFIG_RTE_LIBRTE_VHOST_NUMA=.*#CONFIG_RTE_LIBRTE_VHOST_NUMA=${CONFIG_HAVE_NUMA}#" -i ${S}/config/common_linuxapp 87 sed -e "s#CONFIG_RTE_LIBRTE_VHOST_NUMA=.*#CONFIG_RTE_LIBRTE_VHOST_NUMA=${CONFIG_HAVE_NUMA}#" -i ${S}/config/common_linuxapp
85 sed -e "s#CONFIG_RTE_EAL_NUMA_AWARE_HUGEPAGES=.*#CONFIG_RTE_EAL_NUMA_AWARE_HUGEPAGES=${CONFIG_HAVE_NUMA}#" -i ${S}/config/common_linuxapp 88 sed -e "s#CONFIG_RTE_EAL_NUMA_AWARE_HUGEPAGES=.*#CONFIG_RTE_EAL_NUMA_AWARE_HUGEPAGES=${CONFIG_HAVE_NUMA}#" -i ${S}/config/common_linuxapp
86 89
90 # Fix-up CONFIG_RTE_LIBRTE_POWER based on package config for libvirt
91 sed -e "s#CONFIG_RTE_LIBRTE_POWER=y#CONFIG_RTE_LIBRTE_POWER=${CONFIG_EXAMPLE_VM_POWER_MANAGER}#" -i ${S}/config/common_linuxapp
92
87 make O=$RTE_TARGET T=$RTE_TARGET config 93 make O=$RTE_TARGET T=$RTE_TARGET config
88} 94}
89 95
diff --git a/recipes-extended/dpdk/dpdk_17.11.1.bb b/recipes-extended/dpdk/dpdk_17.11.1.bb
index 098ba73..4c84281 100644
--- a/recipes-extended/dpdk/dpdk_17.11.1.bb
+++ b/recipes-extended/dpdk/dpdk_17.11.1.bb
@@ -10,13 +10,3 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe\
10 10
11SRC_URI[dpdk.md5sum] = "75a2f0922baadc19dc8a222a7547798a" 11SRC_URI[dpdk.md5sum] = "75a2f0922baadc19dc8a222a7547798a"
12SRC_URI[dpdk.sha256sum] = "47f43a3ef66cc351ab639ae313830dc08760089c7d227e5f73daa0d6df38b201" 12SRC_URI[dpdk.sha256sum] = "47f43a3ef66cc351ab639ae313830dc08760089c7d227e5f73daa0d6df38b201"
13
14export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
15export ARCHDIR = "generic"
16
17do_configure_prepend () {
18 sed -e "s#CONFIG_RTE_LIBRTE_POWER=y#CONFIG_RTE_LIBRTE_POWER=${CONFIG_EXAMPLE_VM_POWER_MANAGER}#" -i ${S}/config/common_linuxapp
19}
20
21COMPATIBLE_HOST_linux-gnux32 = "null"
22COMPATIBLE_HOST_libc-musl_class-target = "null"
diff --git a/recipes-extended/dpdk/dpdk_18.02.bb b/recipes-extended/dpdk/dpdk_18.02.bb
index 2c80aef..6178fb1 100644
--- a/recipes-extended/dpdk/dpdk_18.02.bb
+++ b/recipes-extended/dpdk/dpdk_18.02.bb
@@ -14,13 +14,3 @@ SRC_URI += "\
14 14
15SRC_URI[dpdk.md5sum] = "49d08ced0a978a71cc3942af5cf51b95" 15SRC_URI[dpdk.md5sum] = "49d08ced0a978a71cc3942af5cf51b95"
16SRC_URI[dpdk.sha256sum] = "f1210310fd5f01a3babe3a09d9b3e5a9db791c2ec6ecfbf94ade9f893a0632b8" 16SRC_URI[dpdk.sha256sum] = "f1210310fd5f01a3babe3a09d9b3e5a9db791c2ec6ecfbf94ade9f893a0632b8"
17
18export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
19export ARCHDIR = "generic"
20
21do_configure_prepend () {
22 sed -e "s#CONFIG_RTE_LIBRTE_POWER=y#CONFIG_RTE_LIBRTE_POWER=${CONFIG_EXAMPLE_VM_POWER_MANAGER}#" -i ${S}/config/common_linuxapp
23}
24
25COMPATIBLE_HOST_linux-gnux32 = "null"
26COMPATIBLE_HOST_libc-musl_class-target = "null"