summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHe Zhe <zhe.he@windriver.com>2020-03-24 17:24:02 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-03-25 16:15:05 +0800
commit99b7249250bc3f8aecdc4d561716c8d2467dc2c4 (patch)
tree74981a8e41a8fc4b035874cdc789164de7d85708
parentf290fa81c66df3b879a6286d3a864ff81b856493 (diff)
downloadmeta-dpdk-99b7249250bc3f8aecdc4d561716c8d2467dc2c4.tar.gz
dpdk: Backport to fix build failure for kernel v5.6
kernel/linux/kni/kni_net.c:786:20: error: initialization of 'void (*)(struct net_device *, unsigned int)' from incompatible pointer type 'void (*)(struct net_device *)' [-Werror=incompatible-pointer-types] 786 | .ndo_tx_timeout = kni_net_tx_timeout, | ^~~~~~~~~~~~~~~~~~ Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-extended/dpdk/dpdk/0001-kni-fix-build-with-Linux-5.6.patch57
-rw-r--r--recipes-extended/dpdk/dpdk_19.11.0.bb2
2 files changed, 59 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk/0001-kni-fix-build-with-Linux-5.6.patch b/recipes-extended/dpdk/dpdk/0001-kni-fix-build-with-Linux-5.6.patch
new file mode 100644
index 0000000..28897cb
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk/0001-kni-fix-build-with-Linux-5.6.patch
@@ -0,0 +1,57 @@
1From 38ad54f3bc7614b53bd6ca3644a471a3842502fc Mon Sep 17 00:00:00 2001
2From: Ferruh Yigit <ferruh.yigit@intel.com>
3Date: Wed, 12 Feb 2020 17:14:24 +0000
4Subject: [PATCH] kni: fix build with Linux 5.6
5
6With the following Linux commit a new parameter 'txqueue' has been added
7to 'ndo_tx_timeout' ndo:
8commit 0290bd291cc0 ("netdev: pass the stuck queue to the timeout handler")
9
10The change reflected to the KNI with version check.
11
12Cc: stable@dpdk.org
13
14Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com>
15Acked-by: David Marchand <david.marchand@redhat.com>
16
17Upstream-Status: Backport [38ad54f3bc7614b53bd6ca3644a471a3842502fc]
18
19Signed-off-by: He Zhe <zhe.he@windriver.com>
20---
21 kernel/linux/kni/compat.h | 4 ++++
22 kernel/linux/kni/kni_net.c | 5 +++++
23 2 files changed, 9 insertions(+)
24
25diff --git a/kernel/linux/kni/compat.h b/kernel/linux/kni/compat.h
26index 7109474..9ee45db 100644
27--- a/kernel/linux/kni/compat.h
28+++ b/kernel/linux/kni/compat.h
29@@ -130,3 +130,7 @@
30 #if KERNEL_VERSION(4, 10, 0) <= LINUX_VERSION_CODE
31 #define HAVE_IOVA_TO_KVA_MAPPING_SUPPORT
32 #endif
33+
34+#if KERNEL_VERSION(5, 6, 0) <= LINUX_VERSION_CODE
35+#define HAVE_TX_TIMEOUT_TXQUEUE
36+#endif
37diff --git a/kernel/linux/kni/kni_net.c b/kernel/linux/kni/kni_net.c
38index 97fe85b..c82c881 100644
39--- a/kernel/linux/kni/kni_net.c
40+++ b/kernel/linux/kni/kni_net.c
41@@ -623,8 +623,13 @@ kni_net_rx(struct kni_dev *kni)
42 /*
43 * Deal with a transmit timeout.
44 */
45+#ifdef HAVE_TX_TIMEOUT_TXQUEUE
46+static void
47+kni_net_tx_timeout(struct net_device *dev, unsigned int txqueue)
48+#else
49 static void
50 kni_net_tx_timeout(struct net_device *dev)
51+#endif
52 {
53 pr_debug("Transmit timeout at %ld, latency %ld\n", jiffies,
54 jiffies - dev_trans_start(dev));
55--
562.7.4
57
diff --git a/recipes-extended/dpdk/dpdk_19.11.0.bb b/recipes-extended/dpdk/dpdk_19.11.0.bb
index 7a6b9d8..9046ae1 100644
--- a/recipes-extended/dpdk/dpdk_19.11.0.bb
+++ b/recipes-extended/dpdk/dpdk_19.11.0.bb
@@ -10,6 +10,8 @@ LIC_FILES_CHKSUM = "file://license/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4
10 file://license/lgpl-2.1.txt;md5=4b54a1fd55a448865a0b32d41598759d \ 10 file://license/lgpl-2.1.txt;md5=4b54a1fd55a448865a0b32d41598759d \
11 file://license/bsd-3-clause.txt;md5=0f00d99239d922ffd13cabef83b33444" 11 file://license/bsd-3-clause.txt;md5=0f00d99239d922ffd13cabef83b33444"
12 12
13SRC_URI += "file://0001-kni-fix-build-with-Linux-5.6.patch"
14
13do_install_append () { 15do_install_append () {
14 # Remove the unneeded dir 16 # Remove the unneeded dir
15 rm -rf ${D}/${INSTALL_PATH}/${RTE_TARGET}/app 17 rm -rf ${D}/${INSTALL_PATH}/${RTE_TARGET}/app