summaryrefslogtreecommitdiffstats
path: root/recipes-support/spice/spice_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/spice/spice_git.bb')
-rw-r--r--recipes-support/spice/spice_git.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/recipes-support/spice/spice_git.bb b/recipes-support/spice/spice_git.bb
new file mode 100644
index 0000000..900259a
--- /dev/null
+++ b/recipes-support/spice/spice_git.bb
@@ -0,0 +1,63 @@
1#
2# Copyright (C) 2013 Wind River Systems, Inc.
3#
4
5SUMMARY = "Simple Protocol for Independent Computing Environments"
6DESCRIPTION = "SPICE (the Simple Protocol for Independent Computing \
7Environments) is a remote-display system built for virtual \
8environments which allows users to view a computing 'desktop' \
9environment - not only on its computer-server machine, but also from \
10anywhere on the Internet and using a wide variety of machine \
11architectures."
12
13LICENSE = "LGPLv2.1+"
14LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
15
16PR = "r0"
17PV = "0.12.4"
18
19# Actual versions based on the checkouts below
20# spice = "0.12.4"
21# common = "0.12.6"
22# protocol = "0.12.6"
23SRCREV_spice = "b270fb010a3ddb432dfe6b15e4bdffa6ac086cd0"
24SRCREV_spice-common = "fe93908238196bd632287fc9875e6f2e11105d04"
25SRCREV_spice-protocol = "784407f248e7f99d2bfcc9368f9acd1efb2b9617"
26
27SRC_URI = "git://anongit.freedesktop.org/spice/spice;name=spice \
28 git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/spice-common;name=spice-common \
29 git://anongit.freedesktop.org/spice/spice-protocol;destsuffix=git/spice-common/spice-protocol;name=spice-protocol \
30 "
31
32SRC_URI += "file://spice-fix-CVE-2013-4282.patch"
33
34S = "${WORKDIR}/git"
35
36inherit autotools gettext pythonnative python-dir pkgconfig
37
38DEPENDS += "python-native celt051 python-pyparsing jpeg pixman alsa-lib glib-2.0"
39
40EXTRA_OECONF_append = " -Wnone"
41EXTRA_AUTORECONF_append = " -Wnone"
42
43export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python"
44export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages"
45
46PACKAGECONFIG ?= "sasl"
47
48PACKAGECONFIG[smartcard] = "--enable-smartcard,--disable-smartcard,libcacard,"
49PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl,"
50PACKAGECONFIG[client] = "--enable-client,--disable-client,,"
51PACKAGECONFIG[gui] = "--enable-gui,--disable-gui,,"
52PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,,"
53
54PACKAGES =+ "${PN}-protocol"
55LICENSE_${PN}-protocol = "BSD"
56FILES_${PN}-protocol += "${includedir}/spice-1"
57FILES_${PN}-protocol += "${datadir}/pkgconfig"
58
59do_install_append() {
60 cd ${S}/spice-common/spice-protocol
61 oe_runmake DESTDIR="${D}" install
62 cd -
63}