summaryrefslogtreecommitdiffstats
path: root/recipes-support/openldap/openldap-2.4.39/fix-ftbfs-binutils-gold.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/openldap/openldap-2.4.39/fix-ftbfs-binutils-gold.patch')
-rw-r--r--recipes-support/openldap/openldap-2.4.39/fix-ftbfs-binutils-gold.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/recipes-support/openldap/openldap-2.4.39/fix-ftbfs-binutils-gold.patch b/recipes-support/openldap/openldap-2.4.39/fix-ftbfs-binutils-gold.patch
new file mode 100644
index 0000000..1f0ca88
--- /dev/null
+++ b/recipes-support/openldap/openldap-2.4.39/fix-ftbfs-binutils-gold.patch
@@ -0,0 +1,64 @@
1--- a/configure.in
2+++ b/configure.in
3@@ -1214,7 +1214,7 @@ if test $ol_link_tls = no ; then
4 ol_with_tls=gnutls
5 ol_link_tls=yes
6
7- TLS_LIBS="-lgnutls"
8+ TLS_LIBS="-lgnutls -lgcrypt"
9
10 AC_DEFINE(HAVE_GNUTLS, 1,
11 [define if you have GNUtls])
12--- a/libraries/libldap/Makefile.in
13+++ b/libraries/libldap/Makefile.in
14@@ -51,21 +51,21 @@ LIB_DEFS = -DLDAP_LIBRARY
15 XLIBS = $(LIBRARY) $(LDAP_LIBLBER_LA) $(LDAP_LIBLUTIL_A)
16 XXLIBS = $(SECURITY_LIBS) $(LUTIL_LIBS)
17 NT_LINK_LIBS = $(LDAP_LIBLBER_LA) $(AC_LIBS) $(SECURITY_LIBS)
18-UNIX_LINK_LIBS = $(LDAP_LIBLBER_LA) $(AC_LIBS) $(SECURITY_LIBS)
19+UNIX_LINK_LIBS = $(LDAP_LIBLBER_LA) $(AC_LIBS) $(SECURITY_LIBS) $(TLS_LIBS)
20 ifneq (,$(VERSION_OPTION))
21 VERSION_FLAGS = $(VERSION_OPTION)$(srcdir)/libldap.map
22 endif
23
24 apitest: $(XLIBS) apitest.o
25- $(LTLINK) -o $@ apitest.o $(LIBS)
26+ $(LTLINK) -o $@ apitest.o $(LIBS) $(TLS_LIBS)
27 dntest: $(XLIBS) dntest.o
28- $(LTLINK) -o $@ dntest.o $(LIBS)
29+ $(LTLINK) -o $@ dntest.o $(LIBS) $(TLS_LIBS)
30 ftest: $(XLIBS) ftest.o
31- $(LTLINK) -o $@ ftest.o $(LIBS)
32+ $(LTLINK) -o $@ ftest.o $(LIBS) $(TLS_LIBS)
33 ltest: $(XLIBS) test.o
34- $(LTLINK) -o $@ test.o $(LIBS)
35+ $(LTLINK) -o $@ test.o $(LIBS) $(TLS_LIBS)
36 urltest: $(XLIBS) urltest.o
37- $(LTLINK) -o $@ urltest.o $(LIBS)
38+ $(LTLINK) -o $@ urltest.o $(LIBS) $(TLS_LIBS)
39
40 CFFILES=ldap.conf
41
42--- a/libraries/libldap_r/Makefile.in
43+++ b/libraries/libldap_r/Makefile.in
44@@ -60,7 +60,7 @@ XLIBS = $(LIBRARY) $(LDAP_LIBLBER_LA) $(
45 XXLIBS = $(SECURITY_LIBS) $(LUTIL_LIBS)
46 XXXLIBS = $(LTHREAD_LIBS)
47 NT_LINK_LIBS = $(LDAP_LIBLBER_LA) $(AC_LIBS) $(SECURITY_LIBS)
48-UNIX_LINK_LIBS = $(LDAP_LIBLBER_LA) $(AC_LIBS) $(SECURITY_LIBS) $(LTHREAD_LIBS)
49+UNIX_LINK_LIBS = $(LDAP_LIBLBER_LA) $(AC_LIBS) $(SECURITY_LIBS) $(LTHREAD_LIBS) $(TLS_LIBS)
50 ifneq (,$(VERSION_OPTION))
51 VERSION_FLAGS = "$(VERSION_OPTION)$(XXDIR)/libldap.map"
52 endif
53@@ -80,9 +80,9 @@ clean-local: FORCE
54 depend-common: .links
55
56 apitest: $(XLIBS) apitest.o
57- $(LTLINK) -o $@ apitest.o $(LIBS)
58+ $(LTLINK) -o $@ apitest.o $(LIBS) $(TLS_LIBS)
59 ltest: $(XLIBS) test.o
60- $(LTLINK) -o $@ test.o $(LIBS)
61+ $(LTLINK) -o $@ test.o $(LIBS) $(TLS_LIBS)
62
63 install-local: $(CFFILES) FORCE
64 -$(MKDIR) $(DESTDIR)$(libdir)