summaryrefslogtreecommitdiffstats
path: root/recipes-support/openldap/openldap-2.4.39/contrib-modules-use-dpkg-buildflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/openldap/openldap-2.4.39/contrib-modules-use-dpkg-buildflags.patch')
-rw-r--r--recipes-support/openldap/openldap-2.4.39/contrib-modules-use-dpkg-buildflags.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-support/openldap/openldap-2.4.39/contrib-modules-use-dpkg-buildflags.patch b/recipes-support/openldap/openldap-2.4.39/contrib-modules-use-dpkg-buildflags.patch
new file mode 100644
index 0000000..1b15529
--- /dev/null
+++ b/recipes-support/openldap/openldap-2.4.39/contrib-modules-use-dpkg-buildflags.patch
@@ -0,0 +1,40 @@
1Description: pass CFLAGS to contrib builds
2 $(CFLAGS) is missing from the compiler invocations for autogroup and
3 smbk5pwd, which means they're not being hardened.
4Author: Simon Ruderich <simon@ruderich.org>
5Bug-Debian: http://bugs.debian.org/663724
6
7--- a/contrib/slapd-modules/autogroup/Makefile
8+++ b/contrib/slapd-modules/autogroup/Makefile
9@@ -27,12 +27,12 @@ moduledir = $(libexecdir)$(ldap_subdir)
10 .SUFFIXES: .c .o .lo
11
12 .c.lo:
13- $(LIBTOOL) --mode=compile $(CC) $(OPT) $(DEFS) $(INCS) -c $<
14+ $(LIBTOOL) --mode=compile $(CC) $(OPT) $(CFLAGS) $(DEFS) $(INCS) -c $<
15
16 all: $(PROGRAMS)
17
18 autogroup.la: autogroup.lo
19- $(LIBTOOL) --mode=link $(CC) $(OPT) -version-info $(LTVER) \
20+ $(LIBTOOL) --mode=link $(CC) $(OPT) $(LDFLAGS) -version-info $(LTVER) \
21 -rpath $(moduledir) -module -o $@ $? $(LIBS)
22
23 clean:
24--- a/contrib/slapd-modules/smbk5pwd/Makefile
25+++ b/contrib/slapd-modules/smbk5pwd/Makefile
26@@ -46,12 +46,12 @@ moduledir = $(libexecdir)$(ldap_subdir)
27 .SUFFIXES: .c .o .lo
28
29 .c.lo:
30- $(LIBTOOL) --mode=compile $(CC) $(OPT) $(DEFS) $(INCS) -c $<
31+ $(LIBTOOL) --mode=compile $(CC) $(OPT) $(CFLAGS) $(DEFS) $(INCS) -c $<
32
33 all: $(PROGRAMS)
34
35 smbk5pwd.la: smbk5pwd.lo
36- $(LIBTOOL) --mode=link $(CC) $(OPT) -version-info $(LTVER) \
37+ $(LIBTOOL) --mode=link $(CC) $(OPT) $(LDFLAGS) -version-info $(LTVER) \
38 -rpath $(moduledir) -module -o $@ $? $(LIBS)
39
40 clean: