summaryrefslogtreecommitdiffstats
path: root/recipes-support/openldap/openldap-2.4.39/autogroup-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/openldap/openldap-2.4.39/autogroup-makefile.patch')
-rw-r--r--recipes-support/openldap/openldap-2.4.39/autogroup-makefile.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-support/openldap/openldap-2.4.39/autogroup-makefile.patch b/recipes-support/openldap/openldap-2.4.39/autogroup-makefile.patch
new file mode 100644
index 0000000..d3f56c3
--- /dev/null
+++ b/recipes-support/openldap/openldap-2.4.39/autogroup-makefile.patch
@@ -0,0 +1,35 @@
1--- a/contrib/slapd-modules/autogroup/Makefile
2+++ b/contrib/slapd-modules/autogroup/Makefile
3@@ -2,11 +2,11 @@
4
5 LDAP_SRC = ../../..
6 LDAP_BUILD = ../../..
7-LDAP_INC = -I$(LDAP_BUILD)/include -I$(LDAP_SRC)/include -I$(LDAP_SRC)/servers/slapd
8-LDAP_LIB = $(LDAP_BUILD)/libraries/libldap_r/libldap_r.la \
9- $(LDAP_BUILD)/libraries/liblber/liblber.la
10+LDAP_INC = -I$(LDAP_BUILD)/debian/build/include -I$(LDAP_BUILD)/include -I$(LDAP_SRC)/include -I$(LDAP_SRC)/servers/slapd
11+LDAP_LIB = $(LDAP_BUILD)/debian/build/libraries/libldap_r/libldap_r.la \
12+ $(LDAP_BUILD)/debian/build/libraries/liblber/liblber.la
13
14-LIBTOOL = $(LDAP_BUILD)/libtool
15+LIBTOOL = $(LDAP_BUILD)/debian/build/libtool
16 CC = gcc
17 OPT = -g -O2 -Wall
18 DEFS =
19@@ -16,13 +16,13 @@ LIBS = $(LDAP_LIB)
20 PROGRAMS = autogroup.la
21 LTVER = 0:0:0
22
23-prefix=/usr/local
24+prefix=/usr
25 exec_prefix=$(prefix)
26-ldap_subdir=/openldap
27+ldap_subdir=/ldap
28
29 libdir=$(exec_prefix)/lib
30 libexecdir=$(exec_prefix)/libexec
31-moduledir = $(libexecdir)$(ldap_subdir)
32+moduledir = $(libdir)$(ldap_subdir)
33
34 .SUFFIXES: .c .o .lo
35