summaryrefslogtreecommitdiffstats
path: root/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb')
-rw-r--r--recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb b/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
new file mode 100644
index 0000000..a309c1e
--- /dev/null
+++ b/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
@@ -0,0 +1,59 @@
1SUMMARY = "NSS and PAM module for using LDAP as a naming service"
2DESCRIPTION = "\
3 daemon for NSS and PAM lookups using LDAP \
4 This package provides a daemon for retrieving user accounts and similar \
5 system information from LDAP. It is used by the libnss-ldapd and \
6 libpam-ldapd packages but is not very useful by itself. \
7 "
8
9HOMEPAGE = "http://arthurdejong.org/nss-pam-ldapd/"
10
11LICENSE = "LGPLv2.1"
12LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
13SECTION = "base"
14
15FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
16
17SRC_URI = "\
18 http://arthurdejong.org/nss-pam-ldapd/${PN}-${PV}.tar.gz \
19 file://nslcd.init \
20 file://nslcd.service \
21 "
22
23inherit autotools
24
25SRC_URI[md5sum] = "8c99fdc54f4bf9aca8c5f53fdb1403ff"
26SRC_URI[sha256sum] = "ef7362e7f2003da8c7beb7bcc03c30494acf712625aaac8badc6e7eb16f3453f"
27
28DEPENDS += "libpam openldap"
29
30EXTRA_OECONF = "\
31 --disable-pynslcd \
32 --libdir=${base_libdir} \
33 --with-pam-seclib-dir=${base_libdir}/security \
34 "
35
36CONFFILES_${PN} += "${sysconfdir}/nslcd.conf"
37
38FILES_${PN} += "${base_libdir}/security ${datadir}"
39FILES_${PN}-dbg += "${base_libdir}/security/.debug"
40
41LDAP_DN ?= "dc=my-domain,dc=com"
42
43do_install_append() {
44 install -D -m 0755 ${WORKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd
45
46 sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf
47 sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf
48 sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf
49
50 install -d ${D}${systemd_unitdir}/system
51 install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_unitdir}/system
52}
53
54inherit update-rc.d systemd
55
56INITSCRIPT_NAME = "nslcd"
57INITSCRIPT_PARAMS = "defaults"
58
59SYSTEMD_SERVICE_${PN} = "nslcd.service"