summaryrefslogtreecommitdiffstats
path: root/recipes-extended/glusterfs/glusterfs.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/glusterfs/glusterfs.inc')
-rw-r--r--recipes-extended/glusterfs/glusterfs.inc24
1 files changed, 10 insertions, 14 deletions
diff --git a/recipes-extended/glusterfs/glusterfs.inc b/recipes-extended/glusterfs/glusterfs.inc
index f7d3cc3..17aaf75 100644
--- a/recipes-extended/glusterfs/glusterfs.inc
+++ b/recipes-extended/glusterfs/glusterfs.inc
@@ -11,7 +11,7 @@ SECTION = "console/network"
11SRC_URI += "file://glusterd.init \ 11SRC_URI += "file://glusterd.init \
12 file://glusterd.service \ 12 file://glusterd.service \
13 file://glusterfs-configure-automake-with-subdir-objects-for.patch \ 13 file://glusterfs-configure-automake-with-subdir-objects-for.patch \
14 file://xlator-host-contamination-3.4.patch \ 14 file://xlator-host-contamination-5.4.patch \
15 file://glusterfs-disable-default-startup-scripts.patch \ 15 file://glusterfs-disable-default-startup-scripts.patch \
16 file://glusterfs-api-remove-unnecessary-library-options.patch \ 16 file://glusterfs-api-remove-unnecessary-library-options.patch \
17 file://python-work-around-host-and-target-python.patch \ 17 file://python-work-around-host-and-target-python.patch \
@@ -20,15 +20,6 @@ SRC_URI += "file://glusterd.init \
20 file://libglusterfs-Don-t-link-against-libfl.patch \ 20 file://libglusterfs-Don-t-link-against-libfl.patch \
21 file://glusterd-change-port-range.patch \ 21 file://glusterd-change-port-range.patch \
22 file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \ 22 file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \
23 file://0001-shared-storage-Prevent-mounting-shared-storage-from-.patch \
24 file://0002-server-auth-add-option-for-strict-authentication.patch \
25 file://0003-glusterfs-access-trusted-peer-group-via-remote-host-.patch \
26 file://0001-dict-handle-negative-key-value-length-while-unserial.patch \
27 file://0002-posix-disable-open-read-write-on-special-files.patch \
28 file://0003-server-protocol-don-t-allow-.-path-in-name.patch \
29 file://0004-io-stats-dump-io-stats-info-in-var-run-gluster.patch \
30 file://0006-posix-remove-not-supported-get-set-content.patch \
31 file://0007-protocol-don-t-use-alloca.patch \
32 " 23 "
33 24
34LICENSE = "(LGPLv3+ | GPLv2) & GPLv3+ & LGPLv3+ & GPLv2+ & LGPLv2+ & LGPLv2.1+ & Apache-2.0" 25LICENSE = "(LGPLv3+ | GPLv2) & GPLv3+ & LGPLv3+ & GPLv2+ & LGPLv2+ & LGPLv2.1+ & Apache-2.0"
@@ -38,8 +29,8 @@ LIC_FILES_CHKSUM = "file://COPYING-GPLV2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
38 29
39inherit autotools pkgconfig distutils-base update-rc.d systemd 30inherit autotools pkgconfig distutils-base update-rc.d systemd
40 31
41DEPENDS += "bison-native flex-native python-native fuse libaio libtirpc libxml2 ncurses \ 32DEPENDS += "bison-native flex-native python3-native fuse libaio libtirpc libxml2 ncurses \
42 openssl python readline zlib liburcu util-linux glib-2.0 acl" 33 openssl python3 readline zlib liburcu util-linux glib-2.0 acl"
43 34
44# rpc now comes from libtirpc instead of glibc 35# rpc now comes from libtirpc instead of glibc
45# 36#
@@ -49,6 +40,7 @@ LDFLAGS += " -ltirpc"
49EXTRA_OECONF = "ac_cv_file__etc_debian_version=no \ 40EXTRA_OECONF = "ac_cv_file__etc_debian_version=no \
50 ac_cv_file__etc_SuSE_release=no \ 41 ac_cv_file__etc_SuSE_release=no \
51 ac_cv_file__etc_redhat_release=no \ 42 ac_cv_file__etc_redhat_release=no \
43 ac_cv_file__etc_centos_release=no \
52 --with-mountutildir=${sbindir} \ 44 --with-mountutildir=${sbindir} \
53 --disable-fusermount \ 45 --disable-fusermount \
54 TARGET_PYTHON=${bindir}/python \ 46 TARGET_PYTHON=${bindir}/python \
@@ -64,7 +56,7 @@ PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,,"
64PACKAGECONFIG[georeplication] = "--enable-georeplication,--disable-georeplication,,rsync" 56PACKAGECONFIG[georeplication] = "--enable-georeplication,--disable-georeplication,,rsync"
65PACKAGECONFIG[libibverbs] = "--enable-ibverbs,--disable-ibverbs,virtual/libibverbs librdmacm," 57PACKAGECONFIG[libibverbs] = "--enable-ibverbs,--disable-ibverbs,virtual/libibverbs librdmacm,"
66PACKAGECONFIG[ocf] = "--with-ocf,--without-ocf,," 58PACKAGECONFIG[ocf] = "--with-ocf,--without-ocf,,"
67PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind," 59PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
68 60
69do_install_append() { 61do_install_append() {
70 install -d ${D}${sysconfdir}/init.d 62 install -d ${D}${sysconfdir}/init.d
@@ -123,9 +115,10 @@ INSANE_SKIP_${PN}-server += "dev-so"
123PACKAGES += "${PN}-rdma ${PN}-geo-replication ${PN}-fuse ${PN}-server \ 115PACKAGES += "${PN}-rdma ${PN}-geo-replication ${PN}-fuse ${PN}-server \
124 ${PN}-api ${PN}-ocf" 116 ${PN}-api ${PN}-ocf"
125 117
126RDEPENDS_${PN} += "python python-json python-ctypes bash" 118RDEPENDS_${PN} += "python3-core python-json python-ctypes bash"
127RDEPENDS_${PN}-ocf += "bash" 119RDEPENDS_${PN}-ocf += "bash"
128RDEPENDS_${PN}-server += "bash" 120RDEPENDS_${PN}-server += "bash"
121RDEPENDS_${PN}-geo-replication += "python3"
129 122
130FILES_${PN}-dbg += "${libdir}/glusterfs/${PV}/*/.debug \ 123FILES_${PN}-dbg += "${libdir}/glusterfs/${PV}/*/.debug \
131 ${libdir}/glusterfs/${PV}/*/*/.debug \ 124 ${libdir}/glusterfs/${PV}/*/*/.debug \
@@ -142,6 +135,7 @@ FILES_${PN} = "${libdir}/glusterfs/${PV}/auth \
142 ${libdir}/glusterfs/${PV}/xlator/protocol/client* \ 135 ${libdir}/glusterfs/${PV}/xlator/protocol/client* \
143 ${libdir}/glusterfs/${PV}/xlator/system \ 136 ${libdir}/glusterfs/${PV}/xlator/system \
144 ${libdir}/glusterfs/${PV}/xlator/testing \ 137 ${libdir}/glusterfs/${PV}/xlator/testing \
138 ${libdir}/glusterfs/${PV}/xlator/playground \
145 ${libdir}/glusterfs/${PV}/xlator/meta.so \ 139 ${libdir}/glusterfs/${PV}/xlator/meta.so \
146 ${libdir}/glusterfs/ganesha \ 140 ${libdir}/glusterfs/ganesha \
147 ${libdir}/glusterfs/glusterfs/glusterfind \ 141 ${libdir}/glusterfs/glusterfs/glusterfind \
@@ -154,6 +148,7 @@ FILES_${PN} = "${libdir}/glusterfs/${PV}/auth \
154 ${libdir}/libgfdb.so.* \ 148 ${libdir}/libgfdb.so.* \
155 ${libdir}/libgfxdr.so.* \ 149 ${libdir}/libgfxdr.so.* \
156 ${libdir}/python*/site-packages \ 150 ${libdir}/python*/site-packages \
151 ${libexecdir}/glusterfs/gfevents \
157 ${libexecdir}/glusterfs/events \ 152 ${libexecdir}/glusterfs/events \
158 ${libexecdir}/glusterfs/glusterfind \ 153 ${libexecdir}/glusterfs/glusterfind \
159 ${libexecdir}/glusterfs/gfind_missing_files \ 154 ${libexecdir}/glusterfs/gfind_missing_files \
@@ -174,6 +169,7 @@ FILES_${PN} = "${libdir}/glusterfs/${PV}/auth \
174 ${sbindir}/glustereventsd \ 169 ${sbindir}/glustereventsd \
175 ${sbindir}/gf_attach \ 170 ${sbindir}/gf_attach \
176 ${sbindir}/*.py \ 171 ${sbindir}/*.py \
172 ${sbindir}/gluster-setgfid2path \
177 ${bindir}/ \ 173 ${bindir}/ \
178 ${sysconfdir}/glusterfs \ 174 ${sysconfdir}/glusterfs \
179 ${sysconfdir}/ganesha \ 175 ${sysconfdir}/ganesha \