summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/consul/consul_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/consul/consul_git.bb')
-rw-r--r--recipes-connectivity/consul/consul_git.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
new file mode 100644
index 0000000..bcfb5aa
--- /dev/null
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -0,0 +1,67 @@
1DESCRIPTION = "A tool for discovering and configuring services in your infrastructure"
2HOMEPAGE = "https://www.consul.io/"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b278a92d2c1509760384428817710378"
5
6DEPENDS += "circbuf \
7 consul-migrate \
8 go-checkpoint \
9 go-msgpack \
10 go-metrics \
11 go-bindata \
12 go-sys \
13 go-syslog \
14 dockerclient \
15 logutils \
16 memberlist \
17 raft \
18 raft-boltdb \
19 scada-client \
20 serf-go \
21 yamux \
22 muxado \
23 dns \
24 cli \
25 mapstructure \
26 copystructure \
27 reflectwalk \
28 columnize \
29 go-radix \
30 golang-lru \
31 hashicorp-hil \
32 hashicorp-hcl \
33 hashicorp-go-cleanhttp \
34 hashicorp-go-memdb \
35 hashicorp-go-reap \
36 hashicorp-go-uuid \
37 net-rpc-msgpackrpc \
38 "
39
40PKG_NAME = "github.com/hashicorp/consul"
41SRC_URI = "git://${PKG_NAME}.git \
42 file://consul.service \
43 file://0001-prepared_query-make-compatible-with-go1.5.patch \
44 "
45SRCREV = "f97afda8e15046b41d951bf3b4220372c45df7ab"
46
47CCACHE = ""
48
49inherit systemd golang
50
51INSANE_SKIP_${PN} += "ldflags"
52
53SYSTEMD_SERVICE_${PN} = "consul.service"
54SYSTEMD_AUTO_ENABLE_${PN} = "enable"
55
56export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
57
58#Stops go from installing and testing the package
59do_configure(){
60}
61
62do_install_append() {
63 install -d ${D}/${systemd_unitdir}/system
64 cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system
65}
66
67FILES_${PN} += "${systemd_unitdir}/system"