summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-xenapi_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-os-xenapi_git.bb b/meta-openstack/recipes-devtools/python/python-os-xenapi_git.bb
new file mode 100644
index 0000000..f3d54f6
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-os-xenapi_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "XenAPI library for OpenStack projects."
2HOMEPAGE = "https://github.com/openstack/os-xenapi"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRCNAME = "os-xenapi"
8SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master"
9
10PV = "0.3.1+git${SRCPV}"
11SRCREV = "7dce682e2ab0c14236dbc58a38c925536b3b6f8d"
12S = "${WORKDIR}/git"
13
14inherit setuptools
15
16# DEPENDS_default: python-pip
17
18DEPENDS += " \
19 python-pbr \
20 "
21
22RDEPENDS_${PN} += " \
23 python-pbr \
24 python-babel \
25 python-eventlet \
26 python-oslo.concurrency \
27 python-oslo.log \
28 python-oslo.utils \
29 python-oslo.i18n \
30 python-six \
31 "