summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-falcon_0.1.8.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-falcon_0.1.8.bb b/meta-openstack/recipes-devtools/python/python-falcon_0.1.8.bb
new file mode 100644
index 0000000..152aff6
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-falcon_0.1.8.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "An unladen web framework for building APIs and app backends."
2HOMEPAGE = "http://falconframework.org"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://README.rst;md5=795813ca586f7662f91b9ff2265f4bc5"
6
7PR = "r0"
8
9SRCNAME = "falcon"
10SRC_URI = "http://pypi.python.org/packages/source/f/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "82049bd4a6a3e2ec4bb7ea59955a2493"
13SRC_URI[sha256sum] = "dafccf547df57324993c8c13a0e40629b61817e0462f04c7e44fed12f26ff556"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# conflicting file prevention
20do_install_append() {
21 rm -f ${D}${libdir}/python*/site-packages/tests/*
22}
23
24DEPENDS += " \
25 python-pip \
26 "
27
28RDEPENDS_${PN} += " \
29 python-six \
30 python-mimeparse \
31 "