summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinderclient_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-heatclient_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutronclient/neutronclient-use-csv-flag-instead-of-json.patch33
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutronclient_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-novaclient_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-saharaclient_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-swiftclient_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-troveclient_git.bb4
10 files changed, 30 insertions, 33 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
index a82344f..d134e5b 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
@@ -26,7 +26,7 @@ SRC_URI = "\
26 " 26 "
27 27
28PV="1.0.10+git${SRCPV}" 28PV="1.0.10+git${SRCPV}"
29SRCREV="5c8a85e3861c0e90ef63325956ca809edca5719a" 29SRCREV="d4bada707b863c875b9f05a8c62c494a9a2f778d"
30S = "${WORKDIR}/git" 30S = "${WORKDIR}/git"
31 31
32inherit setuptools 32inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
index 442d365..c50b84f 100644
--- a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
@@ -13,8 +13,8 @@ SRC_URI = "\
13 file://fix_cinderclient_memory_leak.patch \ 13 file://fix_cinderclient_memory_leak.patch \
14 " 14 "
15 15
16PV="1.0.9+git${SRCPV}" 16PV="1.1.0+git${SRCPV}"
17SRCREV="0c4010e7fbc9939905e8647afbe1358c384dc658" 17SRCREV="4c8464114f5539706cffc6888ce007d0d3ceba16"
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
20inherit setuptools 20inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
index a492ab5..6f70511 100644
--- a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
@@ -24,7 +24,7 @@ SRCNAME = "heatclient"
24SRC_URI = "git://github.com/openstack/python-heatclient.git;branch=master" 24SRC_URI = "git://github.com/openstack/python-heatclient.git;branch=master"
25 25
26PV="0.2.10+git${SRCPV}" 26PV="0.2.10+git${SRCPV}"
27SRCREV="a98c1f3617604c4871263ff9cc986b27f302ef46" 27SRCREV="95841b563340c494d8ef746261213c22e19c94ac"
28S = "${WORKDIR}/git" 28S = "${WORKDIR}/git"
29 29
30inherit setuptools 30inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
index d0e4569..e0c81db 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
@@ -13,8 +13,8 @@ SRC_URI = "\
13 file://keystoneclient-fix-test-path-to-example-certificates.patch \ 13 file://keystoneclient-fix-test-path-to-example-certificates.patch \
14 " 14 "
15 15
16PV="0.9.0+git${SRCPV}" 16PV="0.10.1+git${SRCPV}"
17SRCREV="679689f70748b1b28a14ecd29161f98881d80662" 17SRCREV="3305c7be4b726de4dcc889006d0be30eb46d3ad9"
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
20inherit setuptools 20inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-neutronclient/neutronclient-use-csv-flag-instead-of-json.patch b/meta-openstack/recipes-devtools/python/python-neutronclient/neutronclient-use-csv-flag-instead-of-json.patch
index d9fade3..32541eb 100644
--- a/meta-openstack/recipes-devtools/python/python-neutronclient/neutronclient-use-csv-flag-instead-of-json.patch
+++ b/meta-openstack/recipes-devtools/python/python-neutronclient/neutronclient-use-csv-flag-instead-of-json.patch
@@ -17,11 +17,11 @@ Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
17 neutronclient/tests/unit/test_cli20_network.py | 4 ++-- 17 neutronclient/tests/unit/test_cli20_network.py | 4 ++--
18 2 files changed, 4 insertions(+), 4 deletions(-) 18 2 files changed, 4 insertions(+), 4 deletions(-)
19 19
20diff --git a/neutronclient/tests/unit/test_cli20_agents.py b/neutronclient/tests/unit/test_cli20_agents.py 20Index: git/neutronclient/tests/unit/test_cli20_agents.py
21index 1e75a92..ab01fb7 100644 21===================================================================
22--- a/neutronclient/tests/unit/test_cli20_agents.py 22--- git.orig/neutronclient/tests/unit/test_cli20_agents.py
23+++ b/neutronclient/tests/unit/test_cli20_agents.py 23+++ git/neutronclient/tests/unit/test_cli20_agents.py
24@@ -25,7 +25,7 @@ class CLITestV20Agent(test_cli20.CLITestV20Base): 24@@ -25,7 +25,7 @@
25 def test_list_agents(self): 25 def test_list_agents(self):
26 contents = {'agents': [{'id': 'myname', 'agent_type': 'mytype', 26 contents = {'agents': [{'id': 'myname', 'agent_type': 'mytype',
27 'alive': True}]} 27 'alive': True}]}
@@ -30,7 +30,7 @@ index 1e75a92..ab01fb7 100644
30 resources = "agents" 30 resources = "agents"
31 31
32 cmd = agent.ListAgent(test_cli20.MyApp(sys.stdout), None) 32 cmd = agent.ListAgent(test_cli20.MyApp(sys.stdout), None)
33@@ -40,7 +40,7 @@ class CLITestV20Agent(test_cli20.CLITestV20Base): 33@@ -40,7 +40,7 @@
34 34
35 def test_list_agents_field(self): 35 def test_list_agents_field(self):
36 contents = {'agents': [{'alive': True}]} 36 contents = {'agents': [{'alive': True}]}
@@ -39,28 +39,25 @@ index 1e75a92..ab01fb7 100644
39 resources = "agents" 39 resources = "agents"
40 smile = ':-)' 40 smile = ':-)'
41 41
42diff --git a/neutronclient/tests/unit/test_cli20_network.py b/neutronclient/tests/unit/test_cli20_network.py 42Index: git/neutronclient/tests/unit/test_cli20_network.py
43index 5e9be2a..eb562d0 100644 43===================================================================
44--- a/neutronclient/tests/unit/test_cli20_network.py 44--- git.orig/neutronclient/tests/unit/test_cli20_network.py
45+++ b/neutronclient/tests/unit/test_cli20_network.py 45+++ git/neutronclient/tests/unit/test_cli20_network.py
46@@ -262,7 +262,7 @@ class CLITestV20NetworkJSON(test_cli20.CLITestV20Base): 46@@ -267,7 +267,7 @@
47 fields_1=['a', 'b'], fields_2=['c', 'd']) 47 fields_1=['a', 'b'], fields_2=['c', 'd'])
48 48
49 def _test_list_nets_columns(self, cmd, returned_body, 49 def _test_list_nets_columns(self, cmd, returned_body,
50- args=['-f', 'json']): 50- args=('-f', 'json')):
51+ args=['-f', 'csv']): 51+ args=('-f', 'csv')):
52 resources = 'networks' 52 resources = 'networks'
53 self.mox.StubOutWithMock(network.ListNetwork, "extend_list") 53 self.mox.StubOutWithMock(network.ListNetwork, "extend_list")
54 network.ListNetwork.extend_list(mox.IsA(list), mox.IgnoreArg()) 54 network.ListNetwork.extend_list(mox.IsA(list), mox.IgnoreArg())
55@@ -275,7 +275,7 @@ class CLITestV20NetworkJSON(test_cli20.CLITestV20Base): 55@@ -280,7 +280,7 @@
56 "tenant_id": "tenant_3", 56 "tenant_id": "tenant_3",
57 "subnets": []}]} 57 "subnets": []}]}
58 self._test_list_nets_columns(cmd, returned_body, 58 self._test_list_nets_columns(cmd, returned_body,
59- args=['-f', 'json', '-c', 'id']) 59- args=['-f', 'json', '-c', 'id'])
60+ args=['-f', 'csv', '-c', 'id']) 60+ args=['-f', 'csv', '-c', 'id'])
61 _str = self.fake_stdout.make_string() 61 _str = self.fake_stdout.make_string()
62 returned_networks = utils.loads(_str) 62 returned_networks = jsonutils.loads(_str)
63 self.assertEqual(1, len(returned_networks)) 63 self.assertEqual(1, len(returned_networks))
64--
651.9.3
66
diff --git a/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb b/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
index 1911fc3..b4e34e3 100644
--- a/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
@@ -24,8 +24,8 @@ SRC_URI = "git://github.com/openstack/python-neutronclient.git;branch=master \
24 file://neutronclient-use-csv-flag-instead-of-json.patch \ 24 file://neutronclient-use-csv-flag-instead-of-json.patch \
25 " 25 "
26 26
27PV="2.3.5+git${SRCPV}" 27PV="2.3.7+git${SRCPV}"
28SRCREV="bfec80a776a53b554a8f2d023d2974539edef3ce" 28SRCREV="1452193f935f5be0bb2f5f01b54bd4947d27331b"
29S = "${WORKDIR}/git" 29S = "${WORKDIR}/git"
30 30
31inherit setuptools 31inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-novaclient_git.bb b/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
index 70cb39e..e8f5aa3 100644
--- a/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-novaclient_git.bb
@@ -13,7 +13,7 @@ SRC_URI = "\
13 " 13 "
14 14
15PV="2.18.1+git${SRCPV}" 15PV="2.18.1+git${SRCPV}"
16SRCREV="b21d6775685fc2ca9bd5c13e817343789d7ad6c5" 16SRCREV="2a1c07e790cc95b1e847974e4c757f826507834f"
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19inherit setuptools 19inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-saharaclient_git.bb b/meta-openstack/recipes-devtools/python/python-saharaclient_git.bb
index 06d7583..6711c0e 100644
--- a/meta-openstack/recipes-devtools/python/python-saharaclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-saharaclient_git.bb
@@ -17,8 +17,8 @@ SRCNAME = "saharaclient"
17 17
18SRC_URI = "git://github.com/openstack/python-saharaclient.git;branch=master" 18SRC_URI = "git://github.com/openstack/python-saharaclient.git;branch=master"
19 19
20PV="0.7.0+git${SRCPV}" 20PV="0.7.2+git${SRCPV}"
21SRCREV="6531965b9719e4ea3a9986afa16daaf12fbba516" 21SRCREV="5be2179d8c5c1e806537849559bea52a1145028f"
22S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
23 23
24inherit setuptools 24inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb b/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb
index fe8cdae..03ed33f 100644
--- a/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb
@@ -9,8 +9,8 @@ SRCNAME = "swiftclient"
9 9
10SRC_URI = "git://github.com/openstack/python-swiftclient.git;branch=master" 10SRC_URI = "git://github.com/openstack/python-swiftclient.git;branch=master"
11 11
12PV="2.1.0+git${SRCPV}" 12PV="2.2.0+git${SRCPV}"
13SRCREV="4cc2201e21a68c61adc3ce572b979553b786fc0f" 13SRCREV="d13441d26244cc0947b85287d3fba298cb532c9a"
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16inherit setuptools python-dir 16inherit setuptools python-dir
diff --git a/meta-openstack/recipes-devtools/python/python-troveclient_git.bb b/meta-openstack/recipes-devtools/python/python-troveclient_git.bb
index 35f3320..28a649b 100644
--- a/meta-openstack/recipes-devtools/python/python-troveclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-troveclient_git.bb
@@ -10,8 +10,8 @@ SRC_URI = "\
10 git://github.com/openstack/python-troveclient.git;branch=master \ 10 git://github.com/openstack/python-troveclient.git;branch=master \
11 " 11 "
12 12
13PV="1.0.5+git${SRCPV}" 13PV="1.0.7+git${SRCPV}"
14SRCREV="248aa8fdf801ca73834606239d3cdb3610993815" 14SRCREV="e010a919750f07493afd42a4db867853b925bcbf"
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit setuptools 17inherit setuptools