summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/ruby/rest-client_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/rest-client_git.bb b/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
new file mode 100644
index 0000000..9d31e65
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
@@ -0,0 +1,30 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "A simple HTTP and REST client for Ruby"
5DESCRIPTION = "A simple HTTP and REST client for Ruby, inspired by the \
6Sinatra's microframework style of specifying actions: get, put, post, \
7delete."
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://README.rdoc;beginline=285;md5=f649e8be3b8f05776195b7aa04d974c6"
11
12PR = "r0"
13
14BPV = "1.6.7"
15PV = "${BPV}"
16SRCREV = "d96be9d1dc8b1b4c04d90a62244b87ded8d86f0c"
17
18S = "${WORKDIR}/git"
19
20SRC_URI = " \
21 git://github.com/rest-client/rest-client.git \
22 "
23
24inherit ruby
25
26RDEPENDS += " \
27 mime-types \
28 "
29
30BBCLASSEXTEND = "native"