summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
new file mode 100644
index 0000000..7c46b5a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
@@ -0,0 +1,33 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "A library for tunnelling connections to servers via a gateway"
5DESCRIPTION = "A library for programmatically tunnelling connections \
6to servers via a single “gateway” host. It is useful for establishing \
7Net::SSH connections to servers behind firewalls, but can also be used \
8to forward ports and establish connections of other types, like HTTP, \
9to servers with restricted access."
10
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6c99c0cc0901fbc3607fe997f9898d69"
13
14PR = "r0"
15
16BPV = "1.2.0"
17PV = "${BPV}"
18SRCREV = "1de7611a7f7cedbe7a4c6cf3798c88d00637582d"
19
20S = "${WORKDIR}/git"
21
22SRC_URI = " \
23 git://github.com/net-ssh/net-ssh-gateway.git \
24 file://gemspec-don-t-force-the-use-of-gem-private_key.pem.patch \
25 "
26
27inherit ruby
28
29RDEPENDS += " \
30 net-ssh \
31 "
32
33BBCLASSEXTEND = "native"