summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.9.bb')
-rw-r--r--meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.9.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.9.bb b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.9.bb
new file mode 100644
index 0000000..e2c99d7
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.9.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Modern concurrency tools including agents, futures, promises, thread pools, supervisors, and more. Inspired by Erlang, Clojure, Scala, Go, Java, JavaScript, and classic concurrency patterns."
2HOMEPAGE = "http://www.concurrent-ruby.com"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e319104fe1435b64fc0a67032db44f02"
6
7SRC_URI = "git://github.com/ruby-concurrency/concurrent-ruby.git;protocol=https;branch=master \
8 file://0001-Removed-check-for-concurrent_ruby.jar.patch \
9 "
10SRCREV = "52c08fca13cc3811673ea2f6fdb244a0e42e0ebe"
11
12S = "${WORKDIR}/git"
13
14do_install:append () {
15 rmdir --ignore-fail-on-non-empty ${D}${libdir}/ruby/gems/${RUBY_GEM_VERSION}/plugins
16}
17
18inherit ruby