summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby/bundler_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby/bundler_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/ruby/bundler_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/bundler_git.bb b/meta-openstack/recipes-devtools/ruby/bundler_git.bb
new file mode 100644
index 0000000..ca69f89
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/bundler_git.bb
@@ -0,0 +1,33 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Makes sure Ruby applications run the same code on every machine."
5DESCRIPTION = "Bundler makes sure Ruby applications run the same code \
6on every machine. It does this by managing the gems that the \
7application depends on. Given a list of gems, it can automatically \
8download and install those gems, as well as any other gems needed by \
9the gems that are listed. Before installing gems, it checks the \
10versions of every gem to make sure that they are compatible, and can \
11all be loaded at the same time. After the gems have been installed, \
12Bundler can help you update some or all of them when new versions \
13become available. Finally, it records the exact versions that have \
14been installed, so that others can install the exact same gems."
15
16LICENSE = "MIT"
17LIC_FILES_CHKSUM = "file://LICENSE.md;md5=196bb963e601609817d7e9ac9a64a867"
18
19PR = "r0"
20
21BPV = "1.6.2"
22PV = "${BPV}"
23SRCREV = "06e3647c117da210ffd15a174624497830addd7b"
24
25S = "${WORKDIR}/git"
26
27SRC_URI = " \
28 git://github.com/bundler/bundler.git \
29 "
30
31inherit ruby
32
33BBCLASSEXTEND = "native"