summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-tooz_2.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-tooz_2.7.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-tooz_2.7.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-tooz_2.7.1.bb b/meta-openstack/recipes-devtools/python/python3-tooz_2.7.1.bb
new file mode 100644
index 0000000..cc2824c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-tooz_2.7.1.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Coordination library for distributed systems."
2HOMEPAGE = "https://pypi.python.org/pypi/tooz"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI[md5sum] = "f8afa62d566f602d63050850d4873583"
8SRC_URI[sha256sum] = "bee07684b12e9fb06adbe6b1a5ddb60ef9e8dc20f5a2d46e667d8797028bcfe5"
9
10inherit setuptools3 pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 python3-pip \
16 python3-pbr \
17 "
18
19# Satisfy setup.py 'setup_requires'
20DEPENDS += " \
21 python3-pbr-native \
22 "
23
24# RDEPENDS_default:
25RDEPENDS_${PN} += " \
26 python3-pbr \
27 python3-stevedore \
28 python3-six \
29 python3-voluptuous \
30 python3-msgpack \
31 python3-fasteners \
32 python3-tenacity \
33 python3-futurist \
34 python3-oslo.utils \
35 python3-oslo.serialization \
36 "