summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-keystoneauth1_4.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-keystoneauth1_4.3.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-keystoneauth1_4.3.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-keystoneauth1_4.3.0.bb b/meta-openstack/recipes-devtools/python/python3-keystoneauth1_4.3.0.bb
new file mode 100644
index 0000000..972668c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-keystoneauth1_4.3.0.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Authentication Library for OpenStack Identity"
2HOMEPAGE = "https://pypi.python.org/pypi/keystoneauth1"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=96f840d59b245a1c817fbcb901afc574"
6
7SRC_URI[md5sum] = "455ff39860b21e924305f4db3d74e293"
8SRC_URI[sha256sum] = "e3fa55b58f082e4d753ae3fe599f3d74c591fd9cb8286879ff532a78955163f1"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 ${PYTHON_PN}-pbr \
14 "
15
16# Satisfy setup.py 'setup_requires'
17DEPENDS += " \
18 ${PYTHON_PN}-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 ${PYTHON_PN}-pbr \
23 ${PYTHON_PN}-iso8601 \
24 ${PYTHON_PN}-requests \
25 ${PYTHON_PN}-six \
26 ${PYTHON_PN}-stevedore \
27 "