summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-positional_1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-positional_1.1.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-positional_1.1.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-positional_1.1.1.bb b/meta-openstack/recipes-devtools/python/python-positional_1.1.1.bb
new file mode 100644
index 0000000..c2dc44c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-positional_1.1.1.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Library to enforce positional or key-word arguments"
2HOMEPAGE = "https://github.com/morganfainberg/positional"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=5335066555b14d832335aa4660d6c376"
6
7SRCNAME = "positional"
8SRC_URI = "https://pypi.io/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
9"
10
11SRC_URI[md5sum] = "c82903c32c1aec1ac0f0f6e166ef4e2e"
12SRC_URI[sha256sum] = "ef845fa46ee5a11564750aaa09dd7db059aaf39c44c901b37181e5ffa67034b0"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18CLEANBROKEN = "1"
19
20RDEPENDS_${PN} += " \
21 python-wrapt \
22" \ No newline at end of file